2009 G6 Bad gas smell - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 03-09-2012, 01:24 PM Thread Starter
Junior Member
 
Join Date: Mar 2012
Posts: 2
 
Unhappy 2009 G6 Bad gas smell

Hello, I've been having this problem for around 2 months now, on a G6 with around 44,500 miles on it, and as I looked into it I found several people with the same issue, so I thought I found my answer. My 2009 G6 fills the whole garage, with a very strong gas smell, and recently it takes just a little longer to turn over. No visible leaking. I'm getting the run around dealing with GM, and am getting soooo frustrated. Diagnostics check says I need a new fuel pump, which seems to relate to the problem I've seen in common where the hose that cracks is molded to the fuel pump, so they have to fix the entire module rather than just the hose, $830. But GM says the prior recall problems do not effect the '09 G6. Maybe it's no the exact same issue, but it sems odd that I have the exact same problem. Has anyone else had to deal with this with an '09? Also out of curiousity, is it reasonable to have an $850 fuel pump issue on a car that doesn't travel very far, sits mostly in the garage, and has only 44,500 miles on it? I'd really appreciate any responses.Thank you.
Lindsayg6 is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 03-09-2012, 08:02 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
For starters, I would encourage you not to park it in a closed garage until the fuel leak is fixed. Gas fumes are extremely flammable. Neither would I be driving it.

Has it thrown any codes or DIC messages?

It's sounds like it could be the fuel pump hose. The leaking gas tends to collect on top of the fuel tank & volatilize.

The pump itself retails in the $375+ neighborhood. IIRC, it is possible to stop the hose leak by using a coupler but the fuel tank still has to be dropped to access it.
greenman is offline  
post #3 of 11 (permalink) Old 03-10-2012, 03:46 AM
OOBER SUPER MEMBER
 
CruisinG6's Avatar
 
Join Date: Jul 2009
Location: Northern Illinois
Posts: 4,053
 
I have a 2009 and have not experienced any problems of this sort.

As greenman said... park it outside! Last thing you want is an explosion or fire.

I've heard of there being issues with the Evaporative emissions systems but it sounds like it's the hose on the fuel pump...
CruisinG6 is offline  
post #4 of 11 (permalink) Old 03-10-2012, 11:30 AM Thread Starter
Junior Member
 
Join Date: Mar 2012
Posts: 2
 
Thank you, yeah not driving it right now, but will definitely go park it outside first thing. Turns out they told me it's clogged and leaking out of the actual module, still seems like low miles for something like this to go wrong, especially knowing how this car is handled, but now the dealership is working with me and really helping out so I'm feeling much better.
Lindsayg6 is offline  
post #5 of 11 (permalink) Old 03-10-2012, 09:45 PM
OOBER SUPER MEMBER
 
CruisinG6's Avatar
 
Join Date: Jul 2009
Location: Northern Illinois
Posts: 4,053
 
Good to hear they're working with you, Hopefully the problem gets resolved and they don't try to rape you in the process.
CruisinG6 is offline  
post #6 of 11 (permalink) Old 03-11-2012, 09:02 AM
Senior Member
 
Join Date: Dec 2005
Posts: 606
 
5 yr 50K warranty

The fuel pump is covered on the G6 power train warranty. They dropped the pump coverage on the 2010 and later, I wonder why lol.
slls is offline  
post #7 of 11 (permalink) Old 03-11-2012, 01:29 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Quote:
Originally Posted by slls View Post
The fuel pump is covered on the G6 power train warranty. They dropped the pump coverage on the 2010 and later, I wonder why lol.
I thought that was the case but I went through the warranty booklet & searched online & I could not find it written in black & white anywhere (& I didn't trust my memory).
greenman is offline  
post #8 of 11 (permalink) Old 03-11-2012, 02:06 PM
OOBER SUPER MEMBER
 
CruisinG6's Avatar
 
Join Date: Jul 2009
Location: Northern Illinois
Posts: 4,053
 
Do you have onstar? If so you should be able to log into the OnStar Website and it'll give you your warranty coverage's. At least which warranties you have.

I was told that safety issues MUST be covered regardless of warranty status. If that's the case I would go and make a strong argument about how unsafe this is and try and get it repaired
CruisinG6 is offline  
post #9 of 11 (permalink) Old 03-12-2012, 10:40 AM
Senior Member
 
Join Date: Dec 2005
Posts: 606
 
Quote:
Originally Posted by greenman View Post
I thought that was the case but I went through the warranty booklet & searched online & I could not find it written in black & white anywhere (& I didn't trust my memory).
slls is offline  
post #10 of 11 (permalink) Old 03-12-2012, 11:50 AM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Quote:
Originally Posted by slls View Post
What is the source of that document? It is not from the "Pontiac Limited Warranty and Owner Assistance Information" booklet that I have. This is from my booklet:

Powertrain Coverage
The powertrain is covered for 5 years or 100,000 miles,
whichever comes first, except for other coverages
listed here under “What is Covered” and those items
listed under “What is Not Covered” later in this section.
Engine: Cylinder head, block, timing gears, timing
chain, timing cover, oil pump/oil pump housing,
OHC carriers, valve covers, oil pan, seals, gaskets,
turbocharger, supercharger and all internal lubricated
parts as well as manifolds, flywheel, water pump,
harmonic balancer and engine mount. Timing belts are
covered until the first scheduled maintenance interval.

Transmission/Transaxle/Transfer Case: Case,
all internal lubricated parts, torque converter, transfer
case, transmission/transaxle mounts, seals, and
gaskets.

Drive Systems: Final drive housing, all internal
lubricated parts, axle shafts and bearings, constant
velocity joints, axle housing, propeller shafts, universal
joints, wheel bearings, locking hubs, front differential
actuator, supports, front and rear hub bearings,
seals and gaskets.
greenman is offline  
post #11 of 11 (permalink) Old 03-12-2012, 02:10 PM
Senior Member
 
Join Date: Dec 2005
Posts: 606
 
warranty

Mine is for 2009 Pontiac Torrent/G6 limited warranty. Back cover # 20763645 A under bar code.
Everything is in there, 15 year and all.
slls is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
06 GTP- fuel smell kwiktsi Problems and Solutions 21 02-21-2016 07:11 AM
Fuel Smell rowehc Problems and Solutions 39 08-03-2013 10:15 PM
Dog Smell NickSixtyThree Automotive Cleaning and Detailing 3 07-28-2010 10:23 PM
New car smell! Ease New Member Introductions 6 11-07-2008 11:25 AM
new car smell hook2233 Automotive Cleaning and Detailing 13 01-03-2006 09:57 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome