Transmission not working and engine squilling - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-17-2017, 08:53 PM Thread Starter
Junior Member
 
Join Date: Mar 2017
Posts: 1
 
Transmission not working and engine squilling

2010 G6 with 110000 miles While driving normally the engine started to squill loudly and then the transmission no longer was engaged. Added transmission fluid but did not make a difference. Does not operate in any position of the transmission, reverse, drive, 1st or 2nd gear. Engine just makes a loud squill when running. Is this a sign that the transmission is finished or is there something else that could be the problem?
timmc32 is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Remote Start not working and CHECK ENGINE light on wllntr54 Problems and Solutions 8 08-25-2013 02:18 AM
Check engine light keeps turning on, no temp guage, and transmission issues. HELP! Joelabelle Problems and Solutions 6 02-20-2013 10:24 PM
Help! SES, check engine, gauges, transmission? ashley1683 Problems and Solutions 0 01-27-2012 10:49 AM
gas gauge not working.. check engine light.. jclawson Problems and Solutions 0 06-11-2011 02:30 AM
Check Engine Light and Remote Starter Stopped Working. links10 Problems and Solutions 2 01-04-2011 09:55 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome