High pitch whistle on acceleration - Pontiac G6 Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 65 (permalink) Old 08-23-2010, 01:35 PM Thread Starter
Junior Member
 
Talldarkhndsm37's Avatar
 
Join Date: Aug 2010
Location: New Jersey
Age: 43
Posts: 8
 
High pitch whistle on acceleration

I have a '07 G6 GT that I inherited from my 87 y/o grandfather when he past away in January. Yes, it's red because what other color would an 87 year old man drive. Within the last 2 months I've started noticing a high pitch whistle/noise when I accelerate. If I back off the throttle its goes away. I thought it was brakes at first but I get no noise when I brake at any speed. Only when I accelerate. Anyone have any thoughts? Haven't brought it in yet, want to see if its a minor fix I can do myself.

Thanks.

Mario
Talldarkhndsm37 is offline  
Sponsored Links
Advertisement
 
post #2 of 65 (permalink) Old 08-23-2010, 01:37 PM
Moderator
 
waterfowler76's Avatar
 
Join Date: May 2009
Location: Las Vegas
Posts: 3,657
 
Send a message via Yahoo to waterfowler76
ive heard about it....I'm pretty sure the problem is the flex pipe. Im sure someone else here knows more

2007 PONTIAC G6 GT

Waterfowler's 6
waterfowler76 is offline  
post #3 of 65 (permalink) Old 08-23-2010, 01:43 PM Thread Starter
Junior Member
 
Talldarkhndsm37's Avatar
 
Join Date: Aug 2010
Location: New Jersey
Age: 43
Posts: 8
 
Thanks. I'll keep an eye out for more replies.
Talldarkhndsm37 is offline  
post #4 of 65 (permalink) Old 08-23-2010, 02:44 PM
07 Black GT Vert ♥
 
TinIndian's Avatar
 
Join Date: Aug 2010
Location: The North Coast
Posts: 445
 
Quote:
Originally Posted by Talldarkhndsm37 View Post
I have a '07 G6 GT that I inherited from my 87 y/o grandfather when he past away in January. Yes, it's red because what other color would an 87 year old man drive. Within the last 2 months I've started noticing a high pitch whistle/noise when I accelerate. If I back off the throttle its goes away. I thought it was brakes at first but I get no noise when I brake at any speed. Only when I accelerate. Anyone have any thoughts? Haven't brought it in yet, want to see if its a minor fix I can do myself.

Thanks.

Mario
I've read the whistle is caused by a factory installed weep hole in the muffler that's designed to let water escape.

TinIndian is offline  
post #5 of 65 (permalink) Old 08-31-2010, 12:14 PM Thread Starter
Junior Member
 
Talldarkhndsm37's Avatar
 
Join Date: Aug 2010
Location: New Jersey
Age: 43
Posts: 8
 
Wasn't the weep hole. Turns out my idle pulley is bad and that stretched out the S belt. Oh yeah, both my front struts are leaking, at 25,500 miles.......................
Talldarkhndsm37 is offline  
post #6 of 65 (permalink) Old 08-31-2010, 12:41 PM
Senior Member
 
Daniel's Avatar
 
Join Date: Feb 2005
Location: Algonquin, Illinois
Age: 30
Posts: 916
 
EDITduring me typing this looks like you answered it LOL)

Ive had the whistle but its mostly from 1-2 when the rpm's get in the 3500-4000 range when shifting i thought it was the trans slipping or the serpentine belt.
Im leaning towards the serpentine but Ive had it forever since i picked up the car.
Also a couple people have changed the belt and the noise stopped. But i have yet to do that.
Daniel is offline  
post #7 of 65 (permalink) Old 08-31-2010, 02:49 PM
07 Black GT Vert ♥
 
TinIndian's Avatar
 
Join Date: Aug 2010
Location: The North Coast
Posts: 445
 
Quote:
Originally Posted by Talldarkhndsm37 View Post
Wasn't the weep hole. Turns out my idle pulley is bad and that stretched out the S belt. Oh yeah, both my front struts are leaking, at 25,500 miles.......................

TinIndian is offline  
post #8 of 65 (permalink) Old 09-08-2010, 12:23 PM
Junior Member
 
Join Date: Jan 2009
Posts: 9
 
I have the exact same issue with my '07 GT convertible. High pitched whistle at certain levels of acceleration.
The car is almost 4 years old (it was originally bought in Dec 2006) and 20K miles on the original serpentine belt. I guess I will try changing it this weekend and see if that resolves the problem. Dealer is a bit far away and would charge for the belt anyway.
If not the belt then I will look for the "weep hole".
I'll post back my results next week... I hope this is the answer.
RD
rdusel is offline  
post #9 of 65 (permalink) Old 09-22-2010, 11:55 AM
Pontiac lives thru us !!!
 
tjd24's Avatar
 
Join Date: Apr 2010
Location: NW NJ
Posts: 14
 
We've got a '07 G6 HTC as well and recently started experiencing a whistle or screeching noise when accelerating. We recently put on new rotors and pads so I first thought it was the brakes but then realize its only on acceleration.

I am taking in the G6 in on 9/22/10 to get the roof button replaced (pressing button would start retraction but stop after a few seconds which then required button to be re-pressed) - I've printed out this thread to show Dealer Service to have them check out my issue - I'll post results as well.

tjd24
2007 G6 HTC - wife's whip
2010 Camaro 2LT RS - my ride
tjd24 is offline  
post #10 of 65 (permalink) Old 09-22-2010, 12:58 PM
07 Black GT Vert ♥
 
TinIndian's Avatar
 
Join Date: Aug 2010
Location: The North Coast
Posts: 445
 
Quote:
Originally Posted by tjd24 View Post
We've got a '07 G6 HTC as well and recently started experiencing a whistle or screeching noise when accelerating. We recently put on new rotors and pads so I first thought it was the brakes but then realize its only on acceleration.

I am taking in the G6 in on 9/22/10 to get the roof button replaced (pressing button would start retraction but stop after a few seconds which then required button to be re-pressed) - I've printed out this thread to show Dealer Service to have them check out my issue - I'll post results as well.
Quote:
Originally Posted by TinIndian View Post
I've read the whistle is caused by a factory installed weep hole in the muffler that's designed to let water escape.
Quote:
Originally Posted by Talldarkhndsm37 View Post
Wasn't the weep hole. Turns out my idle pulley is bad and that stretched out the S belt. Oh yeah, both my front struts are leaking, at 25,500 miles.......................
Take your pick!

TinIndian is offline  
post #11 of 65 (permalink) Old 09-23-2010, 10:01 AM
Junior Member
 
Join Date: Jan 2009
Posts: 9
 
I just tried a new serpentine belt and new idler pulleys, no change at all so I guess I am going looking for a weep hole before I take it to the dealer.
I was surprised that the belt was not in stock anywhere, then I saw how long it is. I don't think I have ever seen one so long before..
Due to the dealer cancelling my after market warrantee ("oops it was a clerical error") I now have to wait 30 days for the coverage to take effect.
arrghh...
rdusel is offline  
post #12 of 65 (permalink) Old 09-23-2010, 10:48 AM
Decepticon Extraordinaire
 
Lampoon's Avatar
 
Join Date: Sep 2005
Location: The Alamo
Posts: 5,288
    
I need a new belt....coming up on 117,000 miles.

MODS:
Crab Intakes CAB, MPD Ram Air hood, Custom exhaust,
WAMS High Performance Tune and a whole lot more....

My Progession
Lampoon is offline  
post #13 of 65 (permalink) Old 09-23-2010, 01:06 PM
Junior Member
 
Join Date: Jan 2009
Posts: 9
 
Not too bad to change, invest a couple of minutes and remove the airbox, you will be glad you did.
And you will probably need a strong bar to move the motor mount back a hair to replace the spacer. You will see what I mean when you get there..
Rob
rdusel is offline  
post #14 of 65 (permalink) Old 09-24-2010, 09:53 AM
Senior Member
 
Join Date: Dec 2005
Posts: 606
 
The whistle on many G6 and Malibu has been the resonator.
slls is offline  
post #15 of 65 (permalink) Old 09-25-2010, 07:18 AM
Pontiac lives thru us !!!
 
tjd24's Avatar
 
Join Date: Apr 2010
Location: NW NJ
Posts: 14
 
Brought the G6 HTC in for service on Thursday 9/23 - Tech told Service Manager that on his test drive he heard the whistling/squeal - checked belts, PVC value as A-OK - had a Tech rev the car while on the jack and heard whistle through the exhaust system. Wasn't clear whether it was at the resonator or Cat - they indicated a replacement exhaust may correct but they said this is common with G6s.

At 27,000 miles it doesn't need a replacement cat-back so we'll just turn up the music...

tjd24
2007 G6 HTC - wife's whip
2010 Camaro 2LT RS - my ride
tjd24 is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
High Pitch Exhaust Whistle TheBigC G6 GXP Discussion 5 07-22-2011 04:00 PM
Hesitation on acceleration 08g6pa Problems and Solutions 6 08-23-2010 10:56 PM
High pitch noise at high RPM's. Please Help! BostonTaylor Problems and Solutions 3 06-25-2009 08:33 AM
Engine Whistle???? wilky2005GT Problems and Solutions 3 09-04-2008 02:01 PM
Sun roof whistle White Wolf Problems and Solutions 6 07-28-2005 08:48 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome