2006 G6 Headlight problem - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 03-21-2011, 05:50 PM Thread Starter
Member
 
Join Date: Oct 2010
Posts: 50
 
2006 G6 Headlight problem

Hi All,
Today I've developed a new problem: My passenger side headlight low beam bulb will not come on. Normally one would think replace the hedlight, but I also noticed the passenger side parking light does not work too. I checked the fuses under the hood, and noticed the #9 mini-fuse (passenger side low beam) was blown. I replaced it and it blew right away.

Wire short somewhere? Anyone else ever experience this little PITA?
Is it possible if the headlight blew on the passenger side it's creating a voltage draw and blowing the fuse everytime I try to replace the fuse?

Thanks,
Adam
NT1078 is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 03-21-2011, 06:05 PM
Senior Member
 
reverttheclown's Avatar
 
Join Date: May 2010
Location: Syracuse, NY
Age: 25
Posts: 911
 
Garage
take out the headlight housing check the wiring going to it...take out the low light bulb and see if its blown. probably going to be the only way to tell is to take it outta there

2006 Pontiac G6 V6 3500L
Crimson Red
reverttheclown is offline  
post #3 of 14 (permalink) Old 03-21-2011, 07:45 PM Thread Starter
Member
 
Join Date: Oct 2010
Posts: 50
 
Thanks for your quick, helpful reply. I will replace the bulb for good measure just in case it's gone sour.

I will report my findings.

Adam
NT1078 is offline  
post #4 of 14 (permalink) Old 03-22-2011, 05:58 PM Thread Starter
Member
 
Join Date: Oct 2010
Posts: 50
 
Okay,
I've changed both bulbs (parking light and low beam) and the problem persists. When I unplugged the head light harness, I counted 4 terminals, and the 5th one, the one sort of in the middle looked burned and corroded. Is there supposed to be 5 terminals where the headlight connects to the wiring harness?
NT1078 is offline  
post #5 of 14 (permalink) Old 03-22-2011, 06:25 PM
Moderator Member Thingy
 
Abyssul's Avatar
 
Join Date: Jun 2009
Location: Myrtle Beach, SC
Posts: 1,330
 
Send a message via AIM to Abyssul Send a message via MSN to Abyssul
Quote:
Originally Posted by NT1078 View Post
Okay,
I've changed both bulbs (parking light and low beam) and the problem persists. When I unplugged the head light harness, I counted 4 terminals, and the 5th one, the one sort of in the middle looked burned and corroded. Is there supposed to be 5 terminals where the headlight connects to the wiring harness?
Yes. Low beam, high beam, side marker, turn signal and ground.

2006 Pontiac G6 GT

Appearance Mods: AIT front bumper, Black Eagle Eye Halo Projectors with DDM Tuning 5000k HIDs 35w,
GT door decals, painted interior trim, red calipers, de-chromed window trim
Performance Mods: WAMS tune, CRABS, aftermarket sound system

Abyssul is offline  
post #6 of 14 (permalink) Old 03-23-2011, 09:38 AM Thread Starter
Member
 
Join Date: Oct 2010
Posts: 50
 
Got it! Thanks for your help, guys.
There should be five terminals in the main connection as stated above. One of my terminals rotted away for some reason. I cut the wire on each side of the connector and installed a butt type connector instead. Replaced the fuse and voila.

Thanks again!
Adam
NT1078 is offline  
post #7 of 14 (permalink) Old 04-02-2011, 04:44 PM
Since 1986.
 
Join Date: Mar 2009
Location: Bondurant, IA
Posts: 19
 
https://www-odi.nhtsa.dot.gov/ivoq/

Please go here and report it. I thought I had mine fixed with electrical parts cleaner to get rid of the corrosion and electrical grease to keep out the moisture. It didn't help as I believe the corrosion had already eaten away too much of the metal in the connectors. My right headlight connector is burned up and the left is so corroded it will not last long.

This is a safety issue that GM should fix, IMO.
dstryr is offline  
post #8 of 14 (permalink) Old 04-03-2011, 06:49 AM Thread Starter
Member
 
Join Date: Oct 2010
Posts: 50
 
Makes me wonder what other electrical problems will come our way if GM was so cheap to use crappy connectors for something as important as our headlights!

Adam

Last edited by NT1078; 04-05-2011 at 09:27 AM.
NT1078 is offline  
post #9 of 14 (permalink) Old 04-04-2011, 06:42 PM
Junior Member
 
Join Date: Apr 2011
Posts: 2
 
Funny, same thing happened to me today!!! Replaced the $17.00 bulb for nothing.... Will check those connections tomorrow!!! I noticed the orange parking lamp worked when turning on the blinker, but not with the headlights on...hmmm We'll see tomorrow! Glad this site is open!
Heyyeahso is offline  
post #10 of 14 (permalink) Old 04-05-2011, 09:29 AM Thread Starter
Member
 
Join Date: Oct 2010
Posts: 50
 
Quote:
Originally Posted by Heyyeahso View Post
Funny, same thing happened to me today!!! Replaced the $17.00 bulb for nothing.... Will check those connections tomorrow!!! I noticed the orange parking lamp worked when turning on the blinker, but not with the headlights on...hmmm We'll see tomorrow! Glad this site is open!
Yes, the turn signal will continue to blink at least but the parking light portion will not work. The high beam also worked on mine, but not the low beam when this was happening. Check the harness connection where the headlight connects into the main harness, it's a white connector IIRC. One of the terminals may be burned. Cutting on either side of the connection and installing the butt connector worked great for me. No problems since.

Adam
NT1078 is offline  
post #11 of 14 (permalink) Old 05-20-2011, 10:30 PM
Junior Member
 
coastiejoe's Avatar
 
Join Date: Dec 2010
Location: Chincoteague Island, VA
Age: 24
Posts: 18
 
Does anyone know where we can buy new connectors or is it just a dealer thing?

2007 GT Convertible: Black Eagle Eye's with 6K HID; Tinted Tails; Tinted windows; 18" ENKEI EKM3 Gunmetal Rims; LED Bulbs All Around; MPD Ram Air Hood; CRAB Option 3 & 4; GT-R Exhaust System
coastiejoe is offline  
post #12 of 14 (permalink) Old 05-21-2011, 01:55 PM
Senior Member
 
Join Date: Dec 2005
Posts: 606
 
Any auto parts store, just need to get the connector that fits the bulb.
slls is offline  
post #13 of 14 (permalink) Old 08-14-2011, 04:36 PM
g61
Junior Member
 
Join Date: Aug 2011
Posts: 10
 
Smile Headlight Problem

Hello every one got a 05 g6 base model got a problem with my headlight every now and then when i go over a bump my passenger side drl ligh cut in and out signal wrks fine high beam wrks fine but the low beam keeps cuttin in and out in the fuse box the low beam relay is braced with a piece of styrfoam friggin guy who sold it to me never told me about it if i take the styrfoam out both headlighs low beam won't wrk. Please help me.
g61 is offline  
post #14 of 14 (permalink) Old 08-15-2011, 06:15 AM
Junior Member
 
Join Date: Apr 2011
Posts: 2
 
Fixed

So I said "Screw it" and decided to just clip all of the wires and just get rid of the connector itself...Had it hard wired for the past few months with no problems! If my passenger side decides to act up, I'm doing the same for that side
Heyyeahso is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange Headlight Problem Blackpony04 Problems and Solutions 9 01-07-2011 09:04 AM
2006 G6 GT Starter/Ignition Problem JustinC7 Problems and Solutions 1 10-19-2010 11:21 PM
Headlight problem ski007jim Problems and Solutions 1 07-28-2010 05:30 PM
2006 G6 stereo display problem shavialex Problems and Solutions 0 07-21-2010 02:18 AM
Trunk Latch Problem - 2006-GTP jzank Problems and Solutions 0 03-28-2010 03:55 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome