wont start sometimes...please help [Archive] - Pontiac G6 Forum

: wont start sometimes...please help


mick102288
02-09-2012, 10:10 PM
I have a 2006 G6 V6. About 5 months ago I went out in the morning to go to work and the car didnt start. So I had it towed to the garage and had to put a new fuel pump in it. I got it back and it worked for acouple days. Then it did the same thing. So I took it back in and this time the fuel pump relay needed replaced. Got it back and it was fine. About two weeks later it did it again, and once again took it back to the shop. He couldnt find nothing wrong so he changed the relay again and also the fuel pump fuse. The next time it happened the mechanic told me that if I pull the fuel pump fuse out and put it back in it will start up. So after he told me that I was pulling the fuse once or twice a week, and it worked every time. Now about a month ago, the car started dying while driving it. When it does i have no gas at all but all other functions work. So I pull over, pop the trunk, pull the fuse, put the fuse back in, and it starts right up. After this started I called the machanic and he put another new fuel pump in because it is now a safety hazard. Its been about two weeks since the new fuel pump was put in, again, and it still has problems starting up. Luckly it hasnt died on the road yet. My mechanic has no idea what to do because he says he never saw anything like this before and I really do not want to take it to a gm dealer without hearing any input and suggestions from anyone. Oh and my air filter is new and I cleaned my air intake, I think thats what its called when you got to buy that spray and spray it into the hose from the air fitler to the engine. Sorry not real smart on the engine. Thanks

spartyg6
02-10-2012, 12:00 AM
I've had the same problem, I have figured out something that works for me. When my G6 wont start I'll wait a couple of seconds then I'll try again and give it a little gas and it always starts right up. I'm quite sure whats going on with yours though

waterfowler76
02-10-2012, 12:15 AM
Sparty. Your problem sounds like the common throttle body problem. It needs to be cleaned out. If you search around there is some info on it around here.

greenman
02-10-2012, 12:28 AM
Pardon my French, but that mechanic sounds like a total horse's patute. It doesn't sound like he could troubleshoot his way out of a paper bag. I would avoid him like a bad case of herpes.

Has the check engine lamp ever come on or has it ever popped a code? Always, always check for codes first. You can buy a basic code reader for twenty bucks.

First possibility that comes to mind is a bad fuse holder (for the fuel pump fuse) in the rear junction box. Especially after pulling & reinserting several times--GM junction boxes are pretty fragile. A bad fuse holder could be intermittently cutting off current to the fuel pump.

If you would describe the symptoms when it won't start in as much detail as possible I could be more help.

But I have to say, if you can't use a multimeter there isn't much you can do but just throw more parts at it. You need a real mechanic.