2006 G6 GTP and failed front speed sensor - Pontiac G6 Forum
Pontiac G6 Forum Pontiac G6 Forum

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions
Register Home Forums Active Topics Photo Gallery Garage Blogs Search Today's Posts Mark Forums Read Auto Escrow

G6OwnersClub.com is the premier Pontiac G6 Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
Old 03-17-2007, 10:02 PM   #1
northernbc26
Junior Member
 
Join Date: Mar 2007
Location: Northern BC
Posts: 1
Gallery: 0
northernbc26 is on a distinguished road
Unhappy 2006 G6 GTP and failed front speed sensor

I have a 2006 G6 GTP with 10,400km on it and had to have the right front hub assembly replaced as the speed sensor quirt working causing the Trac light off, stabilitrack light off and ABS light to illuminate.

My question/comment is: How many others have had to replace such sensors on their G6's?? I bought it in December (06) and have only had it during the winter months here in northern BC (3 months now). I am pretty frustrated with these stupid sensors as i had an Olds Alero prior and had 7 hub assemblies replaced for the same reason (speed sensor failure)....

I had a 1999 Cav Z24 prior to the Alero with abs and traction assist and not once did i have to replace anything like a speed sensor on that car (and you'd think being that it is an entry level a problem like this would most likely show up in a small car like that).

Just curious if anyone has any insight as to why or how these things fail....
northernbc26 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-18-2007, 08:12 PM   #2
Blackrider
Club Six Speeeeeed
 
Blackrider's Avatar
 
Join Date: Sep 2005
Location: Victoria B.C. Canada
Age: 29
Posts: 268
Gallery: 0
Blackrider is on a distinguished road
Send a message via MSN to Blackrider
Its the wheel sensor, not the speed sensor thats gone bad, the speed sensor is in the tranny.
__________________
Blackrider is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 06:11 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
© AutoGuide
Inactive Reminders By Icora Web Design