AC won't start in the morning - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 06-14-2011, 08:44 AM Thread Starter
Junior Member
 
Join Date: Jun 2011
Posts: 6
 
AC won't start in the morning

Pontiac G6, 2008 about 48,000. AC won't start in the morning. It takes about 5 to 10 minutes on the road. Once ON, works fine all day. Next day, same problem. Sometimes I get it to about 4000 RPM for about 10 seconds, and the AC comes ON. Took it to the GM delearship, they can't find any problem, freon level is OK, and the AC works all day. next day, same problem. Any idea?
bissotoe is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 06-14-2011, 08:50 AM
Moderator
 
waterfowler76's Avatar
 
Join Date: May 2009
Location: Las Vegas
Posts: 4,044
 
Send a message via Yahoo to waterfowler76
do you mean that it blows out warm air for the first ten minutes or you turn it on and nothing happens?

2007 PONTIAC G6 GT

Waterfowler's 6 <---- Check out my 6
waterfowler76 is offline  
post #3 of 12 (permalink) Old 06-14-2011, 09:12 AM Thread Starter
Junior Member
 
Join Date: Jun 2011
Posts: 6
 
blows warn air, I turn ON/OFF the AC switch, nothing, just warn air (outside temp), then all of the sudden, Plop! the AC comes ON...
bissotoe is offline  
Sponsored Links
Advertisement
 
post #4 of 12 (permalink) Old 06-14-2011, 11:06 AM
Lifetime Member
 
geewhiz's Avatar
 
Join Date: May 2008
Posts: 3,269
 
Quote:
Originally Posted by bissotoe View Post
Pontiac G6, 2008 about 48,000. AC won't start in the morning. It takes about 5 to 10 minutes on the road. Once ON, works fine all day. Next day, same problem. Sometimes I get it to about 4000 RPM for about 10 seconds, and the AC comes ON. Took it to the GM delearship, they can't find any problem, freon level is OK, and the AC works all day. next day, same problem. Any idea?
Are your mornings cool? My first (gut) guess is the relay.



I'm going off of your post for my little rant ;
How often do folks take their autos to the dealership to have them say, "We can't find the problem"? (I love hassling dealerships with word play.) You could have smiled and reminded them the problem is "the A/C doesn't work" and that they must not be capable of fixing it, hell, you told them the problem!
Then ask them to refer you to a capable service center. You may not get any better help from them but you may have saved the next guy from having to listen to a line of bullshit.



geewhiz is offline  
post #5 of 12 (permalink) Old 06-14-2011, 12:31 PM Thread Starter
Junior Member
 
Join Date: Jun 2011
Posts: 6
 
well, it is Texas and it is Summer, so we start the mornings around 75 F or so. However, this might be a good starting point. It is not expensive to replace that relay so I will try that today. Specially, since GM dealership already checked the level of freon and the pressure. Everything works fine after the first "click" in the morning. I will post my results later. Thank you for the suggestion.
bissotoe is offline  
post #6 of 12 (permalink) Old 06-14-2011, 01:55 PM
Lifetime Member
 
geewhiz's Avatar
 
Join Date: May 2008
Posts: 3,269
 
Quote:
Originally Posted by bissotoe View Post
well, it is Texas and it is Summer, so we start the mornings around 75 F or so. However, this might be a good starting point. It is not expensive to replace that relay so I will try that today. Specially, since GM dealership already checked the level of freon and the pressure. Everything works fine after the first "click" in the morning. I will post my results later. Thank you for the suggestion.
Good luck!



geewhiz is offline  
post #7 of 12 (permalink) Old 06-20-2011, 12:07 PM Thread Starter
Junior Member
 
Join Date: Jun 2011
Posts: 6
 
well, replaced the AC clutch/relay, no luck, same problem. It is very difficult to figure out, the AC doesn't work on the first start in the morning, it takes about 5 to 10 minutes to click. Texas wheather to start in the morning is about 80 degrees F. Once the AC is on the first time, I never have the same problem during the day, until next day. Now, in the morning, both fans are OFF on start, I am wonder if there is a sensor that is telling the AC not to come up because the fan is not ON, but that is normal for any car, at the beginning, the main fan and the secondary fan are not ON to start, unless the car is very hot. However, my other car, when I start with the AC ON, the auxiliary fan comes ON immediatelly. I am lost. Any other ideas are very welcomed.
bissotoe is offline  
post #8 of 12 (permalink) Old 06-20-2011, 06:07 PM
Courtney :]
 
G6V606GT's Avatar
 
Join Date: Sep 2010
Location: Alabama
Age: 29
Posts: 179
 
My old car (2002 chevy cavalier) did the same thing and it was the temperature gage, seems weird but the "cooling fans" that cooled the engine had control -some how- of the "ac fan" and the cooling fan wasnt registering that it was the right temperature to cool the car which in turn wouldnt associate the air conditioning fan...Seems weird but its just a thought?!

2006 3.5L GT Coupe
Mods: Fully Custom Catback w/ Stainless Steel Piping & Flowmaster 80 series 1 in 2 out , CRAB Intake, Blue Calipers, Blue Spark Plug Wires, EE Headlights, White LED Dome, Map, and License Plate Lights, Black Badge Overlays
G6V606GT is offline  
post #9 of 12 (permalink) Old 07-10-2011, 01:19 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Quote:
Originally Posted by bissotoe View Post
Pontiac G6, 2008 about 48,000. AC won't start in the morning. It takes about 5 to 10 minutes on the road. Once ON, works fine all day. Next day, same problem. Sometimes I get it to about 4000 RPM for about 10 seconds, and the AC comes ON. Took it to the GM delearship, they can't find any problem, freon level is OK, and the AC works all day. next day, same problem. Any idea?
Have you resolved this issue?



greenman is offline  
post #10 of 12 (permalink) Old 07-10-2011, 10:55 PM Thread Starter
Junior Member
 
Join Date: Jun 2011
Posts: 6
 
Nop, still have the problem. I just spoke with GM again last week, they were OK and agreed to take a look to the problem, since the car is out of warranty, but depending on the resolution they may or may not pay. I just want the problem fixed, so I left the car on the dealership this weekend, they will work on the issue this week, and we will see if they can fix it or not.
bissotoe is offline  
post #11 of 12 (permalink) Old 07-11-2011, 11:41 AM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Quote:
Originally Posted by bissotoe View Post
Nop, still have the problem. I just spoke with GM again last week, they were OK and agreed to take a look to the problem, since the car is out of warranty, but depending on the resolution they may or may not pay. I just want the problem fixed, so I left the car on the dealership this weekend, they will work on the issue this week, and we will see if they can fix it or not.
I would be very interested to hear what they found.



greenman is offline  
post #12 of 12 (permalink) Old 07-15-2011, 02:26 PM Thread Starter
Junior Member
 
Join Date: Jun 2011
Posts: 6
 
My G6 AC is working again. After two days at the dealership, they fond out that ther is a problem with a "internal valve" on the AC compressor. The delearship replaced the AC compressor and GM was nice enough not to charge. The car has 48,000 and about three (3) years old but out of warranty. This is the second time the delearship replaced the AC unit in less than 48,000 miles. I hope it last another 30,000, at least.
bissotoe is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
need help, won't start mygtp Problems and Solutions 11 06-03-2018 01:02 AM
Lampoon, were you on US-190/281 this morning? DBWatkins Off-Topics 1 07-07-2010 08:58 AM
So I broke my Onstar antenna this morning...... Earl Flynn Problems and Solutions 4 02-14-2010 04:56 PM
Car won't start! brandon27ms Problems and Solutions 2 02-28-2009 06:01 PM
Hi,good morning. kwlx2008 New Member Introductions 2 11-05-2008 11:37 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome