Sluggish Acceleration When Pressing the Gas Help!! - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 07-05-2011, 04:25 PM Thread Starter
Junior Member
 
Join Date: Jul 2011
Posts: 3
 
Sluggish Acceleration When Pressing the Gas Help!!

I have a Pontiac G6 2008 4cyl and I just recently started having an issue with the car not accelerating like it use to. The CEL came on and indicated a P0420 code so the first thing I checked was my O2 sensors and ended up changing out the up-stream sensor, the downsteam was fine. I reset the code in the car and the CEL went off for about a day, but there was little improvement to my car. The next day the CEL came back on and the car seemed like it was worse. Took it to get the CEL code checked and the same P0420 code came up and the person told me it may be my catalytic converter. Since the catalytic converter is covered under warranty for 8 years or 80K miles I took it to the GM dealership and they said they couldn't figure out what was wrong with the car. He said everytime a code came up and he checked it the code would immediately clear itself out...basically it was misfiring. He said they hit the catalytic converter to see if there were any loose pieces or to see if they heard a hollow sound that would indicate it was clogged and they didn't get any indication that anything was wrong with the converter. I dont loose any gas mileage and i dont have a wet floor or the rotten egg smell that I have seen alot of people say they have had when theirs went bad. The dealership told me that since I have an after market alarm system (viper) I need to completely remove that and see if the problem is fixed. He said since the alarm system is hard wired into my cars computer it could be causing mis fires. Is there anyone who has had problems with their G6 like this or any insight on what the problem may be? This is starting to get expensive and it sucks that the dealership cant even figure out whats wrong but has no problem charging me and telling me they dont know whats going on!!!
camillianeyez02 is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 07-05-2011, 04:36 PM
Moderator
 
waterfowler76's Avatar
 
Join Date: May 2009
Location: Las Vegas
Posts: 4,038
 
Send a message via Yahoo to waterfowler76
I'd say it's the cat. I was running with a p0430 (bank 2) code for a while. I'd clear it and it would come back. I switched around 02 sensors and it still came back. Finally I got a new cat and problem solved. Hasn't come back yet.

2007 PONTIAC G6 GT

Waterfowler's 6 <---- Check out my 6
waterfowler76 is offline  
post #3 of 11 (permalink) Old 07-05-2011, 07:17 PM
Da.v3
 
Dav3's Avatar
 
Join Date: Oct 2010
Location: Winnipeg, Manitoba, Canada
Age: 32
Posts: 597
 
you drive a 6 base model with 4cyl...its supposed to be like that

Black 06 GTP Coupe

Performance: Full CRABs | RacingLine street MMIs + STB

Appearance: Tint - 35%r, 45%f | Tinted Alteza Tails | Black Halo Proj Eagle Eye Headlights |5000k HIDS in low and fogs w/ 100w hal in high | Red Leds under dash and behind grilles | White LED Interior Bulbs + Trunk, Plate | Bebadged w/ black overlays
Dav3 is offline  
Sponsored Links
Advertisement
 
post #4 of 11 (permalink) Old 07-05-2011, 10:10 PM Thread Starter
Junior Member
 
Join Date: Jul 2011
Posts: 3
 
My car was never like this before! i know I have the basic model but its sluggish to the point where its stalls when i press the gas and takes 15 secs to even gain a little speed. Then as soon as I have to stop it repeats the same problem. im pretty sure its the catalytic converter but i was wondering if anyone else heard of aftermarket alarms short circuiting the g6 computer and causing misfires??
camillianeyez02 is offline  
post #5 of 11 (permalink) Old 07-06-2011, 12:08 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Quote:
Originally Posted by camillianeyez02 View Post
I have a Pontiac G6 2008 4cyl and I just recently started having an issue with the car not accelerating like it use to. The CEL came on and indicated a P0420 code so the first thing I checked was my O2 sensors and ended up changing out the up-stream sensor, the downsteam was fine. I reset the code in the car and the CEL went off for about a day, but there was little improvement to my car. The next day the CEL came back on and the car seemed like it was worse. Took it to get the CEL code checked and the same P0420 code came up and the person told me it may be my catalytic converter. Since the catalytic converter is covered under warranty for 8 years or 80K miles I took it to the GM dealership and they said they couldn't figure out what was wrong with the car. He said everytime a code came up and he checked it the code would immediately clear itself out...basically it was misfiring. He said they hit the catalytic converter to see if there were any loose pieces or to see if they heard a hollow sound that would indicate it was clogged and they didn't get any indication that anything was wrong with the converter. I dont loose any gas mileage and i dont have a wet floor or the rotten egg smell that I have seen alot of people say they have had when theirs went bad. The dealership told me that since I have an after market alarm system (viper) I need to completely remove that and see if the problem is fixed. He said since the alarm system is hard wired into my cars computer it could be causing mis fires. Is there anyone who has had problems with their G6 like this or any insight on what the problem may be? This is starting to get expensive and it sucks that the dealership cant even figure out whats wrong but has no problem charging me and telling me they dont know whats going on!!!
Mileage? The 420 is almost always the bank 1 cat (I've learned to avoid absolutes). The question is has is worn out or been destoyed by running with a rich fuel trim due to another issue. No other DTC's? How do you know it's misfiring?
From your paragraph I got the feeling that dealer is not interested in fulfilling the emissions warranty. Maybe he wants to wait you out. You may need to try another dealer or take it up with GM corporate.




Last edited by greenman; 07-06-2011 at 12:41 PM.
greenman is offline  
post #6 of 11 (permalink) Old 07-06-2011, 12:37 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Quote:
Originally Posted by camillianeyez02 View Post
...I took it to the GM dealership and they said they couldn't figure out what was wrong with the car. He said everytime a code came up and he checked it the code would immediately clear itself out...basically it was misfiring...
That is total bulls++t. DTC's dont come & go on a lark. It requires a number of driving cycles without the original conditions that set the code. The number depends entirely on which code is set. You're being played for a fool. Unfortunately, because you have that aftermarket alarm, he has a perfect get out of jail free card to play.
One more thing: tapping on a cat is not a way to test if its bad (unless its really been totally destroyed).



greenman is offline  
post #7 of 11 (permalink) Old 07-06-2011, 10:35 PM Thread Starter
Junior Member
 
Join Date: Jul 2011
Posts: 3
 
Yeah, Im taking it to my dealership now. I didnt want to at first cause my car was so bad i didnt want to make the drive because of the way the car is acting but its the only dealership i will trust at the moment. Yeah the guy at the first dealership was full of crap, i have never heard of codes coming up and then clearing themselves and my alarm system is way to expensive to take off and there is absolutely no guarentee it will fix the problem. I told my dealership straight up that the better take the catalytic converter off and look at it or im not paying for anything reguarding service, if its not the converter im ok for paying the 65 dollar charge but they better not give me the same bs the first dealership did and say the need to have a code show up or they dont know whats wrong. We will see how it goes cause im about ready to just get rid of this car and get something else but this is the only prob the car has had its just dealing with the dealerships that is upsetting me. Thank you all for your input:-)
camillianeyez02 is offline  
post #8 of 11 (permalink) Old 07-06-2011, 10:45 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Since you haven't stated the mileage all I can assume is that its under 80K. That cat did not die of old age. More than likely an overly-rich fuel trim destoyed it. Unburned hydrocarbon fuel hits the very hot cat & creates a fire which overheats the catalyst literally incinerating it. One thing that allows unburned fuel into the cat is a misfiring cylinder. A cylinder that does not fire forces unburned fuel into the exhaust. In other words, the bad cat is a symptom of something else (that may have been repaired already-I have no way of knowing).




Last edited by greenman; 07-06-2011 at 11:22 PM.
greenman is offline  
post #9 of 11 (permalink) Old 07-07-2011, 02:38 PM
Member
 
thedrizzle52's Avatar
 
Join Date: May 2011
Posts: 88
 
my car gets seriously! and i mean seriously! hot underneath to the point i cant stand next to the car in shorts...could this be cat related? i also get a check engine light shortly after starting the car cold half way to its heated position at 225 ....any ideas?
thedrizzle52 is offline  
post #10 of 11 (permalink) Old 07-07-2011, 02:45 PM
Moderator
 
waterfowler76's Avatar
 
Join Date: May 2009
Location: Las Vegas
Posts: 4,038
 
Send a message via Yahoo to waterfowler76
^ Get the check engine light checked out so you know where to start. most auto parts stores will scan it for free.

2007 PONTIAC G6 GT

Waterfowler's 6 <---- Check out my 6
waterfowler76 is offline  
post #11 of 11 (permalink) Old 07-07-2011, 03:05 PM
Member
 
thedrizzle52's Avatar
 
Join Date: May 2011
Posts: 88
 
Quote:
Originally Posted by waterfowler76 View Post
^ Get the check engine light checked out so you know where to start. most auto parts stores will scan it for free.
i did, they told me it was a cylinder 3 misfire. they then replaced wires and plugs..a few filters bunch of small shit...none of it got rid of the check engine light flashing...so they informed me the only thing it could be is (and i believe this is what the called it...but i do know for sure it was a coil they mentioned) they called it the engine coil and that if i didnt replace it my engine would eventually melt. they told me this part would be 1500...

i never replaced it...i still get the check engine light every now and then.
but my engine hasnt melted yet
thedrizzle52 is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Pressing The Button To Put The Top Back. 07_GT_3.9L Problems and Solutions 6 09-09-2010 09:39 AM
Slow Sluggish Acceleration and sticking in gear showroomdetail Problems and Solutions 2 11-06-2009 07:54 PM
SOMETIMES 2006 G6 won't start unless pressing on the gas Shannah123 Problems and Solutions 7 06-22-2009 05:31 PM
Rattle when pressing gas pedal... haveinmind Problems and Solutions 3 06-01-2009 09:13 AM
delay when pressing the accelerator! pzwestside Problems and Solutions 6 04-22-2009 01:22 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome