Bearing hub or ABS sensor? - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 07-17-2011, 08:14 PM Thread Starter
Junior Member
 
Join Date: Jul 2011
Posts: 9
 
Red face Bearing hub or ABS sensor?

I hit a pretty gnarly bump the other day (read neglected to crawl over a construcion dip over train tracks) and now my ABS light as well as my traction control lights are on. I am just wondering if my bearing hub is shot or if my abs sensor has gone. I had the car in the air this afternoon and all sensor plugs and wiring harnesses appear intact so I am looking for some helpful advice. I am getting a minor hum from the front end but not quite as bad as my Malibu was when it's bearings went out. Any input would be greatly appreciated
Hyperzong is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 07-18-2011, 09:21 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Quote:
Originally Posted by Hyperzong View Post
I hit a pretty gnarly bump the other day (read neglected to crawl over a construcion dip over train tracks) and now my ABS light as well as my traction control lights are on. I am just wondering if my bearing hub is shot or if my abs sensor has gone. I had the car in the air this afternoon and all sensor plugs and wiring harnesses appear intact so I am looking for some helpful advice. I am getting a minor hum from the front end but not quite as bad as my Malibu was when it's bearings went out. Any input would be greatly appreciated
Unless you can read the GM ABS codes yourself you'll need to take it in & have them read.



greenman is offline  
post #3 of 4 (permalink) Old 07-19-2011, 11:17 AM Thread Starter
Junior Member
 
Join Date: Jul 2011
Posts: 9
 
We had her hooked up to a code reader and it was saying nothing was wrong. It's possible that the cheap universal my buddy has just wasn't picking it up though. I've ordered a set of moog hubs to replace both fronts so see if that's the problem
Hyperzong is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 07-19-2011, 11:30 AM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Quote:
Originally Posted by Hyperzong View Post
We had her hooked up to a code reader and it was saying nothing was wrong. It's possible that the cheap universal my buddy has just wasn't picking it up though. I've ordered a set of moog hubs to replace both fronts so see if that's the problem

GM ABS codes are not read by most scan tools. Actually there are only a few consumer scan tools that will. I use ScanXL with the enhanced GM package on a laptop. Around $220, IIRC, but it has paid for itself many times over. Without getting the codes all you can do is throw parts at it.




Last edited by greenman; 08-16-2011 at 05:00 PM.
greenman is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Hub assembly/ bearing problems? FirexWhenxReady General Maintenance 14 06-19-2013 12:07 PM
how to replace your front bearing clisto HOW-TO 10 03-24-2012 11:01 AM
Wheel Bearing or Hub? AGP5000 Problems and Solutions 7 01-15-2011 04:04 AM
Wheel Bearing kcsov6 Problems and Solutions 1 04-05-2010 03:50 AM
Wheel Bearing CP3 General Maintenance 0 06-01-2009 09:58 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome