Horn won't work, relay doesn't click. - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 08-29-2011, 09:32 PM Thread Starter
Junior Member
 
Join Date: Aug 2011
Location: NB, Canada
Age: 33
Posts: 2
 
Horn won't work, relay doesn't click.

Hey everyone, Just traded a jeep for a 2005 3.5L G6 last week, I didn't think to check the horn when I test drove it and I got it back and of course the horn doesn't work. There is no relay clicking sound when I hit the horn button. I checked the relay by switching it with the fog light relay and it seemed to work normally. So I'm guessing it's an issue with the switch somewhere.

I had the steering wheel off and looked at the connections and everything seemed normal. I didn't to any extensive testing though. I'm not all that great with electrical work so I didn't want to do much to it.

Basically I'm just wondering how I can check the connections at the horn switch and how I can check the horns/horns themselves. The horns were full of water when I pulled them off the car. They are currently not installed on the car cuz I took them off so it would be easier to get to the connections.

Any help would be appreciated, Thanks in advance.
ajguptill is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 08-29-2011, 10:44 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
greenman is offline  
post #3 of 5 (permalink) Old 08-30-2011, 10:34 PM Thread Starter
Junior Member
 
Join Date: Aug 2011
Location: NB, Canada
Age: 33
Posts: 2
 
Wow, I looked the fuse box over and over and never saw the actual horn fuze, I figured there was just the relay which seemed kinda odd but I got it now, it was the fuse. Silly me. Anyway, thanks for the reply.
ajguptill is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 08-30-2011, 11:38 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
That was easy.

Of course, a blown fuse is usually just a symptom of a problem.




Last edited by greenman; 08-30-2011 at 11:42 PM.
greenman is offline  
post #5 of 5 (permalink) Old 04-22-2013, 12:58 AM
Junior Member
 
Join Date: Feb 2011
Location: Northern Virginia
Posts: 10
 
Fuse Not Blown and Relay Clicking??

So today I noticed that my horn isn't working?? Checked the fuse and it was fine. I can also hear the realy clicking when I try and use it? Any ideas??
DrewAyres is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel pump relay issues Rvega Problems and Solutions 17 10-10-2018 09:41 PM
Fuse Box/Relay Issues sjmm20 Problems and Solutions 8 10-06-2011 03:31 PM
hids with relay ???'s Jstn2661 Appearance Modifications and Lighting 10 01-22-2011 01:54 PM
New horn / air horn / LOUD horn / after market horn Dav3 G6 Buyer's Guide/General Information 7 01-19-2011 06:51 PM
Relay Kits? herter92 Problems and Solutions 2 12-06-2010 01:54 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome