90k 3.5 '07 wont stop wining and acceleration loss..help! - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 10-22-2011, 02:47 PM Thread Starter
Member
 
thedrizzle52's Avatar
 
Join Date: May 2011
Posts: 88
 
90k 3.5 '07 wont stop wining and acceleration loss..help!

Ok so i have a 2007 sedan 3.5 v6 with 90k and it has been a fairly dependable car thus far with a few minor problems over the last four years.

the problem im currently encountering is what seems to be a power steering wining noise. Even with relatively decent weather it seems to be making this noise when turning or reversing. I expected it was the power steering just needing a flush so i had the power steering pump flushed and leak checked. replaced power steering fluid. This was about two months ago...during the summer. Now im having the same issues again, reservoir is still full so i threw some leak stop in. Still having the issue...constantly.

on top of that im also noticing a serious horsepower loss. I do like to drive fast at certain times and so every now and then i will floor it... It used to be that i would get the split second lag from the electric throttle and then the engine would kick and i would scream through the first two gears, at that point losing a little horsepower in third gear but nothing too bad.

Now im having a serious lag between the time i mash the pedal and when the gear actually kicks. to top that even when the gear does kick im getting a very serious lag in acceleration...it just seems so sluggish and to be frank...slow.

im hoping this isn't all building up to a bad head gasket but thats what it seems to be leading to...any ideas on how to stop the noise from the power steering pump...if thats what it even is...and also any recommendations on how to recover my lost acceleration between the accelerator and the transmission responding?
thedrizzle52 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 10-24-2011, 04:11 PM
Member
 
Stridex's Avatar
 
Join Date: Jun 2010
Posts: 87
 
Check your air filter for the lagged response? And mine has always whined when i turn it sharp, a few buddies of mine also have 6's and theres does the same thing.

2008 G6 Gxp Street Edition

Mods:Interior LED Neon Lighting, Debadged, 20% Tint, Flowmaster 40 Series Exhaust, Res delete, Alteza black housing taillights, Spyder black housing headlights, CRAB O3 CAI, Airraid Throttle Body Spacer, Racingline Strut bar, 91 OCT WAMS Tune.

Audio:400.1 Kicker amp, 12" Kicker CVR Ported Box
Stridex is offline  
post #3 of 8 (permalink) Old 10-25-2011, 12:49 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Quote:
Originally Posted by thedrizzle52 View Post
and also any recommendations on how to recover my lost acceleration between the accelerator and the transmission responding?
Given 90K I'd recommend an exhaust back pressure test to check for clogged cats.



greenman is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 10-30-2011, 01:14 PM
Junior Member
 
Join Date: Oct 2011
Posts: 1
 
I have an 2007 g6 gtp model, this has been a good car with no problems except with cold starts. My engine or heat riser valve wine for a few seconds. As temperature get colder the wining last a little longer. Has anyone encountered this problem?
jbrown4631 is offline  
post #5 of 8 (permalink) Old 10-30-2011, 03:59 PM
Senior Member
 
jts08g6's Avatar
 
Join Date: Jun 2011
Location: O'Fallon IL
Posts: 556
 
I had this problem in my old nissan and it was actually a bad belt.

JT

The "Upgrades"
Alienationz Eyelids: LEDs in the map, dome, trunk, and license plate: Racingline STB bar: 5% window tint all around and a windshield brow


The To-Do List
6000k HIDS: EE Halos: Tinted Tails: Exhaust: Rims: CAI: New Headunit: Lowering: Color Change
jts08g6 is offline  
post #6 of 8 (permalink) Old 11-01-2011, 07:38 PM Thread Starter
Member
 
thedrizzle52's Avatar
 
Join Date: May 2011
Posts: 88
 
thanks for all the response...i think i might check the cat cuz i know every now and then i also get the check gas cap message that requires me to pull over and pop my gas cap and all this pressure releases also ill run through gas quickly, and im already only getting about 16.5 on the highway
thedrizzle52 is offline  
post #7 of 8 (permalink) Old 11-01-2011, 08:38 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Quote:
Originally Posted by thedrizzle52 View Post
thanks for all the response...i think i might check the cat cuz i know every now and then i also get the check gas cap message that requires me to pull over and pop my gas cap and all this pressure releases also ill run through gas quickly, and im already only getting about 16.5 on the highway
Sounds like you have more than one problem. The check gas cap message means the sealed fuel system is failing the large fuel vapor leak test. But that has no effect whatsoever on your engine performance. It usually means you are venting some fuel fumes but not necessarily enough to even detect by smell. The reason you experience a pressure release on removing the gas cap is because the system is pressurized up to perform the test. It has to be able to maintain pressure for x period of time & yours is failing occasionally. A new cap might correct that issue but it could be a leak anywhere in that system. A smoke test is the best way to locate a leak. Since your issue is so intermittent, you could just ignore it for now & see if it gets worse & pops a code.

A cat can get pretty clogged up without popping a code & it will definitely cause acceleration issues.

Checked it for codes lately?



greenman is offline  
post #8 of 8 (permalink) Old 11-11-2011, 12:46 PM Thread Starter
Member
 
thedrizzle52's Avatar
 
Join Date: May 2011
Posts: 88
 
Quote:
Originally Posted by greenman View Post
Sounds like you have more than one problem. The check gas cap message means the sealed fuel system is failing the large fuel vapor leak test. But that has no effect whatsoever on your engine performance. It usually means you are venting some fuel fumes but not necessarily enough to even detect by smell. The reason you experience a pressure release on removing the gas cap is because the system is pressurized up to perform the test. It has to be able to maintain pressure for x period of time & yours is failing occasionally. A new cap might correct that issue but it could be a leak anywhere in that system. A smoke test is the best way to locate a leak. Since your issue is so intermittent, you could just ignore it for now & see if it gets worse & pops a code.

A cat can get pretty clogged up without popping a code & it will definitely cause acceleration issues.

Checked it for codes lately?
not as of recently when i experienced this problem the first time a few years back i had the codes run and they said the flashing check engine light i would get shortly after start up when the temp gauge was still trying to get to 215 was result of a cylinder 3 miss fire, the shop guy said it was caused by an ignition coil? all of this made no sense to me
thedrizzle52 is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Acceleration Hesitation or Jerking accelerating from a stop. ConvertibleGT67 Problems and Solutions 9 10-11-2012 12:02 PM
08 G6 loss of power Srgslaughterav Problems and Solutions 16 04-20-2011 10:46 PM
loss of control/steering jmada10 Steering Lockup Issues & Discussion 4 12-03-2005 06:59 AM
Hypothetical: Power Steering Loss ragingfish Steering Lockup Issues & Discussion 25 11-03-2005 09:03 PM
Does Replaceing the radio = loss of programable features lrish Car Audio, Video and Security 1 10-12-2005 02:56 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome