My first problem - Pontiac G6 Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 23 (permalink) Old 03-14-2006, 04:40 PM Thread Starter
 
Join Date: Jan 2005
Posts: 557
 
My first problem

Well, its official, something is wrong with my car. It seems my car thinks one of my doors is open when they are all closed. I'm pretty sure its a bad switch in one of the latches. I'm getting it looked at on Thursday. I'm also getting a nagging headliner rattle fixed. I thought my car was going to go 20,000 miles without a major problem... guess not. I'll let you al know how it turns out.
bigbengt67 is offline  
Sponsored Links
Advertisement
 
post #2 of 23 (permalink) Old 03-14-2006, 07:40 PM
 
Join Date: Nov 2004
Posts: 279
 
I have heard of a few - do you think it is the driver door (you would be able to tell because chime would go off with key in ignition and ignition off).

Much rain in your parts recently?
e2helper is offline  
post #3 of 23 (permalink) Old 03-14-2006, 10:55 PM
Senior Member
 
G6~Mike's Avatar
 
Join Date: Dec 2005
Location: Onsted, MI
Age: 39
Posts: 199
 
Quote:
Originally Posted by bigbengt67
Well, its official, something is wrong with my car. It seems my car thinks one of my doors is open when they are all closed. I'm pretty sure its a bad switch in one of the latches. I'm getting it looked at on Thursday. I'm also getting a nagging headliner rattle fixed. I thought my car was going to go 20,000 miles without a major problem... guess not. I'll let you al know how it turns out.
I'm curious, do you have the pano roof or standard? The roof is the only place I dont have a rattle yet....knock on wood.
G6~Mike is offline  
Sponsored Links
Advertisement
 
post #4 of 23 (permalink) Old 03-15-2006, 10:46 AM
 
Join Date: Dec 2005
Posts: 107
 
Quote:
Originally Posted by G6~Mike
I'm curious, do you have the pano roof or standard? The roof is the only place I dont have a rattle yet....knock on wood.
Really? My interior only makes a few rattles on really rough roads. Nothing "chronic." Of course, I'm only creeping up on 4k miles also, but I don't see a reason any of that should change.
Lucius is offline  
post #5 of 23 (permalink) Old 03-15-2006, 11:21 AM
Senior Member
 
G6~Mike's Avatar
 
Join Date: Dec 2005
Location: Onsted, MI
Age: 39
Posts: 199
 
Quote:
Originally Posted by Lucius
Really? My interior only makes a few rattles on really rough roads. Nothing "chronic." Of course, I'm only creeping up on 4k miles also, but I don't see a reason any of that should change.
Yeah, the good news is that I dont hear them with the radio on. I had the rattles creep up within a few weeks after buying the car. They havn't gotten better or worse in the last 14,000 miles so I'm not too worried about it.
G6~Mike is offline  
post #6 of 23 (permalink) Old 03-15-2006, 11:32 AM
 
Join Date: Feb 2006
Posts: 40
 
Rattles have started creeping up one me as well, and I'm only at 1200 miles. There's a particulary pesky little one in the headliner (I have the standard sunroof) Hopefully, I won't get any more.
Sully is offline  
post #7 of 23 (permalink) Old 03-15-2006, 03:32 PM Thread Starter
 
Join Date: Jan 2005
Posts: 557
 
Quote:
Originally Posted by e2helper
I have heard of a few - do you think it is the driver door (you would be able to tell because chime would go off with key in ignition and ignition off).

Much rain in your parts recently?
Not the driver's door although I thought it would be since it gets used 99% of the time, there has been some rain lately. Have other cars experienced this too? The dealer didn't mention that it was common when I asked.

G6Mike, I've got the standard sunroof. I dropped the headliner myself last week to see what was going on up there, the motor is basically free to move up and down about an inch. There is a huge chunk of foam between the motor and the metal roof but nothing between the headliner and the motor. All the dealer has to do is stuff some foam in there and it should be fine.
bigbengt67 is offline  
post #8 of 23 (permalink) Old 03-17-2006, 07:29 PM Thread Starter
 
Join Date: Jan 2005
Posts: 557
 
Well, I got it back today. Unfortunately the door ajar problem cleared itself upon the way to the dealer. Apparently there is an issue with false door ajar warnings, GM is working on it. They had to order some clips for my sunroof to stop the rattle, should take 3-4 days to come in and then I can schedule another appointment... On the good side, I got a free carwash out of it!
bigbengt67 is offline  
post #9 of 23 (permalink) Old 03-17-2006, 09:37 PM
RKH
Member
 
Join Date: May 2005
Location: Germantown MD
Posts: 72
 
Quote:
I thought my car was going to go 20,000 miles without a major problem... guess not.
May be a little early to call but perhaps you'll still make 20K without a major problem.
RKH is offline  
post #10 of 23 (permalink) Old 03-18-2006, 08:31 AM Thread Starter
 
Join Date: Jan 2005
Posts: 557
 
^ depends on your definition of major I guess. A rattle here and there isn't major, but a broken door latch switch that compromises the security system is in my book.
bigbengt67 is offline  
post #11 of 23 (permalink) Old 04-20-2006, 06:39 AM
 
Join Date: Mar 2006
Posts: 42
 
I had the same problem. But then like you said it went away.
eatech3 is offline  
post #12 of 23 (permalink) Old 02-08-2008, 10:09 PM
Junior Member
 
Join Date: Feb 2008
Posts: 7
 
Has anyone found a fix?

I have the door ajar problem on my 05 G6 GT. It has 60k on it so its not under warranty. I was just wondering if anyone has found the real problem and had it fixed. Can you let me know what you found so I can fix it my self. Thanks.
mameling is offline  
post #13 of 23 (permalink) Old 02-10-2008, 10:34 PM
 
Join Date: Dec 2007
Posts: 195
 
i just had the same exact problem on my 05 G6 ... it's one of the door locks because the door open/close sensor on G6 is inside the lock ... the way i figured it out was when you disconect the wires from the door the computer iliminates that door that you disconnected out of the system ... like you have 3 doors after you disconnected the wires ... so ... try unpluging the wires that go to the door ... start with the driver door because it's always the one that you use the most ... it's not too hard ... diconnect the wires and see if the light goes off ...

SOLUTION

1. You could probably try spraying lube into the lock and try to close and open the door a few times and see if the light goes off ... but that's probably not gonna help

2. Replace the door lock (AFTER YOU'VE DETERMINED WHICH ONE IT IS) ... that's what i did ... replaced the driver door lock ... the light went off ...

love my job ... we have plenty parts G6 there ... i can just "borrow" stuff when i need to
daygon is offline  
post #14 of 23 (permalink) Old 02-11-2008, 05:45 AM
Junior Member
 
Join Date: Feb 2008
Posts: 7
 
Thanks Daygon. I did figure out it is the drivers door. I take it you mean the latch assembly when you say "lock". That is where all the wires plug into. Ill get one and replace it and see how it goes.
mameling is offline  
post #15 of 23 (permalink) Old 02-11-2008, 05:36 PM
 
Join Date: Dec 2007
Posts: 195
 
Quote:
Originally Posted by mameling View Post
Thanks Daygon. I did figure out it is the drivers door. I take it you mean the latch assembly when you say "lock". That is where all the wires plug into. Ill get one and replace it and see how it goes.
yeah ... i meant latch ... at work we call them locks cuz i'm working with russians and english is my second language ... in russian lock and latch are the same thing ... so ...
daygon is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome