Transmission does not engage in Drive - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 01-30-2012, 01:06 PM Thread Starter
Junior Member
 
Join Date: Jan 2012
Posts: 2
 
Transmission does not engage in Drive

I just purchased a 2006 Pontiac G6 GT with 66k and quite frankly I am wondering what the hell have I gotten myself into. First, after having the car for only 5 days, the power steering failed. Since I purchased an extended warranty from the dealer, they determined that the P/S unit needed to be replaced? OK... That was 5 days ago. Power steering has not failed...yet?? Then, there was/is a problem with the transmission. After the car has been sitting for a while (usually overnight), when I start the car and put it in DRIVE, it does not engage. It's as if I have it in Neutral. I must "gun" it, so to speak, in order to get the car going and then it jerks forward hard. Took it to the mechanic and he said that the linkage just needed to be adjusted. He claims he did just that, but the car still doesn't engage in Drive unless I do the above. The check engine light came on and so once again, I took it to the mechanic and he says that it was a solenoid problem?? UGh!!! Now, I am hearing popping and clicking when I turn and also it feels like there is something wrong with the brakes/rotors. When braking from high speeds, there is some vibration in the steering wheel and it feels as though the engine has a hard time recovering from that hard braking. It almost feels like the brakes have not disengaged if that's possible. I want to take it to AAMCO and have them perform the free multipoint inspection so that I can take a list of things to the mechanic for him to fix. HELP!!
RickStar44 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 01-30-2012, 01:36 PM
Moderator Member Thingy
 
Abyssul's Avatar
 
Join Date: Jun 2009
Location: Myrtle Beach, SC
Posts: 1,330
 
Send a message via AIM to Abyssul Send a message via MSN to Abyssul
For your power steering, it was under a extended warranty bulletin and you should try and get a compensation for that for you paid out of pocket for any of it. We even have a whole forum section dedicated to it at https://www.g6ownersclub.com/forum/forumdisplay.php?f=33

Your brake problem could very well be a rotor warping issue and is easily fixable by replacing the rotors and brakes (do not resurface the rotors). Can you give us the code that your car gives from the CEL? Do you still have a CEL now? If so, then go to your local auto care store like AutoZone or Advance Auto and get them to scan your car.

Take it to AAMCO. They do good work.

Sorry to hear you are having these problems.

2006 Pontiac G6 GT

Appearance Mods: AIT front bumper, Black Eagle Eye Halo Projectors with DDM Tuning 5000k HIDs 35w,
GT door decals, painted interior trim, red calipers, de-chromed window trim
Performance Mods: WAMS tune, CRABS, aftermarket sound system


Last edited by Abyssul; 01-30-2012 at 01:39 PM.
Abyssul is offline  
post #3 of 7 (permalink) Old 01-30-2012, 02:02 PM Thread Starter
Junior Member
 
Join Date: Jan 2012
Posts: 2
 
Thank you. I appreciate that. I will have AAMCO check it out. Is there a forum for transmission problems? Do you know if what I described is common? What is a CEL?
RickStar44 is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 01-30-2012, 05:23 PM
OOBER SUPER MEMBER
 
CruisinG6's Avatar
 
Join Date: Jul 2009
Posts: 4,232
 
by CEL he means Check Engine Light.

Popping and clicking in the front end could be an axle or end links. But these cars commonly have noisy front ends. It sucks but over larger bumps you hear it easily, If the stereo is off or low of course.

There was a recall about the adjustment of the Shifter cable. It was often a problem where it wouldn't car ALL the way into Park. and you would then not be able to take the key out. That should have been fixed, But considering its a solenoid issue it should be a pretty simple fix.

I would assume the shop you go to would have at least test driven the car before returning it to you.

And yea, checking with AAMCO is a good idea. haha

Good luck!
CruisinG6 is offline  
post #5 of 7 (permalink) Old 01-30-2012, 07:53 PM
RAM AIR!!
 
coupe_gtp's Avatar
 
Join Date: Nov 2006
Posts: 266
 
Send a message via AIM to coupe_gtp
My transmission started slipping really bad when I left work 42 miles away from where I live. It was summer time with about 4 differet construction zones you had to stop at along the way. I never knew it was slipping until I had to stop completely and my car was just revving in drive lol. I had to put it into tap-shift to do anything at all. By the time I got home it was really bad, lucky for me I drive those types of cars all the time at where I work lol.
coupe_gtp is offline  
post #6 of 7 (permalink) Old 05-09-2012, 06:30 PM
Junior Member
 
Join Date: May 2012
Posts: 2
 
transmission help

sorry not sure if doing this right,, but ok,, my transmission would slip from time to time not too much.. then was driving stopped at a stop light when it turned green i gave it gas and nothing at all, i had reverse neutral and another nuetral, my drive was not there, i put it in the slap shift and it worked so i used slap shift for bout 2 days then 1st i would have to give alot of gas, then 2nd same way, by the second daynone of it worked except reverse, now when i was starting in slap once i got to about 35 mph i could put it in d4rive and it worked fine, until i got back down under 35, im sure its bad i know this.. but transmissions dont usually just go out all of a sudden at a stop light ,, do they.. could it be something else maybe
stressedout is offline  
post #7 of 7 (permalink) Old 05-09-2012, 06:44 PM
Junior Member
 
Join Date: May 2012
Posts: 2
 
transmission help

sorry not sure if doing this right,, but ok,, my transmission would slip from time to time not too much.. then was driving stopped at a stop light when it turned green i gave it gas and nothing at all, i had reverse neutral and another nuetral, my drive was not there, i put it in the slap shift and it worked so i used slap shift for bout 2 days then 1st i would have to give alot of gas, then 2nd same way, by the second daynone of it worked except reverse, now when i was starting in slap once i got to about 35 mph i could put it in d4rive and it worked fine, until i got back down under 35, im sure its bad i know this.. but transmissions dont usually just go out all of a sudden at a stop light ,, do they.. could it be something else maybe
stressedout is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 



Similar Threads
Thread Thread Starter Forum Replies Last Post
transmission replaced and still same transmission problem Sterling Problems and Solutions 7 09-20-2011 03:53 PM
What Model G6 Do You Drive TinIndian Off-Topics 41 02-11-2011 02:31 PM
Swap cd drive from 07 to 08? saberz Car Audio, Video and Security 2 08-05-2010 06:01 AM
OK, There both clean, now which one do I drive today? THECATMAC Automotive Cleaning and Detailing 9 03-12-2010 04:32 PM
Question about going into neutral from drive attackofthegirt G6 Buyer's Guide/General Information 11 06-21-2009 12:04 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome