2008 G6 New Problem!!! - Pontiac G6 Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 23 (permalink) Old 02-15-2012, 04:09 AM Thread Starter
Junior Member
 
Join Date: Jan 2012
Posts: 13
 
2008 G6 New Problem!!!

I have encountered a new issue with my 2008 G6 4 cylinder. I bought the car new and it has 29,990 on it. What just started up now, and it's happened twice already, is that when you are going 30 MPH and giving it the gas to take the car up to 40 or more that very last shift the car makes it now slows the engine down or surges it. It almost feels like it's running out of gas. Then, within a minute, it slowly picks up speed again but then hesitates a bit after that. I'll take it to the dealer but I wanted to ask you guy's first. Anyone else with this problem? Thanks! Don
doning is offline  
Sponsored Links
Advertisement
 
post #2 of 23 (permalink) Old 02-15-2012, 02:37 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Before you take it to the dealer: Is the check engine lamp on? If not, you should still check for pending codes (Autozone can do this free). Hesitation on acceleration can be caused by a lot of things. If there are no codes, & the dealer can't easily replicate the issue in a short test drive, they'll probably just shoo you out the door.

It could be as simple as a dirty MAF sensor or throttle body.




Last edited by greenman; 02-15-2012 at 03:27 PM.
greenman is offline  
post #3 of 23 (permalink) Old 02-15-2012, 04:37 PM
OOBER SUPER MEMBER
 
CruisinG6's Avatar
 
Join Date: Jul 2009
Posts: 4,232
 
Quote:
Originally Posted by greenman View Post
Before you take it to the dealer: Is the check engine lamp on? If not, you should still check for pending codes (Autozone can do this free). Hesitation on acceleration can be caused by a lot of things. If there are no codes, & the dealer can't easily replicate the issue in a short test drive, they'll probably just shoo you out the door.

It could be as simple as a dirty MAF sensor or throttle body.
I was thinking you should try cleaning the TB or MAF if you have no check engine light.
CruisinG6 is offline  
Sponsored Links
Advertisement
 
post #4 of 23 (permalink) Old 02-15-2012, 08:13 PM
Junior Member
 
Dr_G6's Avatar
 
Join Date: Feb 2011
Location: Indianapolis, IN
Age: 30
Posts: 24
 
My car does something like this and I, too, have an 08 4cyl. The other day on the highway going about 50mph, I switched to the fast lane to try and accelerate past a slower moving car and it literally took a good 5-8 seconds for the car to gain ANY type of speed. It's almost like the engine refused to respond at all, despite the fact that the gas pedal was being pushed pretty close to the floor. When I first noticed this problem months ago, took it to the dealer and they hooked it up to the machine, a tech drove it, and they could find no problems w/the transmission. No codes are being thrown so of course that complicates the matter too. I'm at about to 58.6K miles and I was wondering if changing the transmission fluid would be of any help with this problem. Suggestions?

08 G6 Value Leader
STOCK and boring....for now
Dr_G6 is offline  
post #5 of 23 (permalink) Old 02-15-2012, 08:23 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Tranny fluid--No.

You should also start with cleaning the MAF sensor & TB. These are routine maintenance items on all modern cars though I realize they don't tell you that in the owner's manual.

Be careful with the MAF sensor. The only thing that should touch it is MAF sensor cleaning spray.



greenman is offline  
post #6 of 23 (permalink) Old 02-16-2012, 03:58 AM Thread Starter
Junior Member
 
Join Date: Jan 2012
Posts: 13
 
No. I have no check engine lights. I was thinking maybe disconnecting the battery and reconnecting to reset something?
doning is offline  
post #7 of 23 (permalink) Old 02-17-2012, 02:25 AM
2006 G6 GTP
 
Join Date: Feb 2012
Location: Northern Indiana
Posts: 30
 
Might be a torque converter or a 3rd gear apply piston in the trans...

Does the car switch back and forth from "overdrive"? Does it jerk forward when doing a rolling stop?
FreakaLeak69 is offline  
post #8 of 23 (permalink) Old 02-17-2012, 04:02 AM Thread Starter
Junior Member
 
Join Date: Jan 2012
Posts: 13
 
No it does not.
doning is offline  
post #9 of 23 (permalink) Old 02-17-2012, 09:23 AM
2006 G6 GTP
 
Join Date: Feb 2012
Location: Northern Indiana
Posts: 30
 
Well that's good! lol.

Have you checked the fuel pump? Sometimes a sporatic fuel pump can cause really weird issues like this...being that u have no pcm codes. I had a Ranger that the fuel pump was going out. It would build up extreme pressure on initial start up and bog down like this on WOT or even accelerating up a hill because it couldn't keep a steady flow of gas to the injectors. Come to think of it...I never once had a pcm code or check engine light either.
FreakaLeak69 is offline  
post #10 of 23 (permalink) Old 02-17-2012, 01:11 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Quote:
Originally Posted by doning View Post
No. I have no check engine lights. I was thinking maybe disconnecting the battery and reconnecting to reset something?
Pending codes will not light the CEL so you should still check for codes. You can get a basic code reader for under 25 bucks now. If you disconnect the battery you'll lose all code info that might help in the diagnosis. It is always worth doing.



greenman is offline  
post #11 of 23 (permalink) Old 02-18-2012, 12:40 AM
2006 G6 GTP
 
Join Date: Feb 2012
Location: Northern Indiana
Posts: 30
 
Yup

True...I agree, Greenman. It does help most of the time to check the pcm codes for sure before replacing anything.
FreakaLeak69 is offline  
post #12 of 23 (permalink) Old 02-19-2012, 09:19 AM
G6 GT member
 
Join Date: Apr 2011
Location: Rochester, NY
Age: 42
Posts: 30
 
Quote:
Originally Posted by FreakaLeak69 View Post
Does the car switch back and forth from "overdrive"? Does it jerk forward when doing a rolling stop?
I HATE "overdrive"

(MPH)>97,98,99,100,.....101.....102.....103.....10 4.....105

Can you turn it off to do an experiment to see if that's the problem......for the guy having the problem, of course!!!
killjoydod is offline  
post #13 of 23 (permalink) Old 02-20-2012, 12:18 AM
2006 G6 GTP
 
Join Date: Feb 2012
Location: Northern Indiana
Posts: 30
 
LOL. Overdrive actually means that your torque converter locks in place, running 1:1 with the engine and trans. Most people think it's a gear by itself. It can be turned off with a tech scanner or a wired up switch, but u would get HORRIBLE gas mileage in 3rd and 4th gear.
FreakaLeak69 is offline  
post #14 of 23 (permalink) Old 02-24-2012, 02:54 AM Thread Starter
Junior Member
 
Join Date: Jan 2012
Posts: 13
 
Well, today's the day. I'm having my wife take the G6 to the dealer. I made the service manager a nice list. We'll see how far I get with that!
doning is offline  
post #15 of 23 (permalink) Old 02-25-2012, 12:02 AM
Gpof59
 
Join Date: Oct 2011
Location: Racine, WI.
Age: 66
Posts: 46
 
Sounds like a bad throttle position sensor.
pof09G6 is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Looking at a 2008 G6 kjvanek G6 Buyer's Guide/General Information 2 04-24-2011 08:25 PM
Problem with trunk on 2008 G6 convertible nerd1701 Problems and Solutions 6 03-31-2011 10:26 AM
2008 G6-V6 with shutter problem... Maliki2 Problems and Solutions 3 02-01-2010 03:08 PM
2008 gxp g6 3.6 transammatt Problems and Solutions 7 02-11-2008 08:00 PM
2008 G6-gxp RayZ Auto News and Rumors 13 01-30-2008 07:53 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome