2010 engine skips under load - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 02-19-2012, 10:07 AM Thread Starter
Junior Member
 
Join Date: Feb 2012
Posts: 7
 
2010 engine skips under load

Hey guys/gals I am new on the forum. My wife drives a 2010 G6 GT with the 3.5L V6, 4 door. I have been a Pontiac fanatic as I have owned about 4 Trans Am's, own a 2000 WS6 currently with a LS6 I built for it pushing around 480hp to the tires and 454 tq as well. So on that note I understand how engines work and I understand sensors can be a nightmare. The problem I have with the G6 is when I drive it under normal acceleration between 1500-2000 rpm it skips and jumps around the rpm range until it reaches anything over 3k then it clears up for the most part. I thought maybe the injectors could have been clogged from bad gas or something but I have run Sea Foam at full strength a few times because I it seems to be the best I know about when it comes to cleaning out fuel systems. Anyway has anyone had an issue with their 2010 similar to this? I have not checked the plugs yet but I wouldn't think with 32k miles on the car they would be bad. Thanks in advance for the help. I use LS1TECH for my TA's tech issues so I hope this forum can do the same for the G6 =)

Last edited by platinum ws6; 06-13-2012 at 07:59 AM.
platinum ws6 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 02-19-2012, 12:13 PM
Varsity Squad
 
CalsGTP's Avatar
 
Join Date: Mar 2008
Location: Sandy Lake, PA
Posts: 751
 
Garage
Any stored codes? Even if check engine light is not on there could be codes. Start there. There are so many things that could be causing this hick-up. I am currently dealing with one caused by the electronic throttle body.
CalsGTP is offline  
post #3 of 4 (permalink) Old 02-19-2012, 03:19 PM Thread Starter
Junior Member
 
Join Date: Feb 2012
Posts: 7
 
I was unaware it could be throwing codes without actually setting off the SES light. I will start there I guess, thanks.

2000 Trans Am WS6: Sebring Silver Metallic LS6, TEA 5.3 stg. 2 heads, VRx5 cam, Monster stg 3 clutch, 3.73 gears, yada yada.....too much more to list.
Daily Driver- 2003 Silverado Z71, 3 inch body lift, 35s, Hypertech
Wife's: 2010 G6 Silver Metallic 3.5 V6 with ebony int.
platinum ws6 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 06-13-2012, 06:36 AM Thread Starter
Junior Member
 
Join Date: Feb 2012
Posts: 7
 
I have checked everything I can think of, even decided to bite the bullet and take it to the stealership to check for any stored codes but all I found was less money in my wallet. Has anyone else had any issues like this? It specifically jumps rpms between 1500 and 2000 rpm while accelerating at a normal pace. It is my wifes car and I don't drive it every day but when I do it drives me insane! Any ideas would be very helpful, thanks.

2000 Trans Am WS6: Sebring Silver Metallic LS6, TEA 5.3 stg. 2 heads, VRx5 cam, Monster stg 3 clutch, 3.73 gears, yada yada.....too much more to list.
Daily Driver- 2003 Silverado Z71, 3 inch body lift, 35s, Hypertech
Wife's: 2010 G6 Silver Metallic 3.5 V6 with ebony int.

Last edited by platinum ws6; 06-13-2012 at 07:12 AM.
platinum ws6 is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
I'm looking to buy a 2010 G6 & need help reginaalear G6 Buyer's Guide/General Information 6 02-06-2011 04:53 PM
CDs won't load piratejeffwdw Car Audio, Video and Security 5 11-08-2010 11:17 AM
Check Engine/Scv Vehicle Soon/Reduced Engine Pwr Indicators all on? insiminator Problems and Solutions 7 09-19-2010 08:21 AM
HIN-NOPI 2010 SUPERSHOW SOLDIER FIELD, CHICAGO ILLINOIS September 25, 2010 mcwheels Off-Topics 0 09-15-2010 10:05 AM
HIN-NOPI 2010 SUPERSHOW LOS ANGELES CONVENTION CENTER September 18, 2010 mcwheels The West 0 08-20-2010 08:18 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome