need some ideas for rough idle - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 03-02-2012, 03:45 PM Thread Starter
Junior Member
 
Join Date: Feb 2012
Posts: 10
 
need some ideas for rough idle

hey guys. i have somewhat of a rough idle when vehicle is stopped and in drive. if i shift to neutral, it's smooth idle. i changed spark plugs, air filter, oil&filter, cleaned the throttle body, cleaned the MAF, ran seafoam through tank and brake booster line, all within the last few months, and i'm still getting same results. i've taken the car to autozone to have them check to see if it shot any codes, nothing.
any suggestions?

thanks,
-u
mai0f is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 03-02-2012, 04:33 PM
Moderator
 
waterfowler76's Avatar
 
Join Date: May 2009
Location: Las Vegas
Posts: 4,040
 
Send a message via Yahoo to waterfowler76
what year, engine do you have?

2007 PONTIAC G6 GT

Waterfowler's 6 <---- Check out my 6
waterfowler76 is offline  
post #3 of 12 (permalink) Old 03-02-2012, 06:45 PM
Member
 
Join Date: Sep 2009
Posts: 34
 
I have a 05 gt and I have the same problem doesn't run bad or anything just a little funny at idle in gear don't know why it's doing it
jncgitrdun is offline  
Sponsored Links
Advertisement
 
post #4 of 12 (permalink) Old 03-02-2012, 07:16 PM Thread Starter
Junior Member
 
Join Date: Feb 2012
Posts: 10
 
Quote:
Originally Posted by waterfowler76 View Post
what year, engine do you have?
Sorry, can't believe I forgot to mention that. 2008 G6 GT 3.5.

Last edited by mai0f; 03-02-2012 at 10:52 PM.
mai0f is offline  
post #5 of 12 (permalink) Old 03-04-2012, 10:45 PM
Cute female member
 
Join Date: Feb 2012
Location: york pa
Posts: 11
 
OMG I am having this exact same problem!!! I just bought my car feb 18th I changed the sparks twice! I am freaking out something really expensive could be wrong and I am stuck in payments for the next 36 months. I also put fuel system cleaner in a few days ago and put NGK plugs in today and changed plug wires and still no change. If u figure out what this is please let me know.
LymepatientX is offline  
post #6 of 12 (permalink) Old 03-04-2012, 11:22 PM
Junior Member
 
Join Date: Mar 2012
Posts: 6
 
hi i am a mechanic at a chevy dealer and i had the same exact problem. it came down to updating the computer. just take it to the dealer and have them reflash the computer. should only cost around 200 dollars.
coryclouser58 is offline  
post #7 of 12 (permalink) Old 03-05-2012, 10:15 PM Thread Starter
Junior Member
 
Join Date: Feb 2012
Posts: 10
 
Quote:
Originally Posted by coryclouser58 View Post
hi i am a mechanic at a chevy dealer and i had the same exact problem. it came down to updating the computer. just take it to the dealer and have them reflash the computer. should only cost around 200 dollars.
damn.... they're going to charge to update it? that sucks... now, two questions....

1. i had the remote start kit installed a few months ago. the car was already "equipped", it just needed a software update. wouldn't that have fixed it?

2. what if i take it in for a software update, and it doesn't fix the prob? :-\

thank you,
-u
mai0f is offline  
post #8 of 12 (permalink) Old 03-07-2012, 01:21 AM
Junior Member
 
Join Date: Mar 2012
Posts: 6
 
well they might have might not did the right system just go there and check to see if your up to date but if you are check your fuel pressure and fuel flow. the computer doesnt monitor fuel systems. since you cant change your fuel filter its a problem in these cars. happens all the time. in the computer system there is a thing called fuel trim. if its trending plus trim that means its trying to put more fuel into your engine so that means either a clogged filter or a faulty pump.
coryclouser58 is offline  
post #9 of 12 (permalink) Old 03-07-2012, 01:26 AM
Junior Member
 
Join Date: Mar 2012
Posts: 6
 
they shouldnt charge you just to check to see if your up to date on things and remember this is a dealer only option
coryclouser58 is offline  
post #10 of 12 (permalink) Old 03-07-2012, 10:59 PM Thread Starter
Junior Member
 
Join Date: Feb 2012
Posts: 10
 
Quote:
Originally Posted by coryclouser58 View Post
they shouldnt charge you just to check to see if your up to date on things and remember this is a dealer only option
will do, thank you for your help..
mai0f is offline  
post #11 of 12 (permalink) Old 03-08-2012, 12:41 AM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Quote:
Originally Posted by mai0f View Post
hey guys. i have somewhat of a rough idle when vehicle is stopped and in drive. if i shift to neutral, it's smooth idle. i changed spark plugs, air filter, oil&filter, cleaned the throttle body, cleaned the MAF, ran seafoam through tank and brake booster line, all within the last few months, and i'm still getting same results. i've taken the car to autozone to have them check to see if it shot any codes, nothing.
any suggestions?

thanks,
-u
3.5l, mileage unknown: That can be tough to find without a good scan tool.

Are you getting any pinging under heavy engine load?

Did you replace the spark plug wires or verify their end-to-end resistance is about the same?




Last edited by greenman; 03-08-2012 at 11:30 AM.
greenman is offline  
post #12 of 12 (permalink) Old 03-08-2012, 02:47 AM
Gpof59
 
Join Date: Oct 2011
Location: Racine, WI.
Age: 66
Posts: 46
 
I would start looking for any vacumn leaks, PCV clogged or dirty? Air Filter dirty? You said you replaced the air filter,so that's out. EGR?, If there's too much EGR flow at idle or cruise or at cold weather conditions, this can cause a rough idle. Other possibilities are, loose or broken motor mounts? lack of fuel delivery from pump or bad injector?, or head gasket leak.
pof09G6 is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Idle goes ROUGH when I turn on heater. HELP? nickel723 Problems and Solutions 5 11-11-2011 07:21 PM
Normal Rough Idle? Beaz Problems and Solutions 4 06-05-2011 07:28 AM
HELP!!! Rough Idle / Starting Problems damnngina15 Problems and Solutions 4 12-12-2010 07:40 PM
Rough idle Panic Switch Problems and Solutions 21 10-30-2010 06:55 AM
Chugging/ Rough idle at stoplights patricktt Problems and Solutions 0 08-01-2010 06:01 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome