tie rod problems - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 03-11-2012, 02:20 PM Thread Starter
Junior Member
 
Join Date: Mar 2012
Posts: 4
 
tie rod problems

i have an 06 g6 gt coupe lowered.

ok so heres my issue. drivers side outer tie rod is bad which is no problem because i can change that quick. but mechanic tried to say my inner tie rod on passenger side is bad. I have EPS and from what i see and understand is that there are no inner tie rods because they are built into the rack.

i can move the passenger tire side to side by putting hands at 9 and 3. pretty loosely i might add. i just replaced the outer tie rod in the past 6 months with MOOG Part No. ES800086. anyone here of the racks built in inner tie rod giving this much play or do you think the outer is bad already. Also it has been taken in last year for the power steering recall situation.
drkheppy is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 03-11-2012, 03:23 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
There are inner tie rods on your car & depending on mileage if one outer rod is worn out I would be inclined to replace inners & outers on both sides if you plan on keeping the car for awhile. They aren't particularly hard to do on this car & not expensive. Maybe $150 max for parts & no special tools required.




Last edited by greenman; 03-11-2012 at 03:26 PM.
greenman is offline  
post #3 of 6 (permalink) Old 03-11-2012, 07:50 PM Thread Starter
Junior Member
 
Join Date: Mar 2012
Posts: 4
 
so are they underneath the boots then? i seen elsewhere that the electronic power steering didnt have inners. and when i looked at the pics of the rack and pinion they were already build into it.

also this thread is pointless now lol i threw out one of my cylinders. i have a 40 min drive to my parents garage and i got 2 miles from the house and my oil light kicked on and then heard knocking and then the engine shut off. i put it in nuetral and coasted till i found a place to park. then i put 2 quarts of oil which lowered the knocking sound but at this point a road bearing or something is spun or something. so now im trying to find a engine tear down guide or a schematic.
drkheppy is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 03-11-2012, 08:20 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Quote:
Originally Posted by drkheppy View Post
so are they underneath the boots then? i seen elsewhere that the electronic power steering didnt have inners. and when i looked at the pics of the rack and pinion they were already build into it.
Yes, the socket is protected by a boot. It's standard R&P steering.



greenman is offline  
post #5 of 6 (permalink) Old 03-12-2012, 10:50 AM
Senior Member
 
Join Date: Dec 2005
Posts: 606
 
Quote:
Originally Posted by drkheppy View Post
i have an 06 g6 gt coupe lowered.

ok so heres my issue. drivers side outer tie rod is bad which is no problem because i can change that quick. but mechanic tried to say my inner tie rod on passenger side is bad. I have EPS and from what i see and understand is that there are no inner tie rods because they are built into the rack.

i can move the passenger tire side to side by putting hands at 9 and 3. pretty loosely i might add. i just replaced the outer tie rod in the past 6 months with MOOG Part No. ES800086. anyone here of the racks built in inner tie rod giving this much play or do you think the outer is bad already. Also it has been taken in last year for the power steering recall situation.
Your rack is worn out, take the boot and slide it back and you will see the
the worn housing. Been there ,done that. Actually easy job to replace rack.
slls is offline  
post #6 of 6 (permalink) Old 03-12-2012, 08:08 PM Thread Starter
Junior Member
 
Join Date: Mar 2012
Posts: 4
 
unfortunatly, now with knock i described in my second reply above i think i am just going to trade it in and take a hit rather than spend time and money i dont have.

i tried lucas and oil mixture which didn't help so its for sure a rod.

in park or neutral it knocks pretty good. but at 1500 - 2000 rpms the sound completely disappears. so that is kinda throwing me off. I have not taken it for a drive to get the rpms that high because im afraid to make it even worse and damage anything more. And dropping the sub frame down and all just to remove and oil pan to see where im at with it is impossible due to time. Im a full time IT admin for a large corporation and on call 24/7.

last time i had a knock like this was in an integra and it was only a $100 car so i jumped on the gas and shot the rod through the front of the engine lol
drkheppy is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
08 G6 , nothing but problems mckenna121779 Problems and Solutions 9 07-14-2010 01:23 PM
ABS Problems Dyanik Problems and Solutions 3 12-31-2009 03:19 PM
G6 problems bajeffrey51 Powertrain Performance Modifications 4 03-04-2009 07:48 AM
New with problems and yes i used the search button, problems with electrical? TuKwick Problems and Solutions 1 02-13-2009 02:12 PM
Several Problems Weller Problems and Solutions 0 11-24-2005 06:48 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome