Alternator good, Battery good, Voltage Low/Car Loses power while driving - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 05-05-2012, 09:53 AM Thread Starter
Junior Member
 
Join Date: May 2012
Posts: 2
 
Alternator good, Battery good, Voltage Low/Car Loses power while driving

I am trying to help my friend fix his 05 or 06 G6 which has a very confusing problem. While driving the car will run out of electrical power, ABS light comes on the the battery light, transmission solenoids fail to shift then the car dies. Running on just the battery it can start and drive for a few hours and even start 3-4 times.

We have tried a total of 4 alternators now including a reman, his original and two OEM junkyard alts. We have fully charged the battery on a trickle charger three times and tested it twice. All are good every time.

When we jump start the car the voltage at any RPM stays between 12.1-12.4 Volts versus 13+ which is what it should be.

How is voltage/current regulated in this car? What should I replace to fix this problem? Are there any recalls about this with G6s?

Thank you very much.
Lord Gaga is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-05-2012, 12:22 PM Thread Starter
Junior Member
 
Join Date: May 2012
Posts: 2
 
You know what, I didn't check the fuses. Are there inline fuses for the alternator? Perhaps in the wire or in the fuse box? If so are there more than one or just one n the fuse box?

When my friend gets back from work I will check voltage at alternator versus voltage at battery. I bet alt is 13+ and battery is 12v.

EDIT: If someone has Alldata can someone please look this up for me?

Last edited by Lord Gaga; 05-05-2012 at 01:19 PM.
Lord Gaga is offline  
post #3 of 3 (permalink) Old 05-05-2012, 11:50 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Possibly the fusible link is blown between the alt output & the starter solenoid (from there it feeds B+). Check wire continuity end-to-end. If blown, do not reinstall the original alt.




Last edited by greenman; 05-06-2012 at 01:14 AM.
greenman is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery/alternator issue Ladylove Problems and Solutions 1 06-28-2011 02:40 PM
good or not good? Adam R Car Audio, Video and Security 3 01-02-2011 11:25 AM
Good or Not Good? Adam R Appearance Modifications and Lighting 4 04-24-2010 11:12 PM
this is so bad, it's good! The Oracle Joke Central 1 02-27-2006 07:58 PM
Good Driving all AutobahnG6 New Member Introductions 5 01-26-2006 05:56 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome