engine start up - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 05-22-2012, 07:31 AM Thread Starter
Junior Member
 
Join Date: May 2012
Posts: 5
 
engine start up

on a 2006 g6 gtp
engine starts when key is inserted without turning.( relay under hood chatters)
runs about 5 seconds,then turns off. remote start has been disabled.
i can then restart ok. any suggestions please
thanks [email protected]
this problem has been going on for about six months and happens
about 50 percent of the time.

Last edited by frank nardelli; 05-23-2012 at 07:17 AM.
frank nardelli is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 05-24-2012, 02:23 PM
Member
 
Join Date: May 2012
Posts: 45
 
Wish I could help you bro. I had a starter problem that was randomly it would crank slowly and wouldn't start unless I pressed the gas. To fix it, I cleaned the throttle body. Three days and it hasn't had a problem again yet.

Have you tried a different key? Reflash the computer? I don't know a whole lot about cars but it sounds like you have more of a computer/electrical than mechanical problem. Maybe when they disconnected the remote start something got crossed. Take it back to whoever did that and talk to them?

Why did you disconnect remote start? Just wondering.
Purple is offline  
post #3 of 14 (permalink) Old 05-24-2012, 03:07 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Quote:
Originally Posted by frank nardelli View Post
on a 2006 g6 gtp
engine starts when key is inserted without turning.( relay under hood chatters)
runs about 5 seconds,then turns off. remote start has been disabled.
i can then restart ok. any suggestions please
thanks [email protected]
this problem has been going on for about six months and happens
about 50 percent of the time.
Does it have factory or aftermarket remote start in that car?
Start relay #31 in the underhood fuse block is chattering?
Expand on this statement: "remote start has been disabled"



greenman is offline  
Sponsored Links
Advertisement
 
post #4 of 14 (permalink) Old 05-25-2012, 07:59 AM Thread Starter
Junior Member
 
Join Date: May 2012
Posts: 5
 
The remote start is factory installed and works fine with both keys.
I disabled the remote start with the menu on the computer.
I also tryed some wd -40 in the key slot with no luck.
I have not replaced the starter relay.how ever i could.
I also called a couple of gm dealers ankd they claim never to have seen this problem.
frank nardelli is offline  
post #5 of 14 (permalink) Old 05-25-2012, 12:26 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
I need more details on this: "relay under hood chatters"

Are you referring to the start relay #31 in the fuse block, the starter solenoid/relay or what?




Last edited by greenman; 05-25-2012 at 04:18 PM.
greenman is offline  
post #6 of 14 (permalink) Old 05-29-2012, 08:05 AM Thread Starter
Junior Member
 
Join Date: May 2012
Posts: 5
 
relay 31 under hood in the fuse block
frank nardelli is offline  
post #7 of 14 (permalink) Old 05-29-2012, 11:32 AM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Quote:
Originally Posted by frank nardelli View Post
relay 31 under hood in the fuse block
Try swapping it out



greenman is offline  
post #8 of 14 (permalink) Old 05-30-2012, 10:33 AM Thread Starter
Junior Member
 
Join Date: May 2012
Posts: 5
 
i will swap it out to night
also fyi
on a few occasions when key is inserted and
turned to acc nothing on dash turns on
then turned to on nothing
then turned to start nothing
when i remove key and reinsert all turns on and engine starts
thanks for all your help GREENMAN
frank
frank nardelli is offline  
post #9 of 14 (permalink) Old 05-30-2012, 12:45 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Quote:
Originally Posted by frank nardelli View Post
on a few occasions when key is inserted and
turned to acc nothing on dash turns on
then turned to on nothing
then turned to start nothing
when i remove key and reinsert all turns on and engine starts
thanks for all your help GREENMAN
frank
It has to be the ignition switch then. That's covered in the Chiltons for G6.



greenman is offline  
post #10 of 14 (permalink) Old 05-31-2012, 09:35 AM Thread Starter
Junior Member
 
Join Date: May 2012
Posts: 5
 
thanks for your help
do you think it is the switch behind the key lock or
the key lock.
thanks,frank
frank nardelli is offline  
post #11 of 14 (permalink) Old 05-31-2012, 11:51 AM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Quote:
Originally Posted by frank nardelli View Post
thanks for your help
do you think it is the switch behind the key lock or
the key lock.
thanks,frank
I don't understand the question.



greenman is offline  
post #12 of 14 (permalink) Old 05-31-2012, 04:15 PM
OOBER SUPER MEMBER
 
CruisinG6's Avatar
 
Join Date: Jul 2009
Posts: 4,232
 
I think he's referring to the electric part of the lock vs the mechanical part of the lock. I'd say the electrical parts. I.E. the switch behind the key'd lock
CruisinG6 is offline  
post #13 of 14 (permalink) Old 05-31-2012, 06:08 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Got it. You are probably going to need to pull & replace the whole smash.



greenman is offline  
post #14 of 14 (permalink) Old 06-01-2012, 01:31 AM
OOBER SUPER MEMBER
 
CruisinG6's Avatar
 
Join Date: Jul 2009
Posts: 4,232
 
I would assume it's easier getting to the assembly with it being in the dash, As opposed to being in the steering column. Just larger panels to remove...
CruisinG6 is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine Won't Start, Seems to be Security System Malfunction oromis Problems and Solutions 8 02-09-2011 12:05 AM
remote start your engine Bluizer GT bigwil1 Powertrain Performance Modifications 1 12-11-2010 08:33 AM
How do you Increase the remote start time your engine runs? THECATMAC Problems and Solutions 3 11-08-2010 05:48 PM
Check Engine/Scv Vehicle Soon/Reduced Engine Pwr Indicators all on? insiminator Problems and Solutions 7 09-19-2010 08:21 AM
2005 Pontiac G6 won't start with warm engine baltimoreG6 Problems and Solutions 6 01-13-2009 05:43 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome