check engine light.flashing - Pontiac G6 Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 29 (permalink) Old 05-25-2012, 08:54 PM Thread Starter
Keep it factory baby!
 
gmitch23's Avatar
 
Join Date: Aug 2010
Location: Oklahoma
Age: 38
Posts: 100
 
check engine light.flashing

today i noticed my car was sluggish. It started.driving normal shortly.after..then i was on the highway using cruise control and upon going up a hill my rpm shot to 5000 and the car did nt accelerate and my engine light.started flashing. I turned the cruise off and tapped the break and everything returned to normal and the light has been off since. Any ideas??
gmitch23 is offline  
Sponsored Links
Advertisement
 
post #2 of 29 (permalink) Old 05-25-2012, 09:00 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Engine was misfiring at a high enough rate to damage the cat convertors. Thus the flashing CEL. Which engine & year?



greenman is offline  
post #3 of 29 (permalink) Old 05-25-2012, 09:02 PM Thread Starter
Keep it factory baby!
 
gmitch23's Avatar
 
Join Date: Aug 2010
Location: Oklahoma
Age: 38
Posts: 100
 
2006 2.4ltr. Is it the cat extended warranty letter i got in the mail last year?

Sent from my SAMSUNG-SGH-I717 using AutoGuide.Com Free App
gmitch23 is offline  
Sponsored Links
Advertisement
 
post #4 of 29 (permalink) Old 05-25-2012, 09:37 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Even if the CEL is off there may still be a pending code/s in the computer. If not, a decent scan tool(not a code reader) can display the misfire data & tell you which cylinder/s is/are involved.

It's misfiring under a high load (pulling uphill). You really need to find out which cylinders are involved.

A clogged cat is a possibility.




Last edited by greenman; 05-25-2012 at 09:41 PM.
greenman is offline  
post #5 of 29 (permalink) Old 05-25-2012, 10:25 PM Thread Starter
Keep it factory baby!
 
gmitch23's Avatar
 
Join Date: Aug 2010
Location: Oklahoma
Age: 38
Posts: 100
 
Is it possible the tranny is slipping? God i hope not. I guess ill let the dealer scan it. I believe autozones scanners only detect codes when the check engine light is on.

Sent from my SAMSUNG-SGH-I717 using AutoGuide.Com Free App
gmitch23 is offline  
post #6 of 29 (permalink) Old 05-25-2012, 10:27 PM Thread Starter
Keep it factory baby!
 
gmitch23's Avatar
 
Join Date: Aug 2010
Location: Oklahoma
Age: 38
Posts: 100
 
Also I've had seemingly loss of power and not as great gas.mileage in the past. I've changed the plugs in it at 70k. There are 94k on it now.

Sent from my SAMSUNG-SGH-I717 using AutoGuide.Com Free App
gmitch23 is offline  
post #7 of 29 (permalink) Old 05-26-2012, 11:02 AM Thread Starter
Keep it factory baby!
 
gmitch23's Avatar
 
Join Date: Aug 2010
Location: Oklahoma
Age: 38
Posts: 100
 
Also, what rpm should it idle at? Right now it seems to idle right at a grand. I can't remember but that seems a tad high.

Sent from my SAMSUNG-SGH-I717 using AutoGuide.Com Free App
gmitch23 is offline  
post #8 of 29 (permalink) Old 05-26-2012, 12:52 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
800 rpm is normal.
When was the last time the MAF sensor & throttle body were cleaned?
A clogged cat in that 2.4l will give you a consistent feeling of sluggishness though it is definitely more noticeable as engine load increases.




Last edited by greenman; 05-26-2012 at 01:19 PM.
greenman is offline  
post #9 of 29 (permalink) Old 05-26-2012, 05:39 PM Thread Starter
Keep it factory baby!
 
gmitch23's Avatar
 
Join Date: Aug 2010
Location: Oklahoma
Age: 38
Posts: 100
 
I had a fuel system cleaning at 50k and 75k. I bet its the cat. I have an appointment Monday morning. Ill update you. Hands for all your help.

Sent from my SAMSUNG-SGH-I717 using AutoGuide.Com Free App
gmitch23 is offline  
post #10 of 29 (permalink) Old 05-26-2012, 06:39 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Quote:
Originally Posted by gmitch23 View Post
I had a fuel system cleaning at 50k and 75k.
Dealers generally refer to MAF sensor cleaning/throttle body cleaning/air filter replacement collectively as "air induction service".



greenman is offline  
post #11 of 29 (permalink) Old 05-26-2012, 07:02 PM Thread Starter
Keep it factory baby!
 
gmitch23's Avatar
 
Join Date: Aug 2010
Location: Oklahoma
Age: 38
Posts: 100
 
At 60 k I hAd A cylinoide in the throttle body replAced i believe

Sent from my SAMSUNG-SGH-I717 using AutoGuide.Com Free App
gmitch23 is offline  
post #12 of 29 (permalink) Old 05-28-2012, 08:24 AM Thread Starter
Keep it factory baby!
 
gmitch23's Avatar
 
Join Date: Aug 2010
Location: Oklahoma
Age: 38
Posts: 100
 
Well the dealer couldn't find anything. The stored code said it misfired in all 4 cylinders. Its running fine now. So i guess i do nothing from here. Its a bit irritating but i guess I saved some cash.

Sent from my SAMSUNG-SGH-I717 using AutoGuide.Com Free App
gmitch23 is offline  
post #13 of 29 (permalink) Old 05-28-2012, 01:53 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Quote:
Originally Posted by gmitch23 View Post
Well the dealer couldn't find anything. The stored code said it misfired in all 4 cylinders. Its running fine now. So i guess i do nothing from here. Its a bit irritating but i guess I saved some cash.

Sent from my SAMSUNG-SGH-I717 using AutoGuide.Com Free App
I'm assuming they pulled a 300 code (multiple cylinders misfiring). Something tells me you haven't seen the last of that issue.




Last edited by greenman; 05-28-2012 at 09:31 PM.
greenman is offline  
post #14 of 29 (permalink) Old 05-28-2012, 08:45 PM Thread Starter
Keep it factory baby!
 
gmitch23's Avatar
 
Join Date: Aug 2010
Location: Oklahoma
Age: 38
Posts: 100
 
He didn't specify but i agree, its not the last of it. Maybe ill get lucky and assume i got bad gas since i filled up before i started having problems.

Sent from my SAMSUNG-SGH-I717 using AutoGuide.Com Free App
gmitch23 is offline  
post #15 of 29 (permalink) Old 05-28-2012, 09:28 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Quote:
Originally Posted by gmitch23 View Post
At 60 k I hAd A cylinoide in the throttle body replAced i believe
There are no replaceable parts in the throttle body assy but they should be carefully cleaned at least at 50K mile intervals.



greenman is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Traction control light and check engine light on after changing plugs Stel Problems and Solutions 12 02-17-2019 12:47 PM
Check Gas Cap messgae/Check Engine Light on Davidk Problems and Solutions 4 09-21-2012 11:53 AM
Flashing Engine Light: Fuel Injector? tay_tay930 Problems and Solutions 5 01-06-2012 01:03 AM
Check engine light flashing rynniki Problems and Solutions 17 12-05-2011 03:01 PM
My check engine light won't go off?!?!? NVMYG6 Problems and Solutions 3 03-12-2010 12:12 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome