Weird noise - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 05-27-2012, 12:28 PM Thread Starter
Senior Member
 
TakeOffYourPantsAndJacket's Avatar
 
Join Date: Apr 2012
Location: Chicago
Posts: 205
 
Weird noise

When ever I start my 2008 2.4L G6 it makes this weird additional sound. It's been like this for about a year. It doesn't happen everytime I start it, only about 1/5 times. It doesn't seem like its affecting the overall quality of the car. Just concerned about it and wondering if this happens to anyone else?


Sent from my Autoguide iPhone app
TakeOffYourPantsAndJacket is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 05-29-2012, 09:09 AM
Senior Member
 
Join Date: Dec 2005
Posts: 606
 
If it sometime has a rattle at start up, it probably just the valves bouncing off the pistons. It caused by the cam phaser not parking right on shut down.

I haven't heard of any ill effects. New phasers should fix it, it would be covered under powertrain warranty.
slls is offline  
post #3 of 11 (permalink) Old 05-29-2012, 01:11 PM Thread Starter
Senior Member
 
TakeOffYourPantsAndJacket's Avatar
 
Join Date: Apr 2012
Location: Chicago
Posts: 205
 
Yup it's a very awkward sounding rattle. I was just wondering if it's common on the G6's.


Sent from my Autoguide iPhone app
TakeOffYourPantsAndJacket is offline  
Sponsored Links
Advertisement
 
post #4 of 11 (permalink) Old 05-30-2012, 09:24 AM
Senior Member
 
Join Date: Dec 2005
Posts: 606
 
Yes, it is common, that's how I know about it. High mileage will cause it.
slls is offline  
post #5 of 11 (permalink) Old 05-30-2012, 03:47 PM Thread Starter
Senior Member
 
TakeOffYourPantsAndJacket's Avatar
 
Join Date: Apr 2012
Location: Chicago
Posts: 205
 
I'm only at 52000


Sent from my Autoguide iPhone app
TakeOffYourPantsAndJacket is offline  
post #6 of 11 (permalink) Old 05-31-2012, 12:26 AM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Quote:
Originally Posted by TakeOffYourPantsAndJacket View Post
When ever I start my 2008 2.4L G6 it makes this weird additional sound. It's been like this for about a year. It doesn't happen everytime I start it, only about 1/5 times. It doesn't seem like its affecting the overall quality of the car. Just concerned about it and wondering if this happens to anyone else?


Sent from my Autoguide iPhone app
I have noticed my a/c compressor is a bit noisy at cold starts in my 2.4l & I have much less mileage than you.



greenman is offline  
post #7 of 11 (permalink) Old 05-31-2012, 11:23 AM
Senior Member
 
Join Date: Dec 2005
Posts: 606
 
Quote:
Originally Posted by greenman View Post
I have noticed my a/c compressor is a bit noisy at cold starts in my 2.4l & I have much less mileage than you.
My A/C compressor was replaced at 14000 miles, service writer said it was too noisy.
slls is offline  
post #8 of 11 (permalink) Old 06-03-2012, 11:41 AM
OOBER SUPER MEMBER
 
CruisinG6's Avatar
 
Join Date: Jul 2009
Posts: 4,232
 
My compressor was also worked on, but here's the story. Brought it in for it's first oil change, they did a 27 point inspection (A/C was not part of it) I got it back and the A/C line caps were missing, they were there before. but not anymore, It soon developed a noise after. After some time it was low on fluid.
So they topped it up and replaced the belt. they also tightened the compressor because it was loose...
Got it back still made the noise, they replaced the belt again! it has since been kind of alright but I still fell something is wrong, The amount of drag I get from it seems more then it should be, but I'm not sure.

But no matter what when it was running and I had it in Drive or Reverse with my foot on the brake, it sounded like a diesel engine at idle.

That phaser problem is kind of worrying. I'll have to listen for that rattle at cold start
CruisinG6 is offline  
post #9 of 11 (permalink) Old 06-03-2012, 12:42 PM Thread Starter
Senior Member
 
TakeOffYourPantsAndJacket's Avatar
 
Join Date: Apr 2012
Location: Chicago
Posts: 205
 
The rattle is pretty noticeable. Can't miss it.


Sent from my Autoguide iPhone app
TakeOffYourPantsAndJacket is offline  
post #10 of 11 (permalink) Old 06-04-2012, 12:13 PM
OOBER SUPER MEMBER
 
CruisinG6's Avatar
 
Join Date: Jul 2009
Posts: 4,232
 
How long would you say it'll make the rattling sound for?
I've noticed sounds but I thought it was just a dry start as the oil was being pumped around...
CruisinG6 is offline  
post #11 of 11 (permalink) Old 06-04-2012, 09:22 PM Thread Starter
Senior Member
 
TakeOffYourPantsAndJacket's Avatar
 
Join Date: Apr 2012
Location: Chicago
Posts: 205
 
It'll make the noise a second after you turn it on. It'll last maybe 2-3 seconds. It's just a very odd rattle that doesn't sound normal. I've never heard it on any other car.


Sent from my Autoguide iPhone app
TakeOffYourPantsAndJacket is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird sound Diavolo Problems and Solutions 5 04-13-2012 04:48 PM
weird noise cmf9040 Problems and Solutions 5 04-11-2010 02:06 PM
weird dragging noise camps9 Problems and Solutions 6 12-21-2009 11:20 PM
Weird Code jdkd Problems and Solutions 2 09-30-2009 04:43 PM
Please Help Weird Noise. GRAFXG6 Problems and Solutions 2 04-08-2009 08:44 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome