EVAP System - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 06-15-2012, 10:39 AM Thread Starter
Junior Member
 
Join Date: May 2012
Posts: 14
 
Exclamation EVAP System

Hello everyone.

In past days my GXP sent me the P0496 Code.

The piece has been changed and the code disappeared, after a week the problem returned

The piece was the purge valve.

Other problem it's when the gasoline has been loaded above 15 gallons, i close the fill cap and when start the engine it takes three times to success the start.

Any idea to fix the problem?

Thanks to all

Regards

Last edited by FherGiron; 06-15-2012 at 10:43 AM.
FherGiron is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 06-15-2012, 01:36 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Quote:
Originally Posted by FherGiron View Post
Other problem it's when the gasoline has been loaded above 15 gallons, i close the fill cap and when start the engine it takes three times to success the start.
Replacing the evap canister purge solenoid should have cured the 'hard start after fillup' issue.



greenman is offline  
post #3 of 11 (permalink) Old 06-15-2012, 10:13 PM Thread Starter
Junior Member
 
Join Date: May 2012
Posts: 14
 
Thank you greenman, but the piece was new, the mechanic told me that, so you suggest that I have to change the solenoid valve once again?
FherGiron is offline  
Sponsored Links
Advertisement
 
post #4 of 11 (permalink) Old 06-15-2012, 10:50 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Quote:
Originally Posted by FherGiron View Post
Thank you greenman, but the piece was new, the mechanic told me that, so you suggest that I have to change the solenoid valve once again?
Are you saying that after replacing the purge valve the P0496 code has returned & you are still having the 'hard start after fillup' problem?

Can you post a picture of the part that was replaced?




Last edited by greenman; 06-15-2012 at 11:39 PM.
greenman is offline  
post #5 of 11 (permalink) Old 06-17-2012, 08:59 PM
Senior Member
 
Join Date: May 2009
Location: Portage, MI
Age: 29
Posts: 638
 
are you saying your PUTTING IN 15 GALLONS of gas when you fill up? the tank only holds 16 gallons so your probably running the damn thing outa gas if your saying that you are pumping 15 gal into the tank lol

2008 Pontiac G6 GT Dark Gray Metalic
Bought Feb 28 2009 with 24k miles now has 130k miles RIP Baby death snowplow 1-30-11
https://www.g6ownersclub.com/forum/showthread.php?t=4757

Carbon Black Metalic 2009 G6 GXP Coupe
Bought Oct 8 2010 with 35 miles

Mods so far: every single performance mod and a whole lot more, fastest NA G6
https://www.g6ownersclub.com/forum/showthread.php?t=7974

1/4 mile: [email protected] 109.23

Performance Red Metalic 2009 G6 GXP coupe
bought june 29 2012 with 3400 miles

Mods: RACE CAR- full race fuel setup and in the process of converting to RWD with a 6spd manual trans
https://www.g6ownersclub.com/forum/sh...ad.php?t=13140
1/4 mile: [email protected] 101.95
SexyG6 is offline  
post #6 of 11 (permalink) Old 06-27-2012, 05:11 PM Thread Starter
Junior Member
 
Join Date: May 2012
Posts: 14
 
Quote:
Originally Posted by greenman View Post
Are you saying that after replacing the purge valve the P0496 code has returned & you are still having the 'hard start after fillup' problem?

Can you post a picture of the part that was replaced?
Hello, what you're saying is correct, the valve was replaced and the problem returned after a week.

SexyG6, sorry it was not 15 gallons, I made bad the conversion gallons to liters, it's about 8 to 10 gallons.

Thanks to all

Regards
FherGiron is offline  
post #7 of 11 (permalink) Old 06-27-2012, 08:21 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Quote:
Originally Posted by FherGiron View Post
Hello, what you're saying is correct, the valve was replaced and the problem returned after a week.
I'm still not convinced the correct valve was replaced. Code 496 & "hard start after fill-up" are the exact symptoms of a bad purge valve.



greenman is offline  
post #8 of 11 (permalink) Old 06-27-2012, 11:16 PM Thread Starter
Junior Member
 
Join Date: May 2012
Posts: 14
 
Quote:
Originally Posted by greenman View Post
I'm still not convinced the correct valve was replaced. Code 496 & "hard start after fill-up" are the exact symptoms of a bad purge valve.
Hello Greenman.

I'm not convinced my self either, so I've decided to buy it again the valve, because last time I didn't see if the valve was new o repaired or whatever.

One last question, do you have the part number of the purge valve that has to be changed?

Thank you bro.

Best Regards
FherGiron is offline  
post #9 of 11 (permalink) Old 06-28-2012, 01:04 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Try amazon.
Search: pontiac G6 evap purge
Enter car details.

Not that likely that he put in a bad valve. But it is possible it was the wrong valve entirely. I cant say without seeing what was replaced. The purge valve hangs off the engine.




Last edited by greenman; 06-28-2012 at 01:07 PM.
greenman is offline  
post #10 of 11 (permalink) Old 07-06-2012, 12:32 PM Thread Starter
Junior Member
 
Join Date: May 2012
Posts: 14
 
Quote:
Originally Posted by greenman View Post
Try amazon.
Search: pontiac G6 evap purge
Enter car details.

Not that likely that he put in a bad valve. But it is possible it was the wrong valve entirely. I cant say without seeing what was replaced. The purge valve hangs off the engine.
Hello Bro.

This is the part number that I found.

Is it correct?

2141946

Thanks for all

Regards
FherGiron is offline  
post #11 of 11 (permalink) Old 07-10-2012, 12:31 PM Thread Starter
Junior Member
 
Join Date: May 2012
Posts: 14
 
Hello everyone.

The problem with the hard start after fill-up it's gone, tha valve was replaced and the GXP it's once again like a crow,

The part was correct is the 2141946 ac/delco

Thanks to all,

We'll keep in touch

Best regards
FherGiron is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Evap help! g6sleeer Problems and Solutions 5 11-03-2015 09:12 PM
Evap jdb2797 General Maintenance 3 11-01-2013 08:41 AM
Purge Evap Solenoid ThreeDog Problems and Solutions 7 03-26-2012 09:23 AM
evap vent solenoid eggnore General Maintenance 2 03-15-2012 03:11 PM
EVAP canister jester General Maintenance 0 03-09-2009 04:40 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome