Passenger Side Low Beams Not Working - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 07-03-2012, 02:12 PM Thread Starter
Junior Member
 
Join Date: Jul 2012
Posts: 2
 
Passenger Side Low Beams Not Working

I have an '07 G6 V6 and my low beam went out recently. I tried two brand new bulbs in it and it still doesn't appear to be working. Any ideas?
kiosan509 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 07-03-2012, 03:51 PM
Senior Member
 
Firedown's Avatar
 
Join Date: Sep 2010
Location: MA
Posts: 392
 
Check the fuse.

Mods: GT-R exhaust, CRABs O3 w/FPU, 35% tint, 5000K HID lows/fogs, upper/lower recessed grilles, Racingline strut bar, concept darts, white LEDs everywhere
Firedown is offline  
post #3 of 6 (permalink) Old 07-03-2012, 06:12 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
+1
Check fuse 9 (IIRC) under the hood. If it's blown, it may just blow again after replacing it. If it does, you likely have a short to ground somewhere in the circuit. If it does not, you should be good to go. It's an extremely good idea to use dielectric silicone gel on both the lamp & pigtail contacts to prevent corrosion buildup & head off future problems (usually caused by corrosion).



greenman is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 07-04-2012, 05:34 PM Thread Starter
Junior Member
 
Join Date: Jul 2012
Posts: 2
 
I checked the fuses and they all appear to be intact. Maybe a short or corrosion where the bulb plugs?
kiosan509 is offline  
post #5 of 6 (permalink) Old 07-05-2012, 11:37 AM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Yes. Now check the bulb socket & the pigtail connector. You'll have to pull back the bumper cover on that side. If that is the issue you should assume the other side is doing the same thing & will fail soon enough. It's a very common issue. Corrosion builds up, increases the resistance to current flow across the connector which then causes local overheating & melting of the connector.



greenman is offline  
post #6 of 6 (permalink) Old 07-06-2012, 12:07 PM
Since 1986.
 
Join Date: Mar 2009
Location: Bondurant, IA
Posts: 19
 
https://www.g6ownersclub.com/forum/sh...6696#post96696

I would like to see a recall to correct this issue because it is so common.
dstryr is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Replacing passenger side mirror assembly Taskona Problems and Solutions 0 04-04-2012 07:25 AM
HID Passenger side won't work? Cole Appearance Modifications and Lighting 7 10-12-2010 10:35 AM
Help Unlocking Passenger Side Door nothincame2mind Problems and Solutions 12 08-10-2009 02:37 PM
Water leaking in on Passenger side cnagy65 Problems and Solutions 45 04-29-2009 09:21 AM
Passenger Side Mirror nbx326 Problems and Solutions 1 06-08-2007 08:07 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome