Power seat - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 05-14-2006, 05:26 PM Thread Starter
 
Join Date: Apr 2006
Posts: 35
 
Power seat

I have a 2006 GTP coupe with power driver's seat. (Wonder how come a power passenger seat is not even an option?)
Almost since new, the seat would stop functioning in the forward/back mode while retaining all other functions. The dealer investigated and found the switch had come unplugged so reconnected it and that seemed to end the problem except about a few weeks later, the seat started jamming again and so this time the dealer put in a new switch. Within three days this time the problem was back.
The 'sticking' lasts anywhere from a few minutes to two or three days; ever try to drive a standard when the seat is stuck in the full 'back' position!??!
Has anyone either experienced a similar problem or has found a solution to the problem?
GTP driver
GTPdriver is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 10-17-2009, 03:42 PM
 
Join Date: Jun 2006
Posts: 28
 
My wife's 05 GT power seat started acting up today. It's stuck in the full back position and will not go forward. Up and down and tilt work fine...but no forward or back.
I have not pulled the seat yet to see if there is anything jamming it. Nothing appears to be.

I can hear the motor try to engage and can see the shaft move like it wants to turn but can't. Not sure if it is internal to the motor or if it is in the track itself.


Luckily, we have the adjustable pedals so she can move them toward her so she can still drive the car!
Cobra1365 is offline  
post #3 of 13 (permalink) Old 10-17-2009, 04:01 PM
Senior Member
 
Join Date: Aug 2009
Posts: 286
Blog Entries: 1
 
Yes I had the same problem. I ohmed out the switch and it worked fine. I cleaned all the contacts and the plug with electrical contact cleaner. No problems since. You will have to remove the switch to do this as you don't want to get that contact cleaner on the plastic bits.

I used LPS electro contact cleaner. You should be able to get it at a hardware store or industrial supply place.
jetmech_5 is offline  
Sponsored Links
Advertisement
 
post #4 of 13 (permalink) Old 10-18-2009, 06:41 AM
 
Join Date: Jun 2006
Posts: 28
 
Jetmech,
Help me out here please.
Do you mean the control switch on the side of the seat or where it connects to the motor?
My switch seems to work fine, just that the motor won't turn. I can see/feel/hear the motor clicking like it wants to, but it's like there is something jamming it.

Thanks
Cobra1365 is offline  
post #5 of 13 (permalink) Old 10-18-2009, 12:14 PM
 
Join Date: Dec 2007
Posts: 195
 
obviously a dead seat motor ... you can use a multimeter to see if the motor is getting power to it ... if it is and it's still not moving then it's a bad motor ... if it's not getting power then there's a problem in the wires somewhere
daygon is offline  
post #6 of 13 (permalink) Old 10-18-2009, 01:37 PM
Senior Member
 
Join Date: Aug 2009
Posts: 286
Blog Entries: 1
 
Well mine did not click it just stopped working. Yes I cleaned all the contacts and plugs from the switch to the motor. You will have to pop the switch out and the little leaver off.

If it is clicking or making noise like it wants to move, you may have the tracks binding. here is instructions if seat is out of alignment.

If the seat is or was ever removed you will have to do this.

The fore/aft manual adjuster is composed of an inboard track assembly (5), and outboard track (4) assembly, and an adjuster handle (1). Each track assembly is made of an upper track (2) and a lower track (3). Both tracks need to be aligned prior to installing in the vehicle.

To align the front seat tracks, do the following:
1. Remove the seat from the vehicle.
2. Put the seat upside down on a table, or on the floor as shown.

3. Unlock both tracks by pushing the adjuster handle down.

4. While pushing the adjuster handle down, move each lower track rearward until contact between the end travel stops.

5. Release the adjuster handle.

6. Move each lower track forward until an audible noise is heard, indicating that the track is fully locked.

7. At this stage both manual tracks are aligned.
8. Measure the overhang from the front edge of the plastic end cap (1) on the lower track to the front edge of the upper track (2). Measurement for each track must be 138 mm or as close as possible.

9. Install the seat in the vehicle without touching the adjuster handle. Then tighten the rear bolts prior to any track adjustment.

10. While sitting in the seat, cycle the tracks fore/aft and lock the tracks at different positions. Check to see whether the tracks are aligned.

11. Visually inspect the tracks, adjust the upper tracks flush with the front of the lower tracks. Check that the configuration in locked position is identical for both inboard (1) and outboard tracks (2).

You may just want to look and see if there is something stuck in the track. Cigarette lighter, candy, 300 year old french fry...ect
jetmech_5 is offline  
post #7 of 13 (permalink) Old 10-19-2009, 10:19 AM
 
Join Date: Jun 2006
Posts: 28
 
Thanks Jetmech.

BTW, what acft do you work on?
Cobra1365 is offline  
post #8 of 13 (permalink) Old 10-19-2009, 11:10 PM
Senior Member
 
Join Date: Aug 2009
Posts: 286
Blog Entries: 1
 
Quote:
Originally Posted by Cobra1365 View Post
Thanks Jetmech.

BTW, what acft do you work on?

I"m an engine tech for the most part. GE90, Rolls Royce BR 715/710, GE CF34-8/-10, Rolls Royce T56, 54H60 Props, T700, Rolls Royce T64...and a host of other engines and airframes.
jetmech_5 is offline  
post #9 of 13 (permalink) Old 02-12-2010, 08:02 AM
Member
 
stevenson_gt's Avatar
 
Join Date: Feb 2010
Posts: 48
 
loud noise in seat ,viration

i moved my driver seat in the back, up and down when i did it made a loud rumble or vibration noise still moved up and down but just really loudily set on the seat and its even louder i looked under the seat and the cyclined is not hitting off anything it seems to be inside it anyone help me out
stevenson_gt is offline  
post #10 of 13 (permalink) Old 10-17-2013, 12:40 PM
Junior Member
 
Join Date: Jul 2010
Posts: 14
 
Mine is not a bad motor it's the worm gear in the track, it's jammed.
kimmer is offline  
post #11 of 13 (permalink) Old 05-27-2016, 03:58 PM
Junior Member
 
Join Date: May 2016
Posts: 2
 
2009 G6 Driver Side Powerseat suddenly stopped working

Check the obvious----saw suggestion of connector coming loose as possible problem. Pulled seat back lever off seat (grab front and back of lever and pull it straight to the side of the car), removed long screw in the front of the plastic housing the switch no the smaller screw under where the seat lever was hiding it. Pulled the bracket off and could easily see that the connector had come loose. Pushed it back together and reassembled. Works fine.
WeekendMech is offline  
post #12 of 13 (permalink) Old 05-27-2016, 04:09 PM
Junior Member
 
Join Date: May 2016
Posts: 2
 
Sorry---spell check not working. I meant to say "removed long screw in the front of the plastic housing the switch AND the smaller screw which was hidden under the seat lever."
WeekendMech is offline  
post #13 of 13 (permalink) Old 05-28-2016, 03:51 PM
Junior Member
 
Lion_9998's Avatar
 
Join Date: May 2016
Location: Virginia
Posts: 3
 
thanks, guys!
your information is really helpful))))
Lion_9998 is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome