Service Traction Control, Cruise Control, Brake lights - Pontiac G6 Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 18 (permalink) Old 07-21-2012, 09:11 AM Thread Starter
Junior Member
 
Join Date: Jul 2012
Posts: 9
 
Service Traction Control, Cruise Control, Brake lights

Hello. My 2008 G6 recently had the information center display that my vehicle needed to have its Traction Control serviced. The brake light stay on all the time and the cruise control won't engage. Put it in the shop a couple times and had the brake sensor switch replaced as well as the brake control module. Does anyone have any wisdom to what might be wrong. I would appreciate some input. Thanks.


Sent from my iPhone using Autoguide
Randothecomando is offline  
Sponsored Links
Advertisement
 
post #2 of 18 (permalink) Old 07-21-2012, 09:27 AM
OOBER SUPER MEMBER
 
CruisinG6's Avatar
 
Join Date: Jul 2009
Posts: 4,232
 
Cruise control probably wont work because the brake lights stay on, It's actually (stupidly) a common issue.
Start by disconnecting the battery.
Go to the passenger fuse box (In the center console passenger side)
And unplug the large plugs from the BCM.
Clean the connectors the best you can.
Apply Dielectric grease
Plug it all back in and reconnect the battery.

The brakes lights should work properly, and hopefully the cruise control would work now as well.

Here's a video that outlines those steps:

He doesn't disconnect the battery and doesn't actually clean the connectors in the video. Just applies the dielectric grease and puts it back together, Pretty sure they have repeat issues. If you clean it you should be fine. He also just does one connector. It wouldn't hurt to do the other one as well.
CruisinG6 is offline  
post #3 of 18 (permalink) Old 07-21-2012, 09:48 AM Thread Starter
Junior Member
 
Join Date: Jul 2012
Posts: 9
 
Cool man. Thanks. I'll try that and let you know how that works out.


Sent from my iPhone using Autoguide
Randothecomando is offline  
Sponsored Links
Advertisement
 
post #4 of 18 (permalink) Old 07-21-2012, 10:58 AM
OOBER SUPER MEMBER
 
CruisinG6's Avatar
 
Join Date: Jul 2009
Posts: 4,232
 
No problem. I forgot to mention, They sell a spray can Electronics Cleaner. You can buy that, give it a good spray and blow it dry with a can of compressed air. Unless it's a product that dries pretty quickly on it's own.
CruisinG6 is offline  
post #5 of 18 (permalink) Old 07-21-2012, 11:19 AM Thread Starter
Junior Member
 
Join Date: Jul 2012
Posts: 9
 
Cool. I'll add the to my list. Hope it work. Just got my G6 in February and I love it, except for these few things.


Sent from my iPhone using Autoguide
Randothecomando is offline  
post #6 of 18 (permalink) Old 07-21-2012, 02:31 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
So I'm curious. Who replaced the BPP sensor & EBCM for this issue? Did they complete the BCM connector removal/reinstallation as specified by GM for this issue first?

I just noticed the guy in the video did not remove the correct connector. He pulled C1 but the culprit connector is C2 (marked J2 on the BCM) which is above C1 (marked J1 on the BCM) & facing sideways. That is the problem connector specified in the bulletin for the brake lamp issue. Since you are in there anyway I would just do both C1 & C2. What actually "cleans" the corrosion is the simple act of removing & reinstalling the connector a few times. The rubbing of the contacting surfaces together is essentially like using an abrasive. Then by spraying with electrical contact cleaner at least some of the corrosion is washed away. The layer of corrosion is so thin usually you can't even see it (unless you are really looking for it). But it's enough to increase the resistance across the metal contacting surfaces which results in the BCM getting a "false" signal.

Here's the bulletin:


Service Manual | Document ID: 2294853
--------------------------------------------------------------------------------

#08-05-22-009A: Intermittently Brake Lights (Stop Lamps) Do Not Function Correctly, Extended Travel to Shift Out of Park, Cruise Control Inoperative, DTC C0161/C0277 Set (Perform Repair as Outlined) - (Jun 25, 2009)


Subject: Intermittently Brake Lights (Stop Lamps) Do Not Function Correctly, Extended Travel to Shift Out of Park, Cruise Control Inoperative, DTCs C0161/C0277 Set (Perform Repair as Outlined)


Models: 2004-2007 Chevrolet Malibu, Malibu Maxx

2008 Chevrolet Malibu Classic

2005-2009 Pontiac G6

2007-2009 Saturn AURA




--------------------------------------------------------------------------------

This bulletin is being revised to shorten the required procedure and revise the Warranty Information. Please discard Corporate Bulletin Number 08-05-22-009 (Section 05 - Brakes).


--------------------------------------------------------------------------------

Condition
Some customers may comment that intermittently the brake lights do not function correctly. Other symptoms may include extended pedal travel required to shift out of PARK, cruise control does not function correctly, and DTC C0161 and/or C0277 may be set.

Cause
The most likely cause of this condition is high resistance due to terminal fretting corrosion in the body control module (BCM) C2 connector (specifically pins C2-18, C2-31 and C2-59).

Correction
DO NOT replace the BCM for this condition. Disconnecting the C2 connector, adding dielectric lubricant and reconnecting the C2 connector per the procedure below will correct the high resistance condition due to terminal fretting corrosion.

Remove the right side front floor console side trim panel to access to the Body Control Module (BCM).
Locate the C2 connector on the BCM.
Unlatch the C2 connector and disconnect the C2 connector from the BCM.
Apply dielectric lubricant (clear gel) GM P/N 12377900 (in Canada, use P/N 10953529), or the equivalent, on the BCM C2 pins (apply with a one-inch nylon bristle brush) on all the C2 connector pins (this will treat the pins against fretting corrosion).
Reconnect the C2 connector back on the BCM and re-latch. Wipe away any access lubricant..
Reinstall the right side front floor console side trim panel.
Using the Tech 2, check that the BPPS ratio is equal to BPPS learned home when the brake pedal is not depressed.
If they are equal, brake lamps should be operating correctly and no further steps are necessary.

If they are not equal, perform the Brake Pedal Position Sensor Calibration procedure in SI to complete the repair.

Check the brake lights for proper operation. If incorrect, refer to SI and perform normal diagnostics.



greenman is offline  
post #7 of 18 (permalink) Old 07-21-2012, 02:44 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
So I just reread (more carefully) the original post & I may have screwed up my answer. Are the brake lamps (including the top-mount lamp) lit constantly with the key on? So the brake pedal has no affect on the lamps? I need clarification.



greenman is offline  
post #8 of 18 (permalink) Old 07-21-2012, 04:02 PM Thread Starter
Junior Member
 
Join Date: Jul 2012
Posts: 9
 
Yes the top as as well. All three remain on when the key is in.


Sent from my iPhone using Autoguide
Randothecomando is offline  
post #9 of 18 (permalink) Old 07-21-2012, 04:20 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Quote:
Originally Posted by Randothecomando View Post
Yes the top as as well. All three remain on when the key is in.
So that's a different issue than the BCM connector fretting corrosion problem. And so far they have replaced the BPP sensor & the EBCM & nothing else. Did they find any codes/DTCs?



greenman is offline  
post #10 of 18 (permalink) Old 07-21-2012, 04:50 PM Thread Starter
Junior Member
 
Join Date: Jul 2012
Posts: 9
 
Click image for larger version

Name:	ImageUploadedByAutoguide1342910979.538070.jpg
Views:	1041
Size:	30.5 KB
ID:	3343



Sent from my iPhone using Autoguide
Randothecomando is offline  
post #11 of 18 (permalink) Old 07-21-2012, 04:50 PM Thread Starter
Junior Member
 
Join Date: Jul 2012
Posts: 9
 
Wonder if this could have something to do with it. Lol


Sent from my iPhone using Autoguide
Randothecomando is offline  
post #12 of 18 (permalink) Old 07-21-2012, 05:14 PM
OOBER SUPER MEMBER
 
CruisinG6's Avatar
 
Join Date: Jul 2009
Posts: 4,232
 
WOW! Talk about corrosion!
CruisinG6 is offline  
post #13 of 18 (permalink) Old 07-21-2012, 07:09 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Quote:
Originally Posted by Randothecomando View Post
Wonder if this could have something to do with it. Lol
To tell you the truth, I really doubt it but it definitely needs tending to.



greenman is offline  
post #14 of 18 (permalink) Old 07-21-2012, 11:27 PM Thread Starter
Junior Member
 
Join Date: Jul 2012
Posts: 9
 
Lol


Sent from my iPad using Autoguide
Randothecomando is offline  
post #15 of 18 (permalink) Old 07-22-2012, 01:10 PM Thread Starter
Junior Member
 
Join Date: Jul 2012
Posts: 9
 
How big a tube of dielectric grease would anyone buy? .33 oz or 3 oz tube to get the job done?


Sent from my iPhone using Autoguide
Randothecomando is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Traction Control/ABS lights on 21likeaG6 Problems and Solutions 1 11-09-2011 01:15 PM
service traction control CK09G6GT Problems and Solutions 1 09-01-2011 11:51 PM
HELP! SES and Traction Control lights keep coming on! race71 Problems and Solutions 1 08-03-2010 11:20 AM
Cruise control, brake lights, shifting to drive luvmypontiac32 Problems and Solutions 5 07-29-2010 12:24 PM
traction control.. morris's-G6-GTP General Maintenance 5 01-31-2010 05:55 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome