Transmission Solinoid??? - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 07-30-2012, 04:16 PM Thread Starter
Junior Member
 
Join Date: Feb 2009
Posts: 5
 
Transmission Solinoid???

I have a little devil... Red 06 G6 V6... 666... lol

I was driving on the expressway, cruise control set at around 68. The car seemed to buck just slightly, then the check engine light came on.

The car continued to drive ok after that.

After I got off the highway, i noticed that even though the car was running, it seemed a little sluggish. Almost like i was driving with the emergency brake on, but it was fine when it got up to speed.

I also noticed that the cruise control will no longer engage.

I stopped at Autozone and used the scan tool they have it it said the code was for the transmission solinoid.

Can it really be that simple, or is there possibly another cause that will make it appear to be the solinoid ( as i said, the cruise control stopped at the same time, and i dont see how that is related, unless it may be a possible vacuum leak?).

Thanks
Corysf is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 07-30-2012, 07:25 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
I would need the exact code to try to help. There are several solenoids in an automatic tranny.




Last edited by greenman; 07-31-2012 at 02:13 PM.
greenman is offline  
post #3 of 6 (permalink) Old 08-01-2012, 09:00 AM Thread Starter
Junior Member
 
Join Date: Feb 2009
Posts: 5
 
Thanks, I will have to swing by autozone again this afternoon and rescan it, the light is back on again, as I knew it would be.

I don't know what i was thinking when i said "can it really be that simple"... for some reason i was thinking this was a solenoid that was easily accessable, not INSIDE the tranny.

Now I can ( and have ) work on just about anything, but just how difficult is it to replace one of these.

Is it possible it is just the Tan Wire thing i was reading about as well? if so, where exactly is that and how can I inspect it.

Will post the code here later... Thanks,
Corysf is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 08-01-2012, 04:07 PM Thread Starter
Junior Member
 
Join Date: Feb 2009
Posts: 5
 
Ok, the codes it is throwing are P0751 and P0753. the descriptions it gave was as follows. P0751, Shift Solenoid A performance or Stuck off
P0753, Shift Solenoid A Electical
and then there was another message that said "freq repaired Fix 1-replaced 2-3 shift solenoid.

Thanks
Corysf is offline  
post #5 of 6 (permalink) Old 08-01-2012, 08:13 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Could be a bad 1-2 shift solenoid valve (it's internal to the tranny) or it could be a tranny harness issue. Either way, it's really a job for a pro shop. If it were mine, I'd clear the codes (if you didn't yet) & drive it & see if they return. In my experience, a dealer will charge more than a tranny specialty shop. Wish I had better news.



greenman is offline  
post #6 of 6 (permalink) Old 08-02-2012, 10:03 AM
Senior Member
 
Join Date: Dec 2005
Posts: 606
 
First thing I would do is the corrosion pin lube on the TCM connectors, worth a try.
slls is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
3.9L gtp transmission??? jessica06gtp General Maintenance 3 03-10-2012 09:36 PM
transmission replaced and still same transmission problem Sterling Problems and Solutions 7 09-20-2011 03:53 PM
Transmission tonyg314 Problems and Solutions 3 04-22-2011 12:25 PM
Transmission? wildkyle90 G6 GXP Discussion 3 02-18-2010 06:24 AM
F40 Transmission RandomTask Powertrain Performance Modifications 2 12-05-2008 12:30 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome