Acceleration jerk - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 07-31-2012, 12:08 PM Thread Starter
Senior Member
 
BAK_yn's Avatar
 
Join Date: Jun 2012
Location: Oklahoma
Age: 25
Posts: 189
 
Garage
Acceleration jerk

I don't know if this a big problem or not but I'm on a trip to go see a family member 3 hours away. I'm about 2 hours in had cruise control at 75. I slowed down for traffic and when I accelerated it felt like it jerked when trying to get higher rpms. Kinda like the jerk when your about to kill manual. (It's an auto) I didn't think anything of it till i was in a town going slower nadir did it again at a lower speed. Could the 110 degree heat and me driving for 3 hours have anything to do with it?
BAK_yn is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 07-31-2012, 02:37 PM
OOBER SUPER MEMBER
 
CruisinG6's Avatar
 
Join Date: Jul 2009
Posts: 4,232
 
I would think the heat could have something to do with it, And having the A/C on as well, I'm fairly certain the PCM alters the way the engine runs to prevent damage to the compressor.

Any check engine light or did you scan for any codes?
CruisinG6 is offline  
post #3 of 15 (permalink) Old 07-31-2012, 02:44 PM Thread Starter
Senior Member
 
BAK_yn's Avatar
 
Join Date: Jun 2012
Location: Oklahoma
Age: 25
Posts: 189
 
Garage
No lights or codes. I made it to the place and it's cooling off now. We'll see if it just had to do with the heat. Hopefully as I've only had it since February and just hit 80k.
BAK_yn is offline  
Sponsored Links
Advertisement
 
post #4 of 15 (permalink) Old 07-31-2012, 06:30 PM
Token Asian
 
Join Date: Jul 2012
Location: Michigan
Posts: 28
 
Have you ever had your trans fluid changed? If you haven't being at 80k the detergent in the trans fluid might have burnt up and that heat just only makes it worse to the point where it kind of just sloshes around. So start with that maybe.
ForeignAsian is offline  
post #5 of 15 (permalink) Old 07-31-2012, 08:01 PM Thread Starter
Senior Member
 
BAK_yn's Avatar
 
Join Date: Jun 2012
Location: Oklahoma
Age: 25
Posts: 189
 
Garage
Quote:
Originally Posted by ForeignAsian View Post
Have you ever had your trans fluid changed? If you haven't being at 80k the detergent in the trans fluid might have burnt up and that heat just only makes it worse to the point where it kind of just sloshes around. So start with that maybe.
Okay thanks. I'll check it out.
BAK_yn is offline  
post #6 of 15 (permalink) Old 08-02-2012, 12:32 PM
Keep it factory baby!
 
gmitch23's Avatar
 
Join Date: Aug 2010
Location: Oklahoma
Age: 38
Posts: 100
 
When my car did that it was a solenoid valve stuck open. It jerks like someone rear ending you when shifting gears? My car didnt give a check engine light either.
gmitch23 is offline  
post #7 of 15 (permalink) Old 08-02-2012, 10:58 PM Thread Starter
Senior Member
 
BAK_yn's Avatar
 
Join Date: Jun 2012
Location: Oklahoma
Age: 25
Posts: 189
 
Garage
How do you check for that?
BAK_yn is offline  
post #8 of 15 (permalink) Old 08-03-2012, 10:00 PM
Keep it factory baby!
 
gmitch23's Avatar
 
Join Date: Aug 2010
Location: Oklahoma
Age: 38
Posts: 100
 
Quote:
Originally Posted by BAK_yn View Post
How do you check for that?
Dealer, they said there was a code in the history. The cel never came on though. In fact, they didn't even find it until they caught the car doing it.
gmitch23 is offline  
post #9 of 15 (permalink) Old 08-04-2012, 02:51 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Quote:
Originally Posted by gmitch23 View Post
Dealer, they said there was a code in the history. The cel never came on though. In fact, they didn't even find it until they caught the car doing it.
Unfortunately, there are a lot of codes the control modules can set that won't light up the CEL or anything else in the cluster.



greenman is offline  
post #10 of 15 (permalink) Old 08-04-2012, 07:01 PM Thread Starter
Senior Member
 
BAK_yn's Avatar
 
Join Date: Jun 2012
Location: Oklahoma
Age: 25
Posts: 189
 
Garage
hmm well i wonder if it is going to be a big problem we'll see i guess..
BAK_yn is offline  
post #11 of 15 (permalink) Old 08-06-2012, 06:29 PM
Senior Member
 
Join Date: Dec 2005
Posts: 606
 
The jerk is caused by being in 2 gears momentarily at the same time, not good, things can break.
slls is offline  
post #12 of 15 (permalink) Old 08-06-2012, 10:21 PM Thread Starter
Senior Member
 
BAK_yn's Avatar
 
Join Date: Jun 2012
Location: Oklahoma
Age: 25
Posts: 189
 
Garage
I'm new to all this. So how would I go about finding a fix. Dealer I'm guessing? It has 83k
BAK_yn is offline  
post #13 of 15 (permalink) Old 08-07-2012, 02:50 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Quote:
Originally Posted by BAK_yn View Post
I'm new to all this. So how would I go about finding a fix. Dealer I'm guessing? It has 83k
If your powertrain warranty hasn't yet expired, you should get the issue documented by a dealer before it does. Unfortunately, you'll have to pay a dealer diagnostic fee (around $100). Yes, it's a racket.

If it has expired, any tranny shop can read any tranny code that may have popped. Call a few & ask what a diagnosis cost. If there are no codes & they can't easily reproduce the complaint, who knows what they'll tell you.

I'd get the fluid&filter changed which may help.



greenman is offline  
post #14 of 15 (permalink) Old 08-08-2012, 03:34 PM Thread Starter
Senior Member
 
BAK_yn's Avatar
 
Join Date: Jun 2012
Location: Oklahoma
Age: 25
Posts: 189
 
Garage
Taking it to the dealer in the morning. Ill let you guys know how it goes.
BAK_yn is offline  
post #15 of 15 (permalink) Old 08-09-2012, 08:09 AM Thread Starter
Senior Member
 
BAK_yn's Avatar
 
Join Date: Jun 2012
Location: Oklahoma
Age: 25
Posts: 189
 
Garage
At the dealer just went for a drive with the guy and tech 2. There wasnt any codes and as usual nothing ever goes wrong when you have someone figure out what's wrong. Decided to see if it worsens and take it back if it does.
BAK_yn is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Acceleration lag with A/C on TakeOffYourPantsAndJacket Problems and Solutions 21 07-10-2012 07:47 PM
Transmission jerk? Coupe_Evo_V Problems and Solutions 19 04-08-2011 10:32 PM
Steering jerk. Jcg6 Problems and Solutions 3 01-15-2011 03:58 AM
Hesitation during acceleration... bendaddabbo Problems and Solutions 0 07-28-2010 12:09 PM
Engine miss/jerk at high speed G6Dave Problems and Solutions 2 02-04-2010 11:37 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome