Odometer reset after changing battery - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 12-04-2007, 03:07 PM Thread Starter
 
Join Date: Dec 2007
Posts: 1
 
Odometer reset after changing battery

I did a search but found nothing related.

I have a 2005 G6 that had about 50K miles on it. The car would not start or jump so I changed the battery. When started the car my electronic odomoter showed zero! It is counting, but has anyone heard of this? Thank you in advance.
brich1975 is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 12-13-2007, 03:57 PM
 
Join Date: Mar 2005
Posts: 304
 
Nope, but I wish mine would reset! It sure will raise trade in value!!!
Hambone is offline  
post #3 of 15 (permalink) Old 12-31-2007, 03:36 PM
 
Join Date: Dec 2007
Posts: 195
 
i heard that computers on the G6 are really fragile and don't like it when you take the battary off ...

that's kind of cool though ... i wish mine would reset so i could sell that thing
daygon is offline  
Sponsored Links
Advertisement
 
post #4 of 15 (permalink) Old 02-03-2008, 11:18 PM
 
Join Date: Feb 2008
Posts: 1
 
Thumbs down

Quote:
Originally Posted by brich1975 View Post
I did a search but found nothing related.

I have a 2005 G6 that had about 50K miles on it. The car would not start or jump so I changed the battery. When started the car my electronic odometer showed zero! It is counting, but has anyone heard of this? Thank you in advance.

This is weird, my roommate's girlfriend just had this happen to her car, not quite the same scenario but it had a dead battery, tried to jump it with a jump box and it reset the mileage. Was at 40000 ish. brought it to the dealer to report that this happened and they treated her like a leper and accused her of tampering with it. (its a leased car)

Now the car it sitting on the street with the horn honking and interior lights flickering on and off BY ITSELF, like the panic is going off but go to turn the panic off and it goes into a fit again and starts honking!!

What a POS!!!
minzbig is offline  
post #5 of 15 (permalink) Old 02-05-2008, 06:33 PM
 
Join Date: Dec 2007
Posts: 195
 
Quote:
Originally Posted by minzbig View Post
This is weird, my roommate's girlfriend just had this happen to her car, not quite the same scenario but it had a dead battery, tried to jump it with a jump box and it reset the mileage. Was at 40000 ish. brought it to the dealer to report that this happened and they treated her like a leper and accused her of tampering with it. (its a leased car)

Now the car it sitting on the street with the horn honking and interior lights flickering on and off BY ITSELF, like the panic is going off but go to turn the panic off and it goes into a fit again and starts honking!!

What a POS!!!
sounds like there's a circuit somewhere in the system ... check the fuses ... the dealer should be able to take care of it
daygon is offline  
post #6 of 15 (permalink) Old 01-03-2011, 08:29 AM
Junior Member
 
Join Date: Jan 2011
Posts: 2
 
Same thing happened to me...dealer has no clue

This morning the same happened with my 2005 G6 sedan. Car started fine this morning. Ran a few errands, came back to start the car and nothing. Tried turning the key to get it to start several time and nothing. Tried to use the remote start and thats when all lights started flickering and the all electronics had reset. Someone jumped it off and all electronics were reset including the odometer. Just curious as to what may have happened or if there is possibly some computer damage

Any help or info would be greatly appreciated.
blackbeauty is offline  
post #7 of 15 (permalink) Old 01-26-2012, 08:29 PM
Junior Member
 
Join Date: Jan 2012
Posts: 5
 
Hello,
I just wanted to know if anybody found a solution to this problem. Same thing happened to me today.
Jokerswild 1213 is offline  
post #8 of 15 (permalink) Old 01-26-2012, 09:01 PM
Moderator Member Thingy
 
Abyssul's Avatar
 
Join Date: Jun 2009
Location: Myrtle Beach, SC
Posts: 1,330
 
Send a message via AIM to Abyssul Send a message via MSN to Abyssul
Disconnect your negative terminal first and leave it for 15 minutes then insert your key at the ignition before connecting your negative battery terminal.

2006 Pontiac G6 GT

Appearance Mods: AIT front bumper, Black Eagle Eye Halo Projectors with DDM Tuning 5000k HIDs 35w,
GT door decals, painted interior trim, red calipers, de-chromed window trim
Performance Mods: WAMS tune, CRABS, aftermarket sound system

Abyssul is offline  
post #9 of 15 (permalink) Old 01-27-2012, 06:39 AM
Sparky
 
Join Date: Oct 2011
Location: Canada
Posts: 26
 
For the people who have this problem; Are you all driving 05 G6's??
androoze is offline  
post #10 of 15 (permalink) Old 01-27-2012, 09:01 AM
Junior Member
 
Join Date: Jan 2012
Posts: 5
 
Abyssul I will try that

Yes mine is an 05

Last edited by Jokerswild 1213; 01-27-2012 at 09:12 AM.
Jokerswild 1213 is offline  
post #11 of 15 (permalink) Old 01-27-2012, 09:19 AM
Junior Member
 
Join Date: Jan 2011
Posts: 2
 
Yep I'm driving an 05. Would like to know if removing the negative terminal works.
blackbeauty is offline  
post #12 of 15 (permalink) Old 01-29-2012, 07:41 PM
Junior Member
 
Join Date: Jan 2012
Posts: 5
 
It didnt work for me. Was this a fix that worked for you before
Jokerswild 1213 is offline  
post #13 of 15 (permalink) Old 01-29-2012, 08:36 PM
Moderator Member Thingy
 
Abyssul's Avatar
 
Join Date: Jun 2009
Location: Myrtle Beach, SC
Posts: 1,330
 
Send a message via AIM to Abyssul Send a message via MSN to Abyssul
Quote:
Originally Posted by Jokerswild 1213 View Post
It didnt work for me. Was this a fix that worked for you before
Never had the problem. Just something I googled and it was suggested.

2006 Pontiac G6 GT

Appearance Mods: AIT front bumper, Black Eagle Eye Halo Projectors with DDM Tuning 5000k HIDs 35w,
GT door decals, painted interior trim, red calipers, de-chromed window trim
Performance Mods: WAMS tune, CRABS, aftermarket sound system

Abyssul is offline  
post #14 of 15 (permalink) Old 02-01-2012, 01:41 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
That odometer reset behavior was due to a firmware flaw in certain GM BCMs. It either had that "feature" or it did not. Can't remember now if there was a reflash that fixed it or it required a new BCM but I'm tending toward the latter.



greenman is offline  
post #15 of 15 (permalink) Old 06-27-2017, 08:48 PM
Junior Member
 
Join Date: Jun 2017
Posts: 1
 
I change the battery to G6 pontiac 2008 and the stop run

Quote:
Originally Posted by brich1975 View Post
I did a search but found nothing related.

I have a 2005 G6 that had about 50K miles on it. The car would not start or jump so I changed the battery. When started the car my electronic odomoter showed zero! It is counting, but has anyone heard of this? Thank you in advance.
mcumbe is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome