Camshaft Problem - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 02-06-2008, 02:10 PM Thread Starter
 
Join Date: Jul 2007
Posts: 13
 
Camshaft Problem

Brought my 2007 G6 GTP (3.6L) in for service Monday .Was driving down the highway, the Traction OFF light came on, and the car started misfiring, surging, bucking, stumbling...you name it, it did it! Was able to make it a few miles to work. Then I restarted the car....seemed to run ok as long as I applied at least light throttle....on coast, the car bucked..(it has always done that, but now much worse) Report back from the dealer is that it threw a code P0021, which says the cam position sensor was giving faulty readings. They did a partial teardown on one side, and found the camshaft had excessive lateral play, which at the extremes of play would cause the camshaft sensor to not read. The play had also caused significant wear on the cylinder head, so both cylinder head and camshaft need to be replaced. Unfortunately, they are having trouble locating parts. This is the third one they have seen with this issue, and GM is certainly aware of it. Dont know why i keep buying Pontiac....each and everyone has been a nightmare! Car has less than 11,000mi.
cdsipjp is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 02-10-2008, 01:40 AM
Member
 
TONY TAT2's Avatar
 
Join Date: Dec 2007
Location: NJ
Posts: 58
 
Sorry to hear about your problem.When my old Sunbird was in for waranty work I would get a Loaner & drive it like I stoled it!

07/G5,85&78 VETTE'S,,,,WIFE 08/G6
TONY TAT2 is offline  
post #3 of 5 (permalink) Old 02-11-2008, 04:08 PM Thread Starter
 
Join Date: Jul 2007
Posts: 13
 
It gets better!

Apparently there are no cylinder heads and no cam shafts available. I'm told the repair will take 3-4 weeks.
cdsipjp is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 02-11-2008, 06:32 PM
Member
 
TONY TAT2's Avatar
 
Join Date: Dec 2007
Location: NJ
Posts: 58
 
Hope thay can find ya some parts faster.Be sure ya keep a record of what thay done incase you have problems in the future.Please keep us updated,thanks.

07/G5,85&78 VETTE'S,,,,WIFE 08/G6
TONY TAT2 is offline  
post #5 of 5 (permalink) Old 02-25-2008, 09:38 AM Thread Starter
 
Join Date: Jul 2007
Posts: 13
 
Car is repaired....took nearly 3 weeks. Everything seems to be ok with the motor, and the gas mileage seems to have increased 1 or 2 MPG.
cdsipjp is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 



Similar Threads
Thread Thread Starter Forum Replies Last Post
Idle problem kraddic Problems and Solutions 29 05-05-2015 04:43 PM
New member with a transmisson problem. TMartin Testing, Testing, 1, 2, 3 1 01-03-2008 10:31 AM
'05 G6 Body Control Module problem '70 Mach 1 Problems and Solutions 0 05-06-2007 07:58 PM
Starting Problem georgew Problems and Solutions 5 05-04-2006 04:16 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome