help with engine - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 05-19-2008, 10:06 PM Thread Starter
 
Join Date: May 2008
Posts: 2
 
help with engine

This is my first post on this forum, I have a civic, but my mom has a g6 first gen, when they first rolled off the assembly line, I believe in December of 2005. Her car is now getting to be 3 years old, the engine light has come on and whenever you put the tranny (its an auto) into reverse or drive the engine shakes badly and my brother said it feels like the engine's gonna drop out when you do put it from park to reverse. I'm not a car guru, but I know that engine shaking isn't supposed to happen, and it might be a piston misfiring, but you never know. I know my brother accidentally broke the tie rod because he hit the curb and pushed the hub cap into the tire (and that also caused the tie rod to be shot). He also said that the engine light is now on, after he hit the curb goin around 40mph.

all comments and suggestions are welcome, I also know that there are numerous problems when buying a first gen car, and that the gm vehicles weren't made like they were used to.

my dad owned his 88 grand am until 2007 when he bought my car, and it ran just fine, all it needed was a paint job and the carpet on the roof was coming off (the glue was melting i guess) so it needed to be reglued.
momsg6 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 05-20-2008, 02:11 PM
 
Join Date: Jan 2005
Posts: 586
 
take it to GM and have the diagnostic ran, that will tell you everything.
Fusion is offline  
post #3 of 5 (permalink) Old 05-24-2008, 04:13 PM
 
Join Date: May 2008
Posts: 7
 
Quote:
Originally Posted by momsg6 View Post
This is my first post on this forum, I have a civic, but my mom has a g6 first gen, when they first rolled off the assembly line, I believe in December of 2005. Her car is now getting to be 3 years old, the engine light has come on and whenever you put the tranny (its an auto) into reverse or drive the engine shakes badly and my brother said it feels like the engine's gonna drop out when you do put it from park to reverse. I'm not a car guru, but I know that engine shaking isn't supposed to happen, and it might be a piston misfiring, but you never know. I know my brother accidentally broke the tie rod because he hit the curb and pushed the hub cap into the tire (and that also caused the tie rod to be shot). He also said that the engine light is now on, after he hit the curb goin around 40mph.

all comments and suggestions are welcome, I also know that there are numerous problems when buying a first gen car, and that the gm vehicles weren't made like they were used to.

my dad owned his 88 grand am until 2007 when he bought my car, and it ran just fine, all it needed was a paint job and the carpet on the roof was coming off (the glue was melting i guess) so it needed to be reglued.
Sounds like the engine is just idling very low causing it to shake. Could be as simple has a bad spark plug/wire or a clogged fuel injector. I say do a tune up on it, and run some "sea foam" in the fuel and see how she does... then go from there. What is it idling at when in park, and in drive? Does the rpm's drop when you put it in drive/reverse?
IWantBoost is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 05-25-2008, 02:43 PM Thread Starter
 
Join Date: May 2008
Posts: 2
 
the tranny needed fluid and something else was up with it too. What do ya'll think of the first gens?? They are pretty good cars, but I still know it won't last as long as the grand am
momsg6 is offline  
post #5 of 5 (permalink) Old 05-28-2008, 02:36 PM
Junior Member
 
siflawless's Avatar
 
Join Date: Nov 2007
Location: staten island
Age: 36
Posts: 5
 
Send a message via AIM to siflawless
stop letting your broher drive the car cause it sounds like hes messing it up even more
siflawless is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light again!!! bruce Problems and Solutions 21 07-29-2010 12:33 PM
2007 G6, 2.4L Engine Noise Dusty35 Problems and Solutions 13 02-24-2009 07:55 AM
My car is "chugging" and now the engine light is on! amgraham Problems and Solutions 4 11-06-2008 11:16 AM
Engine Light Slickdesi Problems and Solutions 21 04-12-2008 10:25 AM
ENG (engine) PWR (power) REDUCED CRAIGZ24 Problems and Solutions 0 01-21-2008 08:01 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome