Front end vibration at high speeds!!!!! - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 09-08-2008, 09:36 AM Thread Starter
 
Join Date: Sep 2008
Posts: 4
 
Front end vibration at high speeds!!!!!

Well I get a lot of vibrations when on the Hwy and will have to slow down doesn't do it when driving on regular roads just at high rated speeds. Can anybody let me know what might be the problem? Thanks.

Sorry, i didnt explain myself clearly it only vibrates when i attempted to slow down putting pressure on the brakes on the Hwy, but not on regular roads.

Last edited by snuffy; 09-09-2008 at 07:44 AM.
snuffy is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 09-08-2008, 10:56 AM
Lifetime Member
 
geewhiz's Avatar
 
Join Date: May 2008
Posts: 3,269
 
https://www.g6ownersclub.com/forum/sh...ight=vibration
Look here

Oh, and welcome aboard.




Mike
MODS;
None, if I want a faster car I'll buy one.
geewhiz is offline  
post #3 of 7 (permalink) Old 09-10-2008, 11:08 AM Thread Starter
 
Join Date: Sep 2008
Posts: 4
 
Hey sorry should of explain myself more clearly it only vibrates when i attempt to slow down by applying pressure on the brakes on the Hwy, but it doesnt do it on regular roads or normal speeds.
snuffy is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 09-10-2008, 11:38 AM
Lifetime Member
 
geewhiz's Avatar
 
Join Date: May 2008
Posts: 3,269
 
do ya think its a warped rotor?



geewhiz is offline  
post #5 of 7 (permalink) Old 09-10-2008, 12:01 PM
Member
 
Join Date: Aug 2008
Posts: 60
 
Sounds like a warped or pitted rotor to me.
ooshnoo is offline  
post #6 of 7 (permalink) Old 09-11-2008, 06:30 AM Thread Starter
 
Join Date: Sep 2008
Posts: 4
 
Quote:
Originally Posted by ooshnoo View Post
Sounds like a warped or pitted rotor to me.
snuffy is offline  
post #7 of 7 (permalink) Old 09-11-2008, 06:31 AM Thread Starter
 
Join Date: Sep 2008
Posts: 4
 
Well ill look into it and will get back to yall thanks for the info.
snuffy is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slight "pop" in front end on take-off BlueVette Problems and Solutions 102 07-10-2017 07:02 PM
Idle problem kraddic Problems and Solutions 29 05-05-2015 04:43 PM
At high speeds, car seems to vibrate/shake ooshnoo Problems and Solutions 7 08-30-2008 05:29 PM
Front End? Need help please! elliptical Problems and Solutions 0 02-29-2008 12:27 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome