Turn signal issues - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 03-12-2009, 05:29 PM Thread Starter
 
Join Date: May 2007
Posts: 36
 
Turn signal issues

Hey all,

I am having a strange issue. My driver's side rear turn signal no long comes on. At first I thought it was just the bulb that blew but I'm now I'm not sure. I tested the bulb and it actually cuts on when I turn my lights on (night lights). If it's during the day, and I hit the right turn light, it cuts on, if I hit the left, only the front driver's side cuts on (signal on dash blinks faster) Now I think it might be a fuse since that bulb does cut on but I've looked through the manual like 8 times and I do not see the fuse that would control the turn signals. Can anyone help me?
(V)eGa is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 03-13-2009, 03:43 PM
Break My Wallet Tech
 
Artic_07's Avatar
 
Join Date: Sep 2008
Location: Dallas
Posts: 77
 
Might have a burnt contact point on the assembly, check connections at plug points as well (make sure not to touch the bulb with bare hands, use a rag or something).
I would also make sure that the bulb is not a double filament bulb.

I personally have not come across that issue with mine yet, but I work on BMWs and we see burnt contacts all the time

Rusty

2007 GTP Sedan
1976 F-100
1969 F-100(in pieces)

Last edited by Artic_07; 03-13-2009 at 03:45 PM.
Artic_07 is offline  
post #3 of 8 (permalink) Old 03-13-2009, 04:49 PM Thread Starter
 
Join Date: May 2007
Posts: 36
 
Thanks Artic...I'll take a look at it this weekend. After all this Winter weather in NJ, it's time to shine my baby up...lol
(V)eGa is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 11-03-2010, 07:33 PM
Junior Member
 
RhodyMike's Avatar
 
Join Date: Jun 2009
Location: Rhode Island
Age: 30
Posts: 16
 
Send a message via AIM to RhodyMike
Currently having this exact same problem, did you ever fix this?? Anyone else have any clue about this one, I don't wnt to take it in and have some monkeys try and figure it out then just replace everything. HELP!!
RhodyMike is offline  
post #5 of 8 (permalink) Old 08-10-2011, 02:17 PM
Junior Member
 
Join Date: Oct 2009
Posts: 3
 
Same here. Noticed left turn signal would click faster than the right. Checked the lights and the rear left does not blink. Pulled the bulb and both filaments appear to be fine. Figured a fuse or relay may be bad but cannot find a location for turn signal or brakelight fuse in the manual.
Anyone ??

2007 GT Convertible
fishingfever is offline  
post #6 of 8 (permalink) Old 08-10-2011, 03:48 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Quote:
Originally Posted by fishingfever View Post
Same here. Noticed left turn signal would click faster than the right. Checked the lights and the rear left does not blink. Pulled the bulb and both filaments appear to be fine. Figured a fuse or relay may be bad but cannot find a location for turn signal or brakelight fuse in the manual.
Anyone ??
Brush the corrosion off the contact points in the socket as best you can. Get a new bulb & dielectric grease. Coat the base with a small amount of dielectric grease & reinstall. Don't touch the bulb glass. Otherwise, pull out your multimeter & start troubleshooting.



greenman is offline  
post #7 of 8 (permalink) Old 08-10-2011, 08:57 PM
Moderator Member Thingy
 
Abyssul's Avatar
 
Join Date: Jun 2009
Location: Myrtle Beach, SC
Posts: 1,330
 
Send a message via AIM to Abyssul Send a message via MSN to Abyssul
I had this happen for a stealth chrome turn signal bulb. I installed a different bulb and it worked as intended. Faulty bulb IMO...

2006 Pontiac G6 GT

Appearance Mods: AIT front bumper, Black Eagle Eye Halo Projectors with DDM Tuning 5000k HIDs 35w,
GT door decals, painted interior trim, red calipers, de-chromed window trim
Performance Mods: WAMS tune, CRABS, aftermarket sound system

Abyssul is offline  
post #8 of 8 (permalink) Old 11-12-2017, 04:51 PM
Junior Member
 
Join Date: Nov 2017
Posts: 1
 
no turn signals

i am having an issue with my turn signals. I installed new headlights and now I have no turn signals in the front of my car now. they flash fast in the back. but when I plugged my old ones back in they worked perfectly. I have no idea what it could be. I'm hoping to get some help
derek89 is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Brake/turn signal not working. BudmanTom Problems and Solutions 6 05-03-2012 08:29 AM
Service Bulletins (and the steering issues) stephcorleone Steering Lockup Issues & Discussion 5 11-20-2008 09:58 AM
Computer issues (several symptoms) brandonreno Problems and Solutions 6 10-10-2008 12:40 PM
2.4 Ecotec G6 Steering Issues Vita Steering Lockup Issues & Discussion 1 08-20-2008 10:39 PM
Turn Signal Bulb Change bigdude Problems and Solutions 2 05-16-2006 09:18 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome