Knock Sensor? - Pontiac G6 Forum
 1Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 30 (permalink) Old 03-13-2009, 10:19 AM Thread Starter
Junior Member
 
Join Date: Feb 2008
Posts: 9
 
Knock Sensor?

Hi my check engine light is on and an OBD scanner shows Knock sensor 1 Low signal. According to my manual KS1 is on the front bank of cylinders. I replaced this last night. Cleared the OBD error, took the car for for a spin and the check engine light is back on with KS1 Low signal! I'm thinking either KS1 is on the rear bank of cylinders or I have a wiring problem. I bought 2 sensors so I'll replace the other one this weekend. It could be a wiring fault as I got a complete engine replaced under warranty last year, maybe something got stretched in the process. Just wondering if anyone else has had fun with knock sensors?? Thanks. Car is a G6 GTP 3.9L.
IdahoSpud is offline  
Sponsored Links
Advertisement
 
post #2 of 30 (permalink) Old 03-15-2009, 12:13 AM Thread Starter
Junior Member
 
Join Date: Feb 2008
Posts: 9
 
My manual sucks. KS1 is on the rear bank of cylinders! Problem solved...
IdahoSpud is offline  
post #3 of 30 (permalink) Old 04-16-2012, 08:12 PM
Junior Member
 
Join Date: Apr 2012
Posts: 11
 
Knock sensor location on 2006 v-6 (3.5 L)

I cannot locate the knock sensors on my engine. I have 2006 G6 with 3.5L V-6 engine. Does anyone have a picture or something that can help me? Detailed instructions would be helpful. I don't have a clue as to where to start. I was told I could change them myself but I can't even locate them.
Thanks!
dfsblue55 likes this.
pint4 is offline  
Sponsored Links
Advertisement
 
post #4 of 30 (permalink) Old 04-16-2012, 08:39 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Quote:
Originally Posted by pint4 View Post
I cannot locate the knock sensors on my engine. I have 2006 G6 with 3.5L V-6 engine. Does anyone have a picture or something that can help me? Detailed instructions would be helpful. I don't have a clue as to where to start. I was told I could change them myself but I can't even locate them.
Thanks!
PM me with an email addy & I'll send the how-to.

But before replacing them, what code/s are you getting?



greenman is offline  
post #5 of 30 (permalink) Old 04-17-2012, 12:30 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
So, for the benefit of the forum, this is what pint4 sent me in a PM:

"Thanks. My codes I believe were p0332 and p0327. the codes said one was ks sensor 1 and the other ks sensor 2."



greenman is offline  
post #6 of 30 (permalink) Old 04-17-2012, 01:05 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
And my reply:

Don't replace the sensors.

Did you do any mods or engine work prior to the onset of the codes?

Could be mice chewing on the harness.




Last edited by greenman; 04-17-2012 at 01:44 PM.
greenman is offline  
post #7 of 30 (permalink) Old 04-17-2012, 09:20 PM
Junior Member
 
Join Date: Apr 2012
Posts: 11
 
Knock Sensors

Yes, I did some work to the car. GM replaced the motor for the power assisted steering. We also changed both lower control arms and a wheel bearing hub. Had to jack up the engine a half inch or so to remove and replace the lower control arms. If I don't replace the knock sensors, do I just clear the check engine light and wait and see if it comes back on or should I be replacing something else.
Thanks.
pint4 is offline  
post #8 of 30 (permalink) Old 04-17-2012, 09:33 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
These are type 2 codes & would have popped very soon after the damage to the harness was done (within a couple engine starts). Can you remember exactly how much time passed between the work being done & the check engine lamp turning on?




Last edited by greenman; 04-18-2012 at 01:51 AM.
greenman is offline  
post #9 of 30 (permalink) Old 04-18-2012, 06:20 PM
Junior Member
 
Join Date: Apr 2012
Posts: 11
 
How do I know if the harness is bad? I have no idea where the Knock Sensors are located and so I have no way of following the harness if I don't know its path-start or finish. How do I find the harness so I can check it out? Wish someone had a picture so I knew where to look.
Thanks.
pint4 is offline  
post #10 of 30 (permalink) Old 04-18-2012, 06:53 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Quote:
Originally Posted by pint4 View Post
How do I know if the harness is bad? I have no idea where the Knock Sensors are located and so I have no way of following the harness if I don't know its path-start or finish. How do I find the harness so I can check it out? Wish someone had a picture so I knew where to look.
Thanks.
Just emailed you.

There are also photos in the Chiltons for G6.

I have to warn you that you're dealing with a problem that would probably baffle many professional mechanics. Looking at the schematic, I can't find any circuit issue that would affect both sensor circuits simultaneously. They are isolated circuits all the way from the PCM. Maybe someone else has seen this one before.

Did you ever try just clearing the codes & seeing if they return?




Last edited by greenman; 04-18-2012 at 11:37 PM.
greenman is offline  
post #11 of 30 (permalink) Old 04-19-2012, 06:18 AM
Junior Member
 
Join Date: Apr 2012
Posts: 11
 
I cleared the codes last night and will see if they return.
Thanks.
pint4 is offline  
post #12 of 30 (permalink) Old 04-19-2012, 03:32 PM
Senior Member
 
Metalhead852's Avatar
 
Join Date: Aug 2010
Location: Lima, OH
Age: 34
Posts: 163
 
MIL comes on - Clear codes -

Lima... where the men outnumber the women and the women outweigh the men.
Metalhead852 is offline  
post #13 of 30 (permalink) Old 04-19-2012, 03:40 PM
Member
 
Join Date: Mar 2010
Location: houston
Posts: 64
 
hello i have the knock sensor on cylinder 2 , low signal but it goes and comes back like a week later without clearing obd, do u think the sensor is going bad,

Mods


Painted calipers,8k low and fog hids, blackedout tailights, chrome trim removal, 6.5 kenwood speakers, alpine 6x9s in the back, L7 in trunk, black grills, all interior white leds,yokahoma tires,


to come black rims, halo projectors, mild cam and tune , stage 3 intake, pcm, painted engine cover
06gtpg6 is offline  
post #14 of 30 (permalink) Old 04-19-2012, 10:05 PM
OOBER SUPER MEMBER
 
Join Date: Jul 2011
Posts: 2,388
 
Quote:
Originally Posted by 06gtpg6 View Post
hello i have the knock sensor on cylinder 2 , low signal but it goes and comes back like a week later without clearing obd, do u think the sensor is going bad,
What exact code are you getting?



greenman is offline  
post #15 of 30 (permalink) Old 04-19-2012, 10:12 PM
Junior Member
 
Join Date: Apr 2012
Posts: 11
 
I cleared codes and the check engine light is on again, less than 12 hours later. Looks like the problem is still there. I guess the next step is to change both sensors. Not sure I have a lot of options-codes are po332 and po 327.
Thanks.
pint4 is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Outside Temperature Sensor kristym32 Problems and Solutions 3 03-01-2009 08:02 AM
2006 G6 GTP and failed front speed sensor northernbc26 Problems and Solutions 1 03-18-2007 08:12 PM
Knock Knock mphred Joke Central 3 09-05-2006 09:20 AM
Passenger airbag sensor. Sully Problems and Solutions 4 03-13-2006 07:58 PM
I got my car back...FINALLY! Bad Sensor?! Carissa249 Steering Lockup Issues & Discussion 12 12-17-2005 10:35 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome