Transmission troubles - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 02-25-2018, 05:56 PM Thread Starter
Junior Member
 
Join Date: Feb 2018
Posts: 1
 
Transmission troubles

I had a bad shift solenoid in my 07 G6, so I decided to change the filter and replace both shift solenoids as well as the lock up solenoid and the EPC solenoid. This is a V6 with the 4t45e transmission. After changing the solenoids and filter, I filled the fluid and ran it through the gears while still on jack stands and noticed the wheels were spinning forward regardless of the shifter position and if I brake checked, it did not feel as though the transmission was fully engaged. I had struggled some trying to get the new filter in place, so I removed the pan and found the filter had come loose and was lying in the pan - so I re-installed, ensuring that this time it was properly seated. I replaced the pan and re-filled the fluid with similar results, only this time the tires go in reverse regardless of the gear selector position.... I pulled the pan again and the filter is fine. Any ideas on what to check? I had no slippage or issues prior to changing the solenoids... what have I done???
johnsoncircle is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 08-04-2019, 10:04 PM
Junior Member
 
Join Date: Jul 2019
Posts: 3
 
I also have an 06 g6 doing the same thing, had a code of p0751 for 1-2 shift solenoid stuck open, we didnt new filter and solenoid and now all gears are forward. I'll check my filter in the morning. Also mines a gt so it has the manual and were the milage is it shows m1 dont know why but might check yours. Hopefully some on here will help us in the right direction.
Derek.lewis is offline  
post #3 of 4 (permalink) Old Today, 04:18 PM
Junior Member
 
Join Date: Jul 2019
Posts: 5
 
Solenoid application for 1st and reverse are the same, 1-2 Shift solenoid ON, 2-3 Shift Solenoid Off. Difference between 1st and Reverse is position of the manual valve. Is it possible the link to the valve got disconnected while installing the solenoids??

There is an ATSG manual posted here:
https://shop.ukrtrans.biz/wp-content...logs/4T40E.pdf

page 53 shows the manual valve link.
Heeke is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old Today, 04:19 PM
Junior Member
 
Join Date: Jul 2019
Posts: 5
 
Heeke is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 



Similar Threads
Thread Thread Starter Forum Replies Last Post
cat code troubles mantunano Problems and Solutions 0 03-15-2014 10:34 AM
monsoon troubles might be fixed 2005gt Problems and Solutions 1 10-19-2012 01:49 PM
Blower Motor Troubles! Justn226 Problems and Solutions 2 01-03-2011 07:51 AM
2005 rim troubles :( kettle115 Problems and Solutions 3 10-25-2010 05:30 PM
What percentage of G6's have big troubles? Gnomad G6 Buyer's Guide/General Information 3 04-04-2008 12:45 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome