Help! Oil going up dipstick and light on - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 07-31-2018, 07:11 PM Thread Starter
Junior Member
 
Join Date: Mar 2018
Posts: 7
 
Help! Oil going up dipstick and light on

Ok i wrote a huge post before this aski g for any help and gave plenty of details amd couldnt get a single person to even comment which i find strang considering this is a forum where people are suppose to help one another and it jusf coat me 600 to get towed all the way home a few hrs away.
now im stuck still messing with it and have figured out a few things but one im stuck on.
My oil lifht has been on steady, have no way to test the pressure but with the knocking/rattling i assume it is safe ro say the pressure is not good.
Now before i ger people stating the obvious let me inform you that im no idiot and i havnt miszed anything.
So without a way to test pressure a d knowing it is full of new oil and with the new parts i can safely say oil level low/high is not an issue and since ive spent days reading and researching and canr find a si gle post with anything even remotely useful i have decided to attempt to common sense trouble shoot.
So oil lights on right after i fully redid the engine harnesses and wwas fine before so the odds of a bad sensor is slim to none especiallt since it is a always open sensor and would only operate when pressure drop enough to close it (or so i read on many forums)
So that mean pressure is in fact bad.
Oil levels read at the line on high mark emgine off 15minutes and samr after 2 days cold.
Now after observing live data i know now that there really is only one possible explanation that i couldnt test for that would cause it and is not too dar outta the realm of possibility.
When i was rebuilding everything i had let the valves amd rings soak a few days before eptying them then pulled the oil filter adapter and drained oil pan. I had to leave the adater are open for 3 days due to storms.
When i finally was done i dumped a bit (quart) of oil in the cc to flush anything out but none came out the pan.
I just assumed it was puddled up in places and not enough.
Time restraints amd other issues arrising forced me to move on and forgot to look into it more.
So now i know that the onlu possible explination is that im mot getting oil circulated througout and common sense tells me that oil level on the dipstick would be low if any at all while running due to it being distributed...(cant even find a straight answer for fhat, some agree and others seem to lack any mental capacity and say it will show higher due to expansion of hot oil...possible but when the oil is all suckes out expansion means absolutly nothing in the dipstick)
So i check it running and as i assumed, the oil was still full, 5 min, 15min, and next morning cold the same which tells me i have a bad pump or clog somewhere.
Im thinking its very possible a bug/bugs crawled in while the adapter was off amd would explain thw oil i tried to flush with not coming out.
Well i figured id check stuff one last time amd this time it changed...during engine rumning for 5 min the oil over doibled on the stick, then 3min later it had quadrupled! I killed it amd checked 5 min later amd was back barely over the full mark.
I have read tons of forums and its always the same responses...either they checked it wrong, bad compression, bad pcv, engine hot, etc...which for the most part are jist ignorant because anyone who doesnt know the common sense stuff like how to shouldnt be woking on it anyways and when they were told it wasnt pcv pr compression then the replys ended. 20 fors i read not one had a solution.
So i will say this just to put an emd to confusion pr those tupes of replys off the bat.
Oil is NEW, level is perfect, i know how to chexk it cold, level ground, my pcv os basically non existant in this car, just a hole no type of vacuum never has been, entire inrake as well as every tube, hose, line,sensor, resevour, gasket, componant, etc in the entire engine has neen replaced, fixed, cleaned, and tested.
So leaving the option of am internal issue only. Compression was check a month ago and was good, 1 cylinder was about 10 psi lower but npt enough tp cause any issues and all my eci readings are perfect. No cels nothing outt the ord at all.
So im wonderimg if there is anything i missed or should check firat before saying that it is clogged for sure?
And what would cause the oil level to rise up the dipstick like that?
And finally, instead of tearing out the pan and going throhgh that huge hassle just to pull stuff and blindly search for the issue, i figured the details may help someone more knowledgable than myself narrow down what is bad pr where it is clogged.
We know this, the oil when poured into the crankcase is most likely being held up before it reached tbe pan or filter. We know that it is not being circulated back to the crankcade for sure. We know no water, coolant, gas, etc, is leaking or mixed in with it, and now we know rhat somehow the oil pressure is pushing it up the dipstick tube while running.
No vacuum leaks at all, no fluid leaks, no smoke, nothing off at all beside oil light, and now the noise (from no lube for thw lifters) coming from bank 2 only amd its very slight.
Plexlove is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil dipstick smells like gas Brendan Problems and Solutions 0 06-17-2015 03:39 PM
bad dipstick reading gregross General Maintenance 4 03-20-2015 08:52 AM
Aftermarket transmission dipstick kit plano_doug Problems and Solutions 1 05-12-2014 02:29 PM
oil light on/off and engine light HELP!! merwillis89 Problems and Solutions 1 04-22-2013 10:22 PM
Oil level on engine oil dipstick always increases. Mugunthan_06_G6 Problems and Solutions 4 12-26-2012 08:34 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome