Assistance required - Traction Light, CEL, P0705 - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-05-2018, 03:29 PM Thread Starter
Junior Member
 
Join Date: Aug 2018
Posts: 1
 
Assistance required - Traction Light, CEL, P0705

Hi all, I am having an issue with my 2007 G6 GT with 111K. I've owned this car for almost 3 years and haven't had any issues until now. I was driving home from work one day when my CEL came on. Got home, pulled the codes P0705 (Transmission Range Sensor Circuit Malfunction) and P0700 (caused by P0705 I assume).

My car runs and drives fine. One of the most notable issues is when I put the car in drive, the doors don't lock like they're supposed to. Also, when I put it in park, they don't unlock. If I clear the code, the doors work the way they should until the code comes back. After clearing the code, if I drive about 5 miles, the traction light will come on, followed by the engine light after a few more miles.

I replaced the neutral safety switch with the factory ACDelco part, and also bought the tool to properly align the sensor. It was installed correctly, while in neutral gear. The replacement made no difference, and it wasn't until this point that I realized that I had no reverse lights either.

So, all in all, I have a traction light that I am assuming is being caused by this P0705 code, and also no reverse lights. My main reason for posting is to see if anyone here may have some suggestions or possibly has ever seen this issue.
John Hagan is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
EPS, traction, gauges and CEL for ecm/pcm comm loss Krazy T Problems and Solutions 2 09-02-2016 03:12 AM
P0705 stapler2025 Problems and Solutions 2 09-02-2014 04:20 PM
Traction Control & CEL warnings AllanR Problems and Solutions 1 02-28-2012 08:29 PM
Please Help! What's required for aftermarket stereo? CutieCahill Car Audio, Video and Security 16 02-21-2012 10:38 PM
More SUGGESTIONS Required Neb Problems and Solutions 2 01-20-2012 12:34 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome