Lost all power, and into the shop it went - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-07-2018, 09:34 AM Thread Starter
Junior Member
 
Join Date: Oct 2017
Posts: 6
 
Lost all power, and into the shop it went

I went to start my car after it sat in a parking lot all day, to find it was misfiring so badly I couldn't back it up more than a few feet. I had it towed to a shop, who says that they have DTC's for random misfiring and a failed crank sensor, it's overheating, and it was low on both coolant and oil.

I can vouch that the oil dipstick showed full two days prior, nor was there oil in my parking spaces. The engine had been occasionally running on the warm side (225F) due to the summer heat, but had never overheated, though I had the thermostat replaced when it stuck open during the winter.

What do you think happened? They found a new-to-me oil leak under the engine somewhere. Except for the crank sensor code, I'd say the head gaskets blowing would explain everything else.

Has anyone had a similar problem with their G6?
delta is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Lost power during top transition M32198 Problems and Solutions 0 07-27-2015 01:05 PM
08' lost some power berryspontiac Problems and Solutions 4 03-21-2014 01:42 PM
after CAI, check gas cap warning and airbag service light went up. wzbhnn Problems and Solutions 24 02-26-2011 10:02 PM
Lost of power light came on BigScoe Problems and Solutions 5 09-15-2010 04:29 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome