Dead gauges and then car won't start - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 11-18-2018, 11:09 AM Thread Starter
Junior Member
 
Join Date: Nov 2018
Posts: 1
 
Dead gauges and then car won't start

Hey all.

I've been having an issue in my 08 G6 convertible that has ended up with it having to be towed twice now. I'll be driving with no issues and then I will hear a few dings and all of my gauges go dead. The mileage meter reads error, my DIC has rotating messages of low fuel, service esc, etc. And every warning indicator shows up on the dash, abs, security, etc. The transmission goes into limp mode, where it slams itself into each gear. Twice I've taken it home during this and then once it's turned off, it won't restart, the ignition is completely dead.

My mechanic the first time just reset the check engine codes and it worked, for about 5 miles. He then had it for over a week and figured out that there was a service bulletin about the Onstar issue creating this problem. He cleaned the connector to the VCIM module and gave it back to me. It worked for 3 days this time. Then we had 6 inches of snow, drove it yesterday and about 10 miles in it did the same thing. So now it has to be towed again. I think I'm going to go to the dealership this time, because my mechanic admitted to not having a lot of knowledge about the computers of the Pontiac. Is it possible the entire connector is bad? I'm already 500 bucks into this, and have been without my primary vehicle for three weeks now. The frustration is getting pretty high at this point.

Any ideas? Thanks gang!
pipervali is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2007 G6 won't start, but has engine light and car with a padlock light. davadholman Problems and Solutions 11 06-03-2018 12:47 AM
Won't start/Gauges go nuts Steven66# Problems and Solutions 7 05-24-2018 05:03 PM
Won't start...no crank...won't even try kevinmaq Problems and Solutions 2 09-23-2015 02:43 PM
need help - all gauges go to zero, and car shutters djinferno Problems and Solutions 12 04-15-2010 05:44 AM
Remote Start / Keyless Entry Battery Dead manqso General Maintenance 0 03-02-2010 05:55 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome