08 G6 Stalled at red light P0168 - Pontiac G6 Forum
 2Likes
  • 2 Post By gruvedaddy
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 12-16-2018, 09:36 AM Thread Starter
Member
 
Join Date: Dec 2012
Posts: 62
 
08 G6 Stalled at red light P0168

Hey all. Code in header is P1682 actually, wouldn't let me fix it after posting. Anyway, So the other morning on the way to work my G6 completely shut off while i was stopped at a red light and immediately "reduced engine power" popped up on the dic (duh). I tried to restart a few times and no luck. I scanned it with my bluedriver that i keep in the car and P1682, Control Module Performance - Ignition circuit, popped up. I then took the key out of the ignition for a couple minutes, tried to start it and it started up no problem. After a few days and a few stop start cycles the check engine light went away and it's been fine. I've owned this G6 nearly 10 years and that is the first time it has occurred. To my knowledge my the 08 G6 doesn't have any recalls for ignition issues, i know many cobalts and i believe malibus had recalls for faulty ignition switches. I did have the power steering recall serviced (and it still occurs once a year) and also the transmission gear position indicator. I looked through the lost list of service bulletins but don't see any related to the ignition switch. Anyone else have a similar issue? Don't want to just start throwing parts at it. Thanks

2008 G6, 2.4 auto, 174,800 miles

08' G6 Sedan, 2.4L Auto 174,800 miles

Last edited by gruvedaddy; 12-16-2018 at 09:44 AM. Reason: typed wrong code in header
gruvedaddy is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 02-04-2019, 01:28 PM Thread Starter
Member
 
Join Date: Dec 2012
Posts: 62
 
Thanks for everyone's help. 🙄 Anyway, this issue occurred again last week and i was able to troubleshoot it down to a loose relay socket in the fuse box in the engine compartment, relay #33 to be precise. I bench tested all the relays and they were all good but relay #33 was loose and when i wiggled it while my wife cranked it over it'd start and stay running until i wiggled it again and it'll stall. So i determine its a bad relay socket. So i go to the pull a part and get the closest match i can get to the part number on my fuse box. Mine is 2588-3023 and the closest i can find is 2588-3024. The car i pulled it off of was also an 08 G6 with a 2.4 but it had a few more options than mine. However when i put it all together the car won't start. I was of the thought that the internal parts in the fuse block would be similar only that if you had extra options that you would need the extra fuses and relays and such and since mine was identical but had fewer options it would work. So my question is am i right in thinking the fuse boxes, although very similar, are imcompatible? I'm having a hard time finding my exact part number and just want to verify that what i am thinking is correct. The dealer wants $360 for the fuse block and i really don't want to go that route so if there is another number that'll work I'm willing to eBay one. Thanks in advance.

08' G6 Sedan, 2.4L Auto 174,800 miles
gruvedaddy is offline  
post #3 of 4 (permalink) Old 02-05-2019, 12:45 PM
Old far...er...tinkerer..
 
Join Date: Aug 2012
Location: Plano, Texas
Posts: 297
 
Quote:
Originally Posted by gruvedaddy View Post
I'm having a hard time finding my exact part number and just want to verify that what i am thinking is correct.
Looking at https://www.gmpartsdirect.com , I get these results:

For an 08 G6 with 3.5L motor, they list p/n 20822698 for the underhood fuse box.

For the 08 with 2.4L, they list 25883023 .

These results seem to conflict with yours. Perhaps I didn't pick the right sub-model - I chose base rather than GT or GXP.

The one thought I had was, depending on how handy you are, is to go back to the fuse box you had, and bypass the one bad relay. That is, add some additional, external wiring to connect the relay to the proper wires, but on the outside of the box.

It's kinda kludgy, but, if you're handy with a soldering iron, you can create a durable repair.

Doug

.
plano_doug is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 02-07-2019, 06:43 AM Thread Starter
Member
 
Join Date: Dec 2012
Posts: 62
 
Thanks for the reply, Doug. After doing more research on youtube i stumbled across a few videos of people disassembling fuse blocks to make the necessary repairs instead of purchasing a new one. After taking mine apart i discovered that the connectors where the relay in question seats into had separated too far apart for the relay to have a good connection. So i squeezed them back together with a pair of pliers and put everything back together and so far the car is running fine. I'll be posting a video of my troubleshooting and correcting the problem to youtube within the next week. If anything changes with the car i'll be sure to come back and update but at this moment it seems i have solved my P1682 code.
plano_doug and buzz1009 like this.

08' G6 Sedan, 2.4L Auto 174,800 miles
gruvedaddy is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Car Stalls at a red light. No codes. Could it be my throttle body? datboi Problems and Solutions 11 12-16-2018 09:49 AM
Power Steering / ESC Light Failed at Red Light PHXSEO Problems and Solutions 6 11-19-2018 10:07 PM
2005 G6 Stalled in Water will not start michellin7 Problems and Solutions 12 06-03-2016 06:37 AM
Autodim, compass, homelink rearview mirror with red compass light w3ap0n-x Items for Sale 6 01-30-2012 05:40 AM
Egine Problem: stalled while accelerating, followed by hard start deathmage Problems and Solutions 9 09-07-2011 04:10 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome