Myriad of electrical problems? - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 02-05-2019, 03:18 PM Thread Starter
Junior Member
 
Join Date: Dec 2018
Posts: 1
 
Myriad of electrical problems?

Sorry for creating a new thread, but after searching through many posts here, I really didn't find one specific to my issue. Because it seems to be many issues. Bare with me...
Last summer I purchased a 2005 G6 GT. Great deal [always clue #1...]. Seemed to have an issue with the security system, as when you unlocked it via key, the horn would give you the short blasts until you put the key in the ignition. Also, at low speeds the doors would rapidly unlock and lock once or twice. Annoying, but I could deal. Also, not the original key and the remote is incorrect for this car. Otherwise, all was good. Had some recall work performed at the dealer. One of these included doing something to the BCM. I point this out, because shortly thereafter the battery died. Had it jumped, ran fine. Now I should add I do not drive it anywhere near every day. It typically will sit for 2 or 3 days between starts. No problems starting though for the first 3 months or so. But it started dying each time I would let it sit. Not completely dead, but to where the accessories would work but it would not start. Battery tested fine, but O'Reilly's said the alternator was bad. Replaced it. Dead as a doornail a few days later. I decided to start disconnecting the battery between uses. This worked for several weeks. Then even that wouldn't get it started. I assume there is a parasitic drain somewhere, and I did buy a meter to test it and I guess that is what I am asking. Does it sound like a drain or with the security system issue, am I wasting my time? I bought one of those portable 5-in-1 jump starters [those things are amazing, I bought one for each of my daughters] and it starts up each time I use it. It is winter, and I'm in the northern US, so I'm sure that isn't helping but the problem started back in late September. Also, several seconds after it has started, a loud clicking noise comes from behind the glove compartment that stops if I change the method of air intake. So, any thoughts from those of you far more knowledgeable than I? I can handle some basic stuff, but if I'm going to have to start pulling out wiring schematics and rewiring this thing, I'm out for that. After reading other threads, I have seen issues with a parasitic drain, security systems and BCM issues. I feel like I have all of those at once, not just one and that is why I started a new thread. Hopefully this ends up being something I can handle and I appreciate any insights.
Rufust7 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 02-05-2019, 06:02 PM
08 convertible
 
Join Date: Jul 2018
Posts: 179
 
Take it one thing at a time in logical order.
First you need to assess the battery and charging system. Get yourself a plug-in voltmeter so you can see if it's charging, like this:
https://www.ebay.com/itm/DC-12V-24V-...GH1:rk:45:pf:0
You should get somewhere in the 13-14.5V range while driving. If not, you have a charging problem.

Now for the battery:

Quote:
Originally Posted by Rufust7 View Post
I decided to start disconnecting the battery between uses. This worked for several weeks. Then even that wouldn't get it started. I assume there is a parasitic drain somewhere, and I did buy a meter to test it and I guess that is what I am asking. Does it sound like a drain ...
That logic doesn't work. If you disconnect the battery, it can't discharge. Doesn't matter if there is a parsitic drain in the car. So if the fully charged battery can't hold a charge for a few days, while disconnected, you likely have a bad battery.

After you have all that sorted out, you can start looking for parasitic drains.
dxG6 is offline  
post #3 of 3 (permalink) Old 04-05-2019, 09:24 AM
Junior Member
 
Join Date: Jan 2018
Posts: 9
 
Take cds out of the stereo and feed them back in
G6gtchristine! is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical problems.... jcwclm Problems and Solutions 9 07-28-2011 08:31 PM
HELP! Electrical problems = car alarms?? p_oshan Problems and Solutions 0 03-16-2010 12:33 AM
Weird Electrical Problems LPCg6 Problems and Solutions 6 03-10-2010 10:23 PM
New with problems and yes i used the search button, problems with electrical? TuKwick Problems and Solutions 1 02-13-2009 02:12 PM
I'm new and have electrical problems Longhorn G6 New Member Introductions 2 01-22-2008 04:48 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome