Slight Coolant Leak - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 02-15-2019, 02:45 PM Thread Starter
Senior Member
 
Drums101's Avatar
 
Join Date: Nov 2010
Posts: 230
 
Slight Coolant Leak

Hey guys, Its been a while since I have been on here....that is a good thing it means my g6 has been mostly problem free for the past few years.

I seem to have developed a slight coolant leak. I have narrowed it down to the three way heater hose connector that is underneath the coolant tank. I have attached a picture of what I am talking about. The coolant seems to be leaking out from around the inside of the end of the hoses.

Two questions:

1)I am not completely sure it is the connector that is leaking. It may be one of the three heater hoses, the one coming from the firewall/heater core, the hose that comes off the right side of the engine or the coolant reservoir hose. In this situation should I just replace everything or try the connector first?

2) I seem to be having issues finding a replacement for that connector and the specific hoses....are there specific names for the parts besides heater hoses?

Thanks for your help guys

Drums101 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 02-15-2019, 04:03 PM
Senior Member
 
Join Date: Jan 2014
Location: RTP Area, NC
Posts: 318
 
When mine failed I took it into an ACE HW store and found something similar in the plumbing section. Sorry I do not recall the part number.
boomer is offline  
post #3 of 5 (permalink) Old 02-15-2019, 05:11 PM Thread Starter
Senior Member
 
Drums101's Avatar
 
Join Date: Nov 2010
Posts: 230
 
Quote:
Originally Posted by boomer View Post
When mine failed I took it into an ACE HW store and found something similar in the plumbing section. Sorry I do not recall the part number.
No worries. I seem to have found the tee fitting online. I might just do what you did and try to find it in a hardware store

When you said when yours failed it was only the tee fitting that failed? Or did you replace the hoses too?
Drums101 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 02-16-2019, 09:28 AM
Senior Member
 
Join Date: Jan 2014
Location: RTP Area, NC
Posts: 318
 
My hoses were fine. The plastic of the T piece had become somewhat brittle and had cracked. I seem to recall it being a little difficult to get out as it was generally weak. On one end I believe I used vice grips to break the remnants out of the hose. Also worth remembering you are going to get a fair amount of fluid pouring out that you might want to prepare for. Good luck with your fix.
boomer is offline  
post #5 of 5 (permalink) Old 02-16-2019, 03:49 PM Thread Starter
Senior Member
 
Drums101's Avatar
 
Join Date: Nov 2010
Posts: 230
 
Thanks for your help boomer.

A quick update in case anyone cares. I replaced the tee connector as the hoses seemed fine. Wasnt too bad at all....it seems to have fixed the leak. The weird part is that the original connector seemed totally fine. It doesnt have any cracks or seem to be brittle yet. I am not sure if it may have just shrunk with age causing the leak? I do not know but at least my car is holding coolant once again.
Drums101 is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Coolant issue -- no visible leak but losing coolant RussellReal Problems and Solutions 9 03-25-2019 09:06 AM
Slight "pop" in front end on take-off BlueVette Problems and Solutions 102 07-10-2017 07:02 PM
Slight squeaking when going over slight bumps.... G6-Lover Problems and Solutions 80 07-24-2015 12:00 PM
Slight Tick K&N Air intake installed tdelamor Problems and Solutions 50 06-14-2011 10:10 PM
Leaking coolant, coolant recovery tank cap. Dvin211 Problems and Solutions 5 05-20-2010 09:52 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome