Clunking from passenger side. - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 06-17-2019, 01:21 PM Thread Starter
Junior Member
 
Join Date: Jun 2019
Posts: 3
 
Clunking from passenger side.

hello, i have a 2010 g6. i have replaced my control arm and ball joints, inner and outer tie rod ends, sway bar links, strut assembly’s and hub assembly. i am still getting a loud clunking sounding like it is coming from my passenger side, it’s whenever i go over bumps. i’m at a loss, i hope someone can help
kmace51 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 06-17-2019, 04:41 PM
2007 gt retractable
 
Join Date: Jan 2017
Location: charlotte nc
Posts: 266
 
i have the same problem from the drivers side.
zenish is offline  
post #3 of 6 (permalink) Old 06-17-2019, 09:07 PM
08 convertible
 
Join Date: Jul 2018
Posts: 178
 
Very few things left. I would look at the sway bar bushings, motor/trans mounts and possibly axle shafts. Does it always happen on bumps only? At any speed, accelerating, braking, turning?
dxG6 is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 06-18-2019, 10:20 AM
Moderator
 
waterfowler76's Avatar
 
Join Date: May 2009
Location: Las Vegas
Posts: 4,022
 
Send a message via Yahoo to waterfowler76
Sway bar bushings was my first thought.

2007 PONTIAC G6 GT

Waterfowler's 6 <---- Check out my 6
waterfowler76 is offline  
post #5 of 6 (permalink) Old 06-18-2019, 02:14 PM Thread Starter
Junior Member
 
Join Date: Jun 2019
Posts: 3
 
I ended up figuring it out after asking the mechanic who did my trans flush to look at it. the guy who put on the control arms and tie rods and sway bar links, did not tighten the nut on the bottom so it was loose. replaced it with a new one because the old would not tighten, and the noise is gone now. thank you!
kmace51 is offline  
post #6 of 6 (permalink) Old 06-18-2019, 07:20 PM
Moderator
 
waterfowler76's Avatar
 
Join Date: May 2009
Location: Las Vegas
Posts: 4,022
 
Send a message via Yahoo to waterfowler76
Awesome. Glad you got it fixed. Thanks for the update.

2007 PONTIAC G6 GT

Waterfowler's 6 <---- Check out my 6
waterfowler76 is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome