Speedometer Issue - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 12-29-2005, 10:45 AM Thread Starter
GJS
 
Join Date: Nov 2004
Posts: 107
 
Speedometer Issue

I know there has been other posts on this my speedometer does not move smooth it started it about a month ago i have not had time to take it into the dealer with xmas and all wondering if there are any updates on this problem and who else has had this problem.
GJS is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 12-29-2005, 11:10 AM
 
Join Date: Nov 2004
Posts: 279
 
For these complaints (which usually is at lower speeds) the fix is to replace instrument cluster.
e2helper is offline  
post #3 of 12 (permalink) Old 01-04-2006, 03:27 PM Thread Starter
GJS
 
Join Date: Nov 2004
Posts: 107
 
I take my car in tomorow morning to get the speedo looked at i hope they replace it not tell me theres nothing wrong like they have done before with other things
GJS is offline  
Sponsored Links
Advertisement
 
post #4 of 12 (permalink) Old 01-08-2006, 10:54 PM
 
Join Date: Jul 2005
Posts: 21
 
Mine has been doing that as well. Sort of jumps in increments of 2-4 Mph.
White Wolf is offline  
post #5 of 12 (permalink) Old 04-27-2006, 09:22 AM
 
Join Date: Apr 2006
Posts: 3
 
My G6 developed a speedometer problem last week. At speeds above 75mph the needle would suddenly drop from 75 to 40 and then recover. Took it to the dealer this morning and while they couldn't duplicate the problem, they "re-programmed" the instrument cluster. I took it back out an went about 10 miles at 75mph and it seemed OK. Will have to watch it.
mannami is offline  
post #6 of 12 (permalink) Old 04-27-2006, 03:12 PM
 
Join Date: Nov 2004
Posts: 279
 
Hmm, interesting because I don't think the instrument cluster can be reprogrammed
e2helper is offline  
post #7 of 12 (permalink) Old 05-11-2006, 07:26 PM
 
Join Date: Apr 2005
Posts: 77
 
I know I'm behind here...I have just noticed the same problem..well not just but a while ago...I 've been thinking about taking it in but my work isn't in the same city as the dealership anymore and I don't trust other dealers around. I'll put this on my list of things to be looked at...along with the engine not turning over properly.

SBM
SBMG6GT is offline  
post #8 of 12 (permalink) Old 06-29-2006, 12:14 PM
 
Join Date: Apr 2006
Posts: 3
 
Speedometer issue

Quote:
Originally Posted by mannami
My G6 developed a speedometer problem last week. At speeds above 75mph the needle would suddenly drop from 75 to 40 and then recover. Took it to the dealer this morning and while they couldn't duplicate the problem, they "re-programmed" the instrument cluster. I took it back out an went about 10 miles at 75mph and it seemed OK. Will have to watch it.
Update - Problem happened again and this time I rode with the dealer's technician and this time we were able to duplicate the problem. He thinks it's a wiring issue. I am going to take it in next week and leave it.
mannami is offline  
post #9 of 12 (permalink) Old 06-29-2006, 01:50 PM
Senior Member
 
Daniel's Avatar
 
Join Date: Feb 2005
Location: Algonquin, Illinois
Age: 33
Posts: 916
 
I posted on hear a year ago about my speedo issues i got so sick of it now i just can tell how fast i am going without looking most of the time mine would be 5mph off sum times or it would just not move, my favroite is the 2min dance on start up before it decided to start workin LOL.
But the kicker is everytime i get an oil change or something there i will tell them to check it out and it is always working perfectly when i am in there and everyone thinks i am CRAZY!
Daniel is offline  
post #10 of 12 (permalink) Old 06-29-2006, 03:08 PM
 
Join Date: Aug 2005
Posts: 488
 
Hmm I've never heard of this problem before. Let us know what it was.
GTPGuy82 is offline  
post #11 of 12 (permalink) Old 07-12-2006, 07:00 PM
 
Join Date: Apr 2006
Posts: 3
 
7/12/06 The car has been in the shop for almost a week. They replaced the speed sensor but problem was still there. They just called to tell me that the GM techical folks think that there is a seal leaking in the transmission that is causing the gear that sends the signal to the speedometer to slip at speeds of 75 mph and above. They now have the transmission apart. If that doesn't fix it, they are going to replace the transmission. I hope the cure is not worse than the problem.

Last edited by mannami; 07-12-2006 at 07:03 PM.
mannami is offline  
post #12 of 12 (permalink) Old 08-16-2006, 09:26 PM
 
Join Date: Aug 2006
Posts: 15
 
I have the 2005 G6 v6 and have the speedo problem myself. It well "tick" about 2 mph at a time. I have taken to the dealer a few times now it seems to work just fine. I well be taking it back soon keep you posted.
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Problems and Solutions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome