[B][/B]Blinker system issue??!![B][/B] - Pontiac G6 Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 18 (permalink) Old 04-23-2013, 12:44 PM Thread Starter
Member
 
Join Date: Apr 2013
Posts: 53
 
Exclamation [B][/B]Blinker system issue??!![B][/B]

I have a 2009 Pontiac G6 3.5 V6 with stock steering wheel. When I turn the right blinker on and do a normal turn. The blinker turns off when the wheel straightens up like normal. But when I turn on the left blinker, I have to do a very major turn before the the blinker decides to turn off by it self. I am having to turn off the left blinker manually pretty much every time as with the right I never have to worry about.

Is there a way to fix that? Is that normal? Any clues on what the cause maybe?
negru08 is offline  
Sponsored Links
Advertisement
 
post #2 of 18 (permalink) Old 04-23-2013, 04:43 PM
OOBER SUPER MEMBER
 
CruisinG6's Avatar
 
Join Date: Jul 2009
Posts: 4,232
 
The turn signal switches tend to go out on these cars... mine's been replaced twice. It's like $25 from amazon and is fairly easy to replace, for someone who hasn't done it before you can probably get it done within a half hour pretty easily.

I'm pretty sure what caused mine to break was holding the lever through a turn as the steering wheel came back, such as for a double turn, if you hold it when it wants to cancel it'll skip over the cam and I guess it's easy to crack since everything is plastic.
CruisinG6 is offline  
post #3 of 18 (permalink) Old 04-24-2013, 07:28 AM
Senior Member
 
GM Customer Service's Avatar
 
Join Date: Oct 2012
Location: Detroit, Michigan USA
Posts: 295
 
Quote:
Originally Posted by negru08 View Post
I have a 2009 Pontiac G6 3.5 V6 with stock steering wheel. When I turn the right blinker on and do a normal turn. The blinker turns off when the wheel straightens up like normal. But when I turn on the left blinker, I have to do a very major turn before the the blinker decides to turn off by it self. I am having to turn off the left blinker manually pretty much every time as with the right I never have to worry about.

Is there a way to fix that? Is that normal? Any clues on what the cause maybe?
negru08,

Sorry to hear that you are experiencing an issue with your turn signal. If I can assist you, please let me know.

Safe travels my friend.

Jennifer T,
GM Customer Care Service

Have you checked into GM Owner Center? You can maintain service history, check on warranty or recall information, and more. Visit my.gm.com!
GM Customer Service is offline  
Sponsored Links
Advertisement
 
post #4 of 18 (permalink) Old 04-24-2013, 07:39 AM
Decepticon Extraordinaire
 
Lampoon's Avatar
 
Join Date: Sep 2005
Location: The Alamo
Posts: 5,346
    
is the canceling cam part of the clock spring?

MODS:
Crab Intakes CAB, MPD Ram Air hood, Custom exhaust,
WAMS High Performance Tune and a whole lot more....

My Progession
Lampoon is offline  
post #5 of 18 (permalink) Old 04-24-2013, 07:48 AM Thread Starter
Member
 
Join Date: Apr 2013
Posts: 53
 
Lampoon. I am pretty mechanically inclined. Cam part? I know when I turn right I hear the click that when I straightened my wheel turns off the signal. But when I turn left it I have to turn the wheel really far before I hear that click that will turn it off when straightened.
negru08 is offline  
post #6 of 18 (permalink) Old 04-24-2013, 08:04 AM
Decepticon Extraordinaire
 
Lampoon's Avatar
 
Join Date: Sep 2005
Location: The Alamo
Posts: 5,346
    
Im thinking the canceling cam is part of your clock spring. Your clock spring mechanism is under your steering wheel. If so it would be an easy fi. Ill ask a buddy of mine....

MODS:
Crab Intakes CAB, MPD Ram Air hood, Custom exhaust,
WAMS High Performance Tune and a whole lot more....

My Progession
Lampoon is offline  
post #7 of 18 (permalink) Old 04-24-2013, 08:35 AM Thread Starter
Member
 
Join Date: Apr 2013
Posts: 53
 
Alright thanks, so then buying a new turning signal lever not fix the issue?
negru08 is offline  
post #8 of 18 (permalink) Old 04-24-2013, 09:32 AM Thread Starter
Member
 
Join Date: Apr 2013
Posts: 53
 
Whole reason I ask is I dont wanna just buy something that wont really fix the issue you know?
negru08 is offline  
post #9 of 18 (permalink) Old 04-24-2013, 08:08 PM
OOBER SUPER MEMBER
 
CruisinG6's Avatar
 
Join Date: Jul 2009
Posts: 4,232
 
That's understandable. It fixed my problem and some other peoples problem. But I don't know for sure if it'll fix your issue, I'm not familiar with how the clock spring and cam is setup in this car, my switch was replaced both times under warranty.
CruisinG6 is offline  
post #10 of 18 (permalink) Old 04-25-2013, 07:28 AM
Decepticon Extraordinaire
 
Lampoon's Avatar
 
Join Date: Sep 2005
Location: The Alamo
Posts: 5,346
    
Ok....here is what he said:
Quote:
itll be the whole switch. the days of cancel cams are long gone lol
Hope that helps!

MODS:
Crab Intakes CAB, MPD Ram Air hood, Custom exhaust,
WAMS High Performance Tune and a whole lot more....

My Progession
Lampoon is offline  
post #11 of 18 (permalink) Old 04-25-2013, 08:09 AM Thread Starter
Member
 
Join Date: Apr 2013
Posts: 53
 
So then I am going to order that turn signal switch/lever for 30 off amazon
negru08 is offline  
post #12 of 18 (permalink) Old 04-25-2013, 10:03 AM Thread Starter
Member
 
Join Date: Apr 2013
Posts: 53
 
And thank you all for the help
negru08 is offline  
post #13 of 18 (permalink) Old 04-30-2013, 11:45 AM Thread Starter
Member
 
Join Date: Apr 2013
Posts: 53
 
So I got the part in the mail. Cant seem to find any forum on how to change it ...unless I just am doing it wrong. Has anyone done a "How To" on it?
negru08 is offline  
post #14 of 18 (permalink) Old 04-30-2013, 09:23 PM
Senior Member
 
mshinall's Avatar
 
Join Date: May 2010
Location: NoVA
Posts: 636
 
Turn signal switch is also pretty cheap from local auto parts joint. Easy to install. Just make sure to disconnect the battery for about ten minutes to make sure the air bag doesn't discharge.

Sent from AutoGuide.com App

2009 Techno Gray Metallic G6 GXP Sedan (3.6L Auto6 112K miles)
---
CRAB Intake Opt 3 w/FPU, Lloyds GXP floor mats, HIDs low 6000k 55w/fog 3000k 35w, LED DRLs behind lower grills, V3 Triton LED turn signal/reverse/brake, LED side markers/maps/dome/tag/trunk/high mount stop, 2 coats niteshades on tails, Tint 35% all around, Debadged (except arrows), PAC IPod and BT adapters, PowerStop D/S rotors and ceramic pads, Resonator repl w/24" cherry bomb, Racingline STB, Big 3 Upgrade, Optima Yellowtop D75/25, Blacked out arrows, chrome window trim and black dipped wheels, KYB struts and shocks, CM lowering springs, Cherry Bomb Vortex Crossflow muffler, 2.5" pipe from axle back, two 4" stainless double walled slant tips
...still working...
mshinall is offline  
post #15 of 18 (permalink) Old 04-30-2013, 09:32 PM
Member
 
DjParadise's Avatar
 
Join Date: Jan 2011
Location: Central New York
Posts: 32
 
I have the same issue. Same direction. Is there a TSB? I habent checkd yet

Sent from AutoGuide.com Free App
DjParadise is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > General Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Rear blinker issue 2006 G6 Timmer1313 Problems and Solutions 10 03-13-2013 11:56 AM
Blinker problem jtalvio Problems and Solutions 4 04-13-2010 02:51 PM
Blinker not working Xochitl Problems and Solutions 3 03-22-2010 05:50 PM
Issue with XM in Stock Monsoon System JR989 Car Audio, Video and Security 3 09-09-2009 08:02 AM
Blinker issue Lucius Problems and Solutions 8 03-15-2007 10:32 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome