Engine movement - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-21-2019, 12:19 AM Thread Starter
Junior Member
 
Join Date: Mar 2019
Posts: 2
 
Engine movement

2007 G6 GTP

My engine bounces around a lot, shakes the car back and forth. I did have a cylinder misfire that I fixed with coil pack replacement. I also had a P0017 code, referring to the timing chain being misaligned (could also mean faulty timing chain sensor). I assumed the bouncy engine was from this code, but the code disappeared randomly.

So I have no trouble codes now, check engine light is off, and I still have a bouncy engine.

Any suggestions mates?
Tunaboy is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-21-2019, 08:05 AM
Old far...er...tinkerer..
 
Join Date: Aug 2012
Location: Plano, Texas
Posts: 282
 
Quote:
Originally Posted by Tunaboy View Post
2007 G6 GTP

My engine bounces around a lot, shakes the car back and forth. I did have a cylinder misfire that I fixed with coil pack replacement. I also had a P0017 code, referring to the timing chain being misaligned (could also mean faulty timing chain sensor). I assumed the bouncy engine was from this code, but the code disappeared randomly.

So I have no trouble codes now, check engine light is off, and I still have a bouncy engine.

Any suggestions mates?
Sounds like you have one or more bad engine/transmission mounts. As I recall, on my 07 G6 with the 3.5, there is an engine mount on the passenger end down on the frame rail, and a damper above that. On the driver's end, there's a transmission mount on the frame rail, and 2 more mounts fore and aft of the engine near the bell housing. These last two control how much the engine rocks when you put it in gear or get on the gas. I'd bet both are bad. If you've been driving it this way for a while, the other mounts may be worn out as well.

Doug

.
plano_doug is offline  
post #3 of 3 (permalink) Old 04-13-2019, 02:00 PM Thread Starter
Junior Member
 
Join Date: Mar 2019
Posts: 2
 
Update:

I had the p0017 code return. I replaced both the crankshaft and camshaft position sensors. This change brought about new codes: p0340 and p0365. My next move would be to replace the wiring for these sensors.

Anybody have better advice other than wiring replacement?
Tunaboy is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > General Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 



Similar Threads
Thread Thread Starter Forum Replies Last Post
Idler/Pittman Arm Problem? Lateral movement while driving - No noise pkat1 Problems and Solutions 2 12-09-2014 06:56 AM
battery movement ryangski Powertrain Performance Modifications 7 08-20-2011 12:07 AM
Check Engine/Scv Vehicle Soon/Reduced Engine Pwr Indicators all on? insiminator Problems and Solutions 7 09-19-2010 08:21 AM
06 Gt Coupe - Drivers Seat Movement fbg6coupe Problems and Solutions 1 12-10-2008 11:12 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome