2010 Pontiac g6 HELP - Pontiac G6 Forum
 1Likes
  • 1 Post By rebel65
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 09-10-2019, 10:32 AM Thread Starter
Junior Member
 
Join Date: Sep 2019
Posts: 3
 
2010 Pontiac g6 HELP

Hello, I need help! I have a 2010 Pontiac g6 2.4 yesterday I went to leave from work, she started up and I got about 1 mile down the road and the engine just shut off, not a sputter just literally stopped. So I put it in park turned off the power and restarted it. It started back up then died and that's what it keeps doing. It starts everytime but wont stay running more then a few seconds. Some people are telling me it's the full pump but I can hear it come on before I turn it over. Some are saying the timing chain but i had that replaced about a year ago. Also i replaced the camshaft sensor about a month ago. I need help! Mom of 2 young kiddos and really need my car😔
Caycem24 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 09-10-2019, 10:35 AM Thread Starter
Junior Member
 
Join Date: Sep 2019
Posts: 3
 
Picture I took this morning after taking the covers off
Attached Thumbnails
Click image for larger version

Name:	20190910_085024_1568133265512.jpg
Views:	27
Size:	110.9 KB
ID:	14143  
Caycem24 is offline  
post #3 of 7 (permalink) Old 09-10-2019, 02:39 PM
Member
 
Join Date: Aug 2019
Location: USA, NY, Allegany Co.
Posts: 44
 
No Check engine light while driving before this happened? Did you just get fuel before this happened? There is a crank sensor also, and I've heard of these "acting up" by stalling without turning the CEL on or giving a code(gotten by diagnostic code reader /scanner).
rebel65 is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 09-10-2019, 03:26 PM
Senior Member
 
Join Date: Jan 2014
Location: RTP Area, NC
Posts: 336
 
Clogged catalytic converter? No exhaust, no run.
Just a guess from threads I have seen. I do not have a 2.4 so can offer little real insight. Hope you can find the problem and get it fixed
boomer is offline  
post #5 of 7 (permalink) Old 09-11-2019, 09:07 AM Thread Starter
Junior Member
 
Join Date: Sep 2019
Posts: 3
 
My check engine light has stayed on sense I changed out the crank shaft sensor. I took some stuff apart yesterday to look at cheaper possible reasons. I have oil on 2 of my spark plugs, and some build up and dirt in the fuel injectors. I put some fuel injector cleaner in it but idk if its pushing threw because it wont stay running
Caycem24 is offline  
post #6 of 7 (permalink) Old 09-11-2019, 02:43 PM
Member
 
Join Date: Aug 2019
Location: USA, NY, Allegany Co.
Posts: 44
 
Quote:
Originally Posted by Caycem24 View Post
My check engine light has stayed on sense I changed out the crank shaft sensor. I took some stuff apart yesterday to look at cheaper possible reasons. I have oil on 2 of my spark plugs, and some build up and dirt in the fuel injectors. I put some fuel injector cleaner in it but idk if its pushing threw because it wont stay running
Would be wise to get ahold of a cheap code scanner that plugs into the connector under the steering wheel. IF light has been on since doing the crank sensor there is at least 1 code in the computer to help figure out what's going on ... and possibly more since the car has really started acting up.

Could even be a problem with the MAF sensor at the air cleaner assembly or the throttle body.

And just how long have you let things "slide" until it now won't stay running? Your first post said CAM sensor was replaced, now you say CRANK sensor was done a month ago, both work together for proper operation...Try and get a code scan done as I posted...it will help in figuring things out.
boomer likes this.

Last edited by rebel65; 09-11-2019 at 03:07 PM.
rebel65 is offline  
post #7 of 7 (permalink) Old 09-15-2019, 05:37 AM
Senior Member
 
Join Date: Oct 2018
Location: Canada
Posts: 131
 
Garage
Read my thread"car dies after filling with fuel". I know they are expensive but I would say the fuel pump after my experience. My code reader had multiples codes in it noon of which lead me directly to the fuel pump. The car is already ten years Old if you go back to the build date.
Convertme is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > General Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome