Help! HID lights - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 03-10-2012, 12:11 PM Thread Starter
Senior Member
 
G6inCanada's Avatar
 
Join Date: Jan 2011
Posts: 102
 
Help! HID lights

So iv had my HID's for a a few months now. I have 6000 k's highs and lows, an i used the relay harness. One of my fuse holders (low beams) that was sent to me didnt close right so the fuse always kinda had a loose connection. I just had to push it in every once and a while and they would work awhile. They were working good for like a month straight and then they stopped. I opened the fuse holder up and the fuse was melted right into the fuse holder. I know this is an easy fix to just put a new inline fuse and holder in, but i just dont understand why this happened and dont wanna waste my time if its just gunna happen again. My highs still work so this is bareable for awhile.

Hammerhead Spoiler, CRAB intake, Resonator delete, Custom Magnaflow exhaust set up, Racing line front mount strut bar, Racingline MMI's, Red streetglow neon, WMAS 91 tune, 6000k HID's High's and Lows, Black and red outlined floor matts!
G6inCanada is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 03-10-2012, 04:28 PM
SUPER MEMBER
 
Dmanj's Avatar
 
Join Date: May 2010
Location: Canada
Posts: 1,420
 
Could just be that there was more current than its rated for passing through it for a long period of time.
Dmanj is offline  
post #3 of 7 (permalink) Old 03-11-2012, 02:22 PM
OOBER SUPER MEMBER
 
CruisinG6's Avatar
 
Join Date: Jul 2009
Posts: 4,232
 
Could also be because the fuse was loose. If it's sitting loose enough and it was just a barely making contact then it would work, But trying to pull all that current through one little spot on the connector can make get really hot but not fail. Happened on my amp when I replaced the broken fuse holder with two spade connectors, Melted them all together, Put an in-line fuse holder in and boom, all works well
CruisinG6 is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 03-28-2012, 03:11 PM Thread Starter
Senior Member
 
G6inCanada's Avatar
 
Join Date: Jan 2011
Posts: 102
 
Just an update, i replaced the fuse holder with a 99.9 percent water proof one and i have not had a problem since. I should have just done that at the start when i first noticed the fuse in the holder was loose. Alls good now tho!

Hammerhead Spoiler, CRAB intake, Resonator delete, Custom Magnaflow exhaust set up, Racing line front mount strut bar, Racingline MMI's, Red streetglow neon, WMAS 91 tune, 6000k HID's High's and Lows, Black and red outlined floor matts!
G6inCanada is offline  
post #5 of 7 (permalink) Old 03-28-2012, 05:40 PM
OOBER SUPER MEMBER
 
CruisinG6's Avatar
 
Join Date: Jul 2009
Posts: 4,232
 
Good to hear!
CruisinG6 is offline  
post #6 of 7 (permalink) Old 06-10-2012, 11:47 PM
Senior Member
 
Kirby89's Avatar
 
Join Date: Nov 2009
Location: Wisconsin
Age: 30
Posts: 147
 
Does your HIDs take a few seconds to fully light up?!

Mods Added: Seat Covers, Low Beam Bulb Upgrade

Mods To Come: Window Tint, Rims, AIT Body Kit, Projector Headlights w/ HIDs, and some window stickers
Kirby89 is offline  
post #7 of 7 (permalink) Old 06-11-2012, 05:31 AM
SUPER MEMBER
 
Dmanj's Avatar
 
Join Date: May 2010
Location: Canada
Posts: 1,420
 
All hids take a few seconds warm up
Dmanj is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Appearance Modifications and Lighting

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Lights lights all kinds of lights!!! Lol 2pimp4u Appearance Modifications and Lighting 5 04-02-2011 09:03 AM
2005 G6 Rear Turn Lights / Brake Lights Don't Work G6Ontario Problems and Solutions 11 01-05-2010 03:38 PM
Head lights and tail lights tinting problems. attackofthegirt Appearance Modifications and Lighting 6 06-18-2009 10:04 AM
Why do my tail lights and dashboard lights only go on when I brake? bodykits Problems and Solutions 1 05-16-2009 10:21 AM
Dome Lights and Dash Lights Tate_06_Red_G6 Appearance Modifications and Lighting 1 09-06-2008 05:31 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome