Issues with HIDs - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 09-28-2013, 09:13 AM Thread Starter
Member
 
Join Date: Apr 2013
Location: Iowa
Posts: 37
 
Issues with HIDs

Have a set of HIDs on my 06. I've had HIDs on other cars, so I know how they operate and wire up. They worked fine for awhile, now my driver side won't come on. Checked the fuse and it was blown. Replaced it with higher and won't blow, but still won't come on. Do I need a relay harness? I thought those were only needed of not plug and play?

Sent from AutoGuide.com Free App
Hendersonfan is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 09-28-2013, 11:03 AM
SUPER MEMBER
 
Dmanj's Avatar
 
Join Date: May 2010
Location: Canada
Posts: 1,420
 
First of all, you should never replace a fuse with one of a higher value, unless you know the wiring can handle more current. Try taking the ballast from the passenger side and see if it will work on the drivers side. If it does, your ballast is likely shot. The relay harness is used to draw power directly off the battery. It ensures there is adequate power for start up and since the DRL circuit runs on less power, it provides the proper power to keep the lights running.
Dmanj is offline  
post #3 of 6 (permalink) Old 09-28-2013, 11:42 AM Thread Starter
Member
 
Join Date: Apr 2013
Location: Iowa
Posts: 37
 
It's raining right now, so it will have to wait. I do know both bulbs work as I have put each on the passenger side ballast and it works. I'll swap the other ballast to see if it works on the passenger side wiring.

Sent from AutoGuide.com Free App
Hendersonfan is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 09-28-2013, 11:49 AM Thread Starter
Member
 
Join Date: Apr 2013
Location: Iowa
Posts: 37
 
And I only swapped the fuse temporary to see if it would blow. Figured that would be a short? It did work and then just stopped. I'll post my result tomorrow or later if it stops raining.

Sent from AutoGuide.com Free App
Hendersonfan is offline  
post #5 of 6 (permalink) Old 10-01-2013, 02:37 AM
Senior Member
 
USMC0311's Avatar
 
Join Date: Dec 2011
Location: Chicago, Illinois
Posts: 130
 
You need a relay harness. I had the same issue with mine. My regular lights, high beams are 6K 55W HIDs and my fogs are 6K 35W HIDs. IF you run a 55W kit you definitely need a relay harness. Most 35W kits don't need them. Also depending how you lay out your wiring, excessive heat can cause the fuse to burn out...I was having trouble with mine, kept flickering or just shutting off, then i noticed the fuse was melted. Where i had it located, it was too close to the engine, and the heat caused it to melt. I layed out my wiring it neatly and away from anything that will cause obstructions/heat. Hope this helps with your situation.
USMC0311 is offline  
post #6 of 6 (permalink) Old 10-02-2013, 10:14 AM
Junior Member
 
Join Date: Oct 2013
Posts: 5
 
Currently I am also facing the same problem. I read out interesting and informative ideas. It is dead easy and pretty difficult to go wrong. This will be helpful for me. thanks everyone...

Vehicle Modifications

>>>>>>>>>>>>
<<<<Adrien>>>>
<<<<<<<<<<<<

Last edited by Adrien8100; 10-05-2013 at 08:36 AM.
Adrien8100 is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Appearance Modifications and Lighting

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
HIDs USMC0311 G6 Buyer's Guide/General Information 48 01-26-2012 01:34 PM
Putting in HIDS Stridex Appearance Modifications and Lighting 6 10-25-2011 01:18 PM
Got my 5K HIDs in gotzaG6 Appearance Modifications and Lighting 21 07-11-2011 07:05 AM
hids with relay ???'s Jstn2661 Appearance Modifications and Lighting 10 01-22-2011 01:54 PM
Flickering HIDS herter92 Problems and Solutions 5 12-10-2010 06:04 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome