Mids aren't working only tweeters in the front doors? - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 12-29-2016, 09:57 PM Thread Starter
Junior Member
 
Join Date: Dec 2016
Posts: 1
 
Question Mids aren't working only tweeters in the front doors?

Hi everyone, I just made an account for this site because im having trouble. I have an 07 G6 GT Sedan, non monsoon. And I was having a problem where only the front two tweeters were playing music. No mids, and rear speakers are playing just fine, so only the front door speakers aren't playing.

So i figure new speakers should do it, so I buy some rockford 6.5" 3 Ways. I also purchased these ( Metra Part # 72-4568 | GM wire harness | Metra Online ) wiring harness to just plug and play. So i get the door panel off and i plug it in and wire it to the speaker, and go to play music, and of course only music is coming from the tweeter part of the speaker, no mids.

Has anyone else had this problem? Am i missing something? Any help would be appreciated! Thanks
tkoerner20 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 12-30-2016, 05:50 AM
Old far...er...tinkerer..
 
Join Date: Aug 2012
Location: Plano, Texas
Posts: 297
 
Quote:
Originally Posted by tkoerner20 View Post
Hi everyone, I just made an account for this site because im having trouble. I have an 07 G6 GT Sedan, non monsoon. And I was having a problem where only the front two tweeters were playing music. No mids, and rear speakers are playing just fine, so only the front door speakers aren't playing.

So i figure new speakers should do it, so I buy some rockford 6.5" 3 Ways. I also purchased these ( Metra Part # 72-4568 | GM wire harness | Metra Online ) wiring harness to just plug and play. So i get the door panel off and i plug it in and wire it to the speaker, and go to play music, and of course only music is coming from the tweeter part of the speaker, no mids.

Has anyone else had this problem? Am i missing something? Any help would be appreciated! Thanks
My best guess is broken wires in the door jambs. That will allow the tweeters to work but stop the mids because the wires split upstream of the door jambs.

The wires in the jambs fail due to the doors opening and closing resulting in broken and chafed wires.

With the door open, pinch the rubber boot at one end and then pull it from the door (or jamb, whichever end you're pinching). Then inspect the wires for breaks. The insulation may still be holding the wire together, but the break will be evident - the wire will be flimsy at the break.

If you don't see any breaks on the open end of the boot, then go to the other end, pull it back and inspect there.

On the driver's side, look for gray and tan wires to inspect. On the passenger side, light green and dark green.

The one odd thing about this is that the breaks primarily occur on the driver's door since it gets opened and closed the most thereby flexing those wires the most. So having a broken wire on the passenger side is unusual.

Still, if the tweeters are working, that means the radio is working, which means the failure is further downstream, most likely in the wiring. So inspecting the wiring is the next step.

BTW, these cars are known for failing door speakers. I had to replace both of mine because they had either stopped altogether or were intermittent. So be sure you had everything hooked up properly when you tested the new speakers, just in case it's not the wiring. For example, be sure the harness connectors are fully seated on both ends.

HTH.

Doug

.

Last edited by plano_doug; 10-28-2017 at 07:10 AM.
plano_doug is online now  
post #3 of 4 (permalink) Old 10-27-2017, 07:46 AM
Junior Member
 
Join Date: Oct 2017
Posts: 1
 
I have the same problem with the door speakers in the front. Will be checking the wires. I bought a set of speakers but haven't tried them yet.

I had an earlier used Pontiac Sunbird where the electric windows in 3 of the doors wouldn't work. It turned out to be the wires broken where they go into the doors. They all broke within a week of each other. That car seemed to be a "flood car" because so many things went wrong. My wife thought it was haunted. Every time we drove past a Burger King, the wipers would make one swipe. A seat spring broke one day and poked my wife's leg, and tore her dress. The motor kept shutting when you would be entering an Interstate just as you were merging in. The dealer changed 2 Turbochargers, 2 heads, one short block, because the head gasket would blow out causing so much smoke that you couldn't see the car. The dealer refused to work on it anymore, so I sued them. They had to buy the car back for what I paid, pay me back for some repairs I had done, and paid my lawyer fees. I owned the car for 3 years and drove it for about 4 months. On the last trip to the dealer, they kept it for the whole winter, covered up by snow in the back lot, "waiting for parts". When I picked it up after having a "new motor", I drove it out of the lot and the car shut off. I went back in and told them, and they said that the 12,000 mile warranty was done so any repairs from then on would be charged. While covered in snow in the back lot, the car had accumulated 8,000 miles. I had proof because right before I took it in I bought new tires and the store had written the mileage on the slip.

They are now a Chevrolet Dealer.
Jimbo is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 03-14-2018, 06:56 AM
Junior Member
 
Join Date: Mar 2018
Posts: 1
 
I also have the same problem just a tweeters aren't working the mids or the back aren't working either I was wondering did it have anything to do with the wires in the door jamb the other day my buddy was fixing my brakes for me and my lights weren't working so I was playing with the door jam and different things started going on my headlights don't work so I have to drive with my brights on don't work so I have to drive with my brights on
Shaun Cory Sprinkle is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Car Audio, Video and Security

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
cruise not working, doors not locking/unlocking automatically quiksilver2101 Problems and Solutions 0 01-30-2014 04:29 PM
Hooking up front mids and tweeters Gee-six Car Audio, Video and Security 0 07-24-2009 09:27 PM
Front Tweeters almonteb Car Audio, Video and Security 1 06-24-2009 01:16 PM
No mids or lows jkress8 Car Audio, Video and Security 3 08-25-2008 08:24 AM
Front doors make popping noise... HELP SPRCUTE Problems and Solutions 6 06-25-2008 10:44 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome