'06 Radio Display Problem - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 12-21-2009, 02:53 PM Thread Starter
Junior Member
 
Join Date: Dec 2009
Posts: 19
 
'06 Radio Display Problem

I tried searching for similar problems to no avail so I was hoping that somebody could help me out. Recently the battery died on my '06 G6 and needed to be replaced. I put a new battery in but now the time and temp on the radio display disappear about 15 seconds after you turn the car on. All of the radio functions still work and hitting the display button will bring it back for 15 seconds but then it goes blank again. The only item that doesnít shut off is what source the radio is in (ex FM1). Even more odd is when you turn the car off it magically reappears until you open the driverís door. Any assistance with this would be greatly appreciated.
je1279 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 12-21-2009, 05:35 PM Thread Starter
Junior Member
 
Join Date: Dec 2009
Posts: 19
 
I forgot to mention that the backlighting is working properly and all of the buttons are lit. Also, I realized that the time and temp only appear for about 5 seconds rather than the 15 that I originally said.
je1279 is offline  
post #3 of 4 (permalink) Old 02-04-2011, 05:25 PM
Junior Member
 
Join Date: Feb 2011
Posts: 1
 
same problem

Hi, I was wondering if you figured out what was going wrong with your display. I am having the same problem after replacing the battery. All my other displays show except the clock/temp display. Did you find a solution?
mashinka is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 02-07-2011, 05:08 PM Thread Starter
Junior Member
 
Join Date: Dec 2009
Posts: 19
 
A few weeks after I replaced the battery it just started working again. Not sure what caused it or what made it start working again but its been fine ever since.
je1279 is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > Car Audio, Video and Security

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Temperature display on radio nyislander27 Problems and Solutions 1 03-30-2009 02:25 PM
Problem with 05 G6 radio mkopmann Car Audio, Video and Security 3 03-19-2009 08:16 PM
Radio Install Problem gribinvon Car Audio, Video and Security 1 07-12-2008 06:19 PM
Radio display noodles Car Audio, Video and Security 2 05-20-2008 11:25 AM
Question about my XM radio display woodyronchar Car Audio, Video and Security 2 08-08-2005 08:32 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome